locked
How to prevent user double booking use Exchange 2007 resource mailbox?

    Question

  •  

    How to prevent user double booking resources use Exchange 2007 resource mailbox?

     

    Thursday, February 15, 2007 5:10 AM

All replies

  • Enable resource mailbox account and login by use OWA,in the option select resource config by default it's enable prevent conflict resource booking.

    Friday, February 16, 2007 3:01 AM
  • Hi guys,

     

    Sorry for resurrecting an old thread, but I wanted to ask a question related to this.

     

    We're a few weeks into a fresh install of Exchange 2007 with Outlook 2007, and I have set up a bunch of meeting rooms, making sure they're automatically accepting/declining meeting invitations etc.

     

    For the first week or so, if a user tried to schedule a meeting in a room that was already booked for that meeting time, Outlook would prompt them when they hit send, with this message:

     

    <resource name> is already booked for the specified time. You must use another time or find another resource.

     

    This was great, because let's face it: If the room was already booked then all it can do is decline your invitation.

     

    As of late last week, however, our users no longer get this warning. They send their invitations, and a minute later the room declines, meaning that the meeting organizer has to reschedule and send update notices to all invitees.

     

    What could we have done to stop this warning message from showing? It has to have been something server-side because it's affecting everybody. From memory, the message didn't have a "don't show this message again" checkbox ... and even if it had, not everybody would have checked it!

     

    If anyone could point us in the right direction I'd be eternally grateful! Smile

     

    Cheers,

    Matt Hamilton

    Thursday, November 1, 2007 3:07 AM
  •  

    Hi Matt,

     

    we'd also love to see some popup that alarms the user that a room has already been booked. Did you ever find a solution for this?

     

    Thanks

    Tuesday, April 1, 2008 3:11 PM
  • Hi Bill,

     

    Yes and no - I should have posted a follow up here.

     

    Shortly after the "already booked" message stopped appearing, I asked our IT guys what changed (I'm more of a developer and haven't had anything to do with the Exchange rollout) and one of the things their consultant did was to disable Public Folders.

     

    Strangely enough, re-enabling Public Folders brought the message back - so now users are (most of the time) warned if they're trying to double-book a room before they can send the invitation.

     

    I say "most of the time" because users every so often are able to double-book rooms, and we're still not sure why. Sad

     

    Cheers,

    Matt

    Tuesday, April 1, 2008 9:24 PM
  • Hi there,

     

    here are my observations so far:

     

    To enable the popup you have to enable the resource account, log in, start Outlook and connect to Exchange as the resource, go to Tools, Options, Calendar Options, Resource Scheduling and check the first two options ("Automatically accept meeting requests and process cancellations" and "Automatically decline conflicting meeting requests"). Disable the resource account again.

     

    The popup will show up under the following condition:

    -Create the meeting and book the resource with Outlook (2003 and 2007) AND

    -Book it as a resource (and not as "required")

     

    The popup will NOT show up under the following conditions:

    -Create the meeting with Outlook Web Access OR

    -Book the resource as "Required" (which is possible in Outlook 2003/2007, not in OWA)

     

    The popup will show up but the meeting is being created anyway (worst case, I'd say):

    -Create the meeting with Outlook 2003. The popup shows up, you press ok and then close the meeting. When closing, you'll have to say "No" when asked "would you like to send it". The meeting is still in your calendar, not in the resource's calendar though.

    This behaviour does not seem to happen with Outlook 2007.

     

    At least we were not able to double book so far but we've only been testing. If the popup does not show up the requestor at least gets a "declined" email which is better than nothing but of course it might make him look pretty stupid.

     

    So one of the last mysteries here would be how to change the resource scheduling settings mentioned above without logging in as the resource. I assume there must be some way of doing this in power shell, mdbvu32, pfdav or whatever.

    But hey, I also thought that there must be a way to change the out of office subject Smile

     

    Thanks

     

    Friday, April 4, 2008 1:21 PM
  •  mabster wrote:

    Shortly after the "already booked" message stopped appearing, I asked our IT guys what changed (I'm more of a developer and haven't had anything to do with the Exchange rollout) and one of the things their consultant did was to disable Public Folders.

     

    Cheers,

    Matt

     

    I'm the IT Guy that Mabster was refering to. We found the issue where most people were double booking because the user failed to invite the room to the meeting.

     

    The problem that we have now is that two user can sometimes correctly book the same room resource by inviting it using the rooms button but somehow will still double book the room. The last instance of this happened when the second meeting was booked in the same room at the same time 2 days later !! both users exist on the same mailserver as well.

     

    Cheers,

    Aaron

    Tuesday, August 5, 2008 5:16 AM
  • I would confirm that the room mailboxes are configured to not allow conflicts.

    get-mailboxcalendarsettings -identity XXXXX | fl

    Confirm that AllowConflicts is set to false.
    Thursday, August 7, 2008 1:47 PM
  • thanks for your message djtodd.

     

    i have confirmed that all our room mailbox settings are set to false

    Wednesday, August 13, 2008 1:42 AM
  • how do you connect to exchange as the resource?
    Tuesday, January 5, 2010 1:28 AM
  • 1. Log onto OWA as yourself or another Exchange account.
    2. Once logged on, select the arrow next to your name on the top right toolbar.
    3. It will open a "Open another mailbox" option.
    4. Type the alias of the resource and click OK.
    5. It will open an OWA session to the resource.
    6. Then you can click Options in top right and you'll have access to the resource options on the right menu.
    Wednesday, January 13, 2010 7:41 PM
  • In yet another bizarre twist of this problem...

    1.  User schedules meeting.

    2.  Second users schedules meeting for same room and time - get's the "training room is already booked..." message - Yea.

    3.  Third user schedules meeting for same room and time and is able to schedule the meeting with no popup, etc.

    I've been through the config using OWA, and the EMS.

    This is Exchange 2007 Version: 08.02.0176.002 on Server 2003 R2 x64

    Outlook clients are a mixture of XP and WIN7.

    Thoughts?

    Friday, February 4, 2011 8:49 PM
  • I'm having this issue too. Hoping someone has sorted it out...
    Tuesday, February 8, 2011 9:54 PM
  •  

    @How to prevent user double booking use Exchange 2007 resource mailbox?

    Double bookings can only be prevented if for every scheduled meeting invite, the related resource mailbox is also invited. Plus from Outlook 2003/2007 clients this needs to be made sure that in the Location field, to-be-booked-room is selected from Address Book and not manually entered.

     

     


    Performance is your reality - Forget everything else.
    Monday, March 21, 2011 9:56 PM
  •  

    @How to get Pop-up for already booked meeting resource???

     When "Get-MailboxCalendarSettings -Identity resource.room | fl" is executed from Power Shell,

    • if the 'AutomateProcessing' feature is set to AutoUpdate - meeting resource availability will be checked prior to be confirmed for final booking and a prompt saying 'The resource is already booked' will be displayed in case unavailable.
    • if the 'AutomateProcessing' feature is set to Auto-Accept - meeting request will be checked after it (the request) is submitted and will be checked later on. In case of unavailability a Decline message will be sent to the booking requester. In which a new booking need to be sent for the same invite.

     


    Performance is your reality - Forget everything else.
    Monday, March 21, 2011 10:03 PM
  • Having same/similar issue.  Exchange 2007 sp3; mixture 2007 and 2003 Outlook users.  Have had a number of resource room mailboxes set up and working properly for several years.  All of a sudden, one of them has started allowing double-booking - no message, no rejection - two overlapping meetings.

    Have been through the OWA settings check process, and settings are correct, and same as other rooms that still work properly.  Not exactly sure what day/time the problem started - could it be daylight savings time related?

    AutomateProcessing                  : AutoAccept
    AllowConflicts                      : False
    BookingWindowInDays                 : 180
    MaximumDurationInMinutes            : 1440
    AllowRecurringMeetings              : True
    EnforceSchedulingHorizon            : True
    ScheduleOnlyDuringWorkHours         : False
    ConflictPercentageAllowed           : 0
    MaximumConflictInstances            : 0
    ForwardRequestsToDelegates          : True
    DeleteAttachments                   : True
    DeleteComments                      : True
    RemovePrivateProperty               : True
    DeleteSubject                       : True
    DisableReminders                    : True
    AddOrganizerToSubject               : True
    DeleteNonCalendarItems              : True
    TentativePendingApproval            : True
    EnableResponseDetails               : True
    OrganizerInfo                       : True
    ResourceDelegates                   : {}
    RequestOutOfPolicy                  :
    AllRequestOutOfPolicy               : False
    BookInPolicy                        :
    AllBookInPolicy                     : True
    RequestInPolicy                     :
    AllRequestInPolicy                  : False
    AddAdditionalResponse               : False
    AdditionalResponse                  :
    RemoveOldMeetingMessages            : True
    AddNewRequestsTentatively           : True
    ProcessExternalMeetingMessages      : False
    DefaultReminderTime                 : 15
    RemoveForwardedMeetingNotifications : False

    Friday, March 25, 2011 6:09 PM
  • I am experiencing the same issue... a user (in this case, MYSELF) is attempting to book a previously booked room, and the system is allowing it anyway without any warning.  Exchange 2007 SP1, Outlook 2007.  Also having the issue with another user using Outlook 2003.
    Monday, April 4, 2011 3:37 PM
  • Hey,

    Try running this from Exchange Management Shell:

    Set-MailboxCalendarSettings -Identity <ConferenceRoomAlias> -AutomateProcessing AutoAccept

    That fixed it for me.

    Mike

    Monday, April 4, 2011 6:46 PM
  • It seems to be working today... I tried that command you specified, but it didn't seem to change anything yesterday, but now today it's working as it should.  Might have needed to process on the server side???  Thanks.
    Tuesday, April 5, 2011 5:36 PM
  • Other users have reported fixing the double booking after running it a second time even though it's already set to autoaccept.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Wednesday, April 6, 2011 12:08 AM
  • After you have created the room resource then you need to apply the settings for it to so that you can control it for your needs. I created about 250 or more of these from a previous migration of Notes to Exchange.

    Here is the powershell command I used that has worked for us: (you may want to adjust a few things for your environment such BookingWindowInDays to 365)

    Set-MailboxCalendarSettings -identity FL-3650-ConferenceRoom -BookingWindowInDays 500 -automateprocessing:autoaccept -DeleteSubject $False -AddOrganizerToSubject $True -AllowConflicts 0 -ConflictPercentageAllowed 100 -MaximumConflictInstances 500 -RemovePrivateProperty $False -MaximumDurationinMinutes 1380

    Here is an additional powershell command you may want to have added to your rooms:

    Set-Mailbox -identity "FL-3650-ConferenceRoom" -ResourceCapacity 6

    We a huge userbase in my company I know what your going with setting up these rooms so if you have any other questions about this specific issue let me know.


    Take Care, Vytor

    • Proposed as answer by Vytor Thursday, April 7, 2011 4:04 PM
    Thursday, April 7, 2011 4:02 PM
  • As suggested above by Mike, I ran this command twice consecutively from the Exchange Management Shell and it resolved the issue for me.

     

    Set-MailboxCalendarSettings -Identity <ConferenceRoomAlias> -AutomateProcessing AutoAccept

    Thank you

    • Proposed as answer by inthewindows Tuesday, May 3, 2011 9:00 PM
    Tuesday, May 3, 2011 8:11 PM
  • Hi

    in my case it was Auto Accept only for the room mailbox but it is not working. Later i found out that OOF was not working after correcting that problem .. i started getting Popup successfully.

    so check the OOF feature is working or not and resolve the issue.

     

     

     

     

    • Proposed as answer by SPV4645 Monday, January 16, 2012 7:36 AM
    Monday, January 16, 2012 7:36 AM
  • Hi All,

    sorry to resurrect an old thread...again.

    We are having a similar problem:

    We have a room resource account for our conference room.  We want a conflict pop-up to appear at the moment someone tries to send an invitation that includes the resource as an attendee when the resource is already booked for that time.  What happens now is that no pop-up appears and instead the user gets a "invitation declined' from the room resource account a few seconds later.  This is not acceptable  to our management, who wants the pop ups.  We had another room account that had pop-ups working but we deleted the account while ago.

    What I did so far is I confirmed that the resource account is set to "automatically accept invitation requests" enabled, and "allow double booking" is unchecked or =false when examining the account with the exchange management shell.  After applying those settings in OWA I disabled the resource account again.  Our public folders are active.   The out-of-office attendant is working fine.   Also in one test after adding the resource account as an attendee, I tried changing the attendee type from "Resource" to "Required Attendee" before sending with the same result: no pop-up.  So I can't tell from the potential solutions in this thread what else we can do to get the pop-ups to reappear.  Any assistance is much appreciated.

    We are running Exchange 2007 standard SP3 on Windows Server 2008 standard with Office 2007 SBE running on Windows 7 Professional.

    thanks

    Brian




    • Edited by Brian Vandemark Wednesday, November 21, 2012 7:23 PM even more info
    Wednesday, November 21, 2012 6:24 PM
  • Hello again

    I found the answer to my question in the comments on this article

    http://blogs.technet.com/b/exchange/archive/2009/02/26/3407028.aspx

    To produce the pop-ups that warn and prevent a conflicting meeting invitation from going out, an Outlook 2007 client must be configured for "Direct Booking" of the Conference Room Resource User.  This is done by opening the mailbox Conference Room Resource User with Outlook  (2007 in my case), Configuring Meeting Request settings, and assigning permissions to other human users for accessing the Resource User's Calendar.  When these settings and permissions are in a place, Outlook 2007 make a direct connection to the Resource User's mailbox, and that then enables pop-up functionality in Outlook.  A conflicting appointment time will prevent the user from being able to send out the appointment, generating a pop-up the moment they click "send"  !  YAY !

    Here is a simple doc on setting up "Direct Booking"

    http://support.microsoft.com/kb/291616

    Friday, November 23, 2012 6:31 PM