none
list with incoming email --> workflow does not start RRS feed

  • Question

  • hey,

    i have a discussion board with "incoming emails" enabled;

    i added also a workflow which starts, when an item is created;

     

    iv created an item manuelly and the workflow fired

     

    but if an item is created from the system, when an email arrived, the workflow doesnt fire

    e.g. if im trying to debug, nothing happens and so on

     

    the strange thing is: in the workflow coloumn it shows me, that the workflow is "In Progress"

     

    but nothing happens

     

    suggestions would be really great

    Friday, July 23, 2010 10:07 AM

Answers

  • iv tested this with sp designer now

     

    and after stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes it works

     

    but why it doesnt work with visual studio???

     

    any ideas?

    • Marked as answer by chrisshizzle2 Friday, July 23, 2010 12:32 PM
    Friday, July 23, 2010 12:02 PM

All replies

  • there was the same problem for sharepoint 2007 and sp1

     

    http://support.microsoft.com/kb/953749/

    http://support.microsoft.com/kb/953289/

     

    shouldnt this be fixed in sp 2010 already?

     

    so i only have to type that: Stsadm -o Setproperty - Pn Declarativeworkflowautostartonemailenabled - BW true

    but it seems, that this command doesnt exist in sp 2010 ??

    Friday, July 23, 2010 10:59 AM
  • ok, this is the correct command for 2010 stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes it told me: Operation completed successfully but my workflow (created with visual studio) still doesnt fire.......# what else i can do?
    Friday, July 23, 2010 11:33 AM
  • iv tested this with sp designer now

     

    and after stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes it works

     

    but why it doesnt work with visual studio???

     

    any ideas?

    • Marked as answer by chrisshizzle2 Friday, July 23, 2010 12:32 PM
    Friday, July 23, 2010 12:02 PM