none
Sharepoint ask for username and password for Central Admin access and site access

    Question

  • Hello Community

        When I click IE and type in the url to the Sharepoint installation, Sharepoint prompts for:

        username: someuser
        password: somepassword

        After that you see Sharepoint's "Central Administration".

        Then after that if you type in the url to a site it prompts for:

        username: someuser
        password: somepassword

        "access denied"

        In order to access the site you have to enter:

        username: domainname\someuser
        password: somepassword

        As you can see to access the site you have to add the domain name to the same username.

        After entering the url, there should be no need to enter any username and
    password.

        I might add that when logging on you can log into the Sharepoint member server that is  connected to the domain controller running SQL Server on the farm, or on that same Sharepoint member server instead of logging onto that Sharepoint member server directly,  you can select from the dropdownbox and log into the domain controller running SQL server in which that Sharepoint member server is one of the servers that make up the farm.

        In this problem I am typing the url on the Sharepoint member server that is connected to the domain controller running SQL Server in the farm.

        how can I prevent Sharepoint from prompting for username and password when typing in the url to access the Central Administration and how can I prevent Sharepoint from prompting for domainname\username and password when the url is entered for Sharepoint to access the sharepoint site?

        Thank you
        Shabeaut

    Saturday, October 22, 2011 9:43 PM

Answers

  • Let us say you browse the central admin using the following link:

     

    http://sps2010:90

     

    Then you must add http://sps2010 without the port as I mentioned in the first reply.


    http://SharePoint4Arab.blogspot.com
    • Marked as answer by Shabeaut Monday, October 24, 2011 1:21 PM
    Monday, October 24, 2011 4:16 AM

All replies

  • Hi,

    You need to disable loopbackcheck:

    Click Start, click Run, type regedit, and then click OK
    In Registry Editor, locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Right-click Lsa, point to New, and then click DWORD Value. (In Win 2008, its DWORD 32bit)
    Type DisableLoopbackCheck, and then press ENTER.
    Right-click DisableLoopbackCheck, and then click Modify.
    In the Value data box, type 1 and then click OK.
    Quit Registry Editor.
    You may need to restart your server.

    You need also to add your URL to Local Intranet zone in IE. Enable also Integrated Windows authentication under advanced tab in IE.

     


    Regards
    Henrik A. Halmstrand
    sharepointrevealed.com
    getspconfig.codeplex.com
    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.
    Saturday, October 22, 2011 10:26 PM
  • Kindly follow the following steps:

    1. Open IE (Microsoft IE).
    2. Internet Options.
    3. Security Tap.
    4. Select "Local intranet".
    5. Click Sites.
    6. Click Advanced
    7. write http://servername.
    8. Click Add.

    Done.


    http://SharePoint4Arab.blogspot.com
    Sunday, October 23, 2011 4:52 AM
  • Hello Enjreny

        Central Administration uses its default port number.

        wss\virtualdirectories uses it default port number.

        This web application and this site I created in this example uses port 80.   

        I am going to follow the steps you recommend but which server's servername and
    what port number should I use?

        Thank you
        Shabeaut   

    Sunday, October 23, 2011 9:17 PM
  • Hi,

     

    I agree with Henrik A. Halmstrand and Enjreny.

     

    In addition, you need to enable automatically login on Internet Explorer if you use NTLM authentication.

     

    For the full conditions must be met for Internet Explorer to automatically authenticate a user's logon and password and maintain security, see

     

    http://social.technet.microsoft.com/Forums/nl/sharepoint2010setup/thread/0de7b015-3a76-47b5-8dd0-bb0cdc20f733

     

    Finally, you should use different port numbers for Central Admin and a web application for a specific site collection. The server’s name is the server who render the site content, for example, WFE if you have.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Monday, October 24, 2011 3:16 AM
  • Let us say you browse the central admin using the following link:

     

    http://sps2010:90

     

    Then you must add http://sps2010 without the port as I mentioned in the first reply.


    http://SharePoint4Arab.blogspot.com
    • Marked as answer by Shabeaut Monday, October 24, 2011 1:21 PM
    Monday, October 24, 2011 4:16 AM
  • This can help you ot :

    http://sharepointshah.blogspot.in/2012/09/central-administration-asks-for.html


    Viral Shah http://sharepointshah.blogspot.com

    Friday, September 07, 2012 4:56 AM