none
New Website in Sharepoint Portal 2007 gives page cannot be displayed

    Question

  • Hello Everyone,


    I have recently created a new Sharepoint test website. When I type the site URL in the browser it is displaying "page cannot be displayed".
    I have created a new web application called MyTest.

    So the webapplication url that has got created is http://mytest:80


    In this application I have created a new website collection called portal team.

     

    So the new URL for this website is http://mytest:80/sites/portalteam.

    Once this site collection is created, it has given the following message: This site can be viewed in a browser.

    But when I have tried viewing it gave "Page cannot be Displayed"

    I expected a default page which asks for its customization by addition of new webparts.
    Could any one help me out of this.

     

    Thanks


    Regards,
    Sridhar


     

    Monday, December 24, 2007 3:31 PM

Answers

  • Sridhar, the site is crerated like http://mytest:80, means you your webserver name is mytest and you installed it on default port 80. You can check the following to resolve the problem:

    1. Check the user permission being used to create the new site and application pool. That user must have permission on SQL Server.

    2. Try to create a new web application (say TEST) on a different port, like 4004 (an unique port). Then create a site collection. after this, you can check from IIS Web Sites (run inetmgr) that a new web site is created with the given name of the web application (TEST in this case) which is using port 4004.

    Now run the URL: http://mytest:4004, it should show the site you just created provided the WSS is installed correctly and IIS setting is okay.

     

    Hope this helps, if not let me know.

     

    Regards,

     

    JC

     

    Friday, December 28, 2007 6:18 AM

All replies

  •  

     

     

    In one of the recent posts I have read  that we might get this 401 error when the anonymous access in IIS Manager for a given website is disabled.

     

    In addition to this I have even checked the web.config file to see if the authentication mode has been set to "Windows".

     

    Both of them are correct in the web application that I have created.

     

    When we type the site URL in the browser I have to see a default.aspx appended to the URL => it has to open the default.aspx file of the website.

     

    I have tried searching for this file (default.aspx) in the web application. But I could not find any.

    I still get a page cannot be displayed when I type the URL : http://mytest:80/sites/portalteam.

     

    Is it not able to find the template that I have used while creating this site collection?

    or Is there any thing else that I should check why the above link is giving a "page cannot be displayed" error....

    Could any one help me in moving forward in resolving this issue?

     

     

    Regards

    Sridhar

    Tuesday, December 25, 2007 9:03 AM
  • Apply a template to the root site (portal site) which is located at http://mytest:80/.  You can do that by creating a new site and instead of switching it to say "/sites" and entering the site name, keep it at "/" and create it.

     

    See if that works.

    Wednesday, December 26, 2007 4:09 AM
  • Hello Jarnett

    Thanks for your response.

    I have created a site as you have mentioned in your reply. Now I have created a top level site called Test. So the URL says http://test

     

    Central Administration > Application Management > Create Site Collection > Top-Level Site Successfully Created  

    Top-Level Site Successfully Created

    "The new, empty top-level site was created successfully with the specified URL. If you have permission to view the Web site, you can do so in a new browser window by clicking the URL.  To return to SharePoint Central Administration, click OK.

    http://test"

     

    Now when I click on the above link, it should open the default.aspx page which must be the default home page of this new site. I have tried searching for this page.

     

    And one more query

    When we create a new site, where is it created and how can we check the details in IIS Manager.

     

    For example, we have a new web application called test and you are creating a new web site collection called abc. How can we check where this site is created?

     

    Looking forward to your response.

     

    Thanks

    Regards

    Sridhar

     

     

     

    Wednesday, December 26, 2007 11:37 AM
  •  

    Usually the Sites get created within c:\Inetpub\WWWroot
    This problem may be related with IIS
    Unistall Sharepoint. Remove IIS from ADD\remove windows Component
    Add IIS back
    & then Install Sharepoint
    now When you create a Site e.g
    http://servername:80
    Apply a team Site template on it & try whether it Works
    Thursday, December 27, 2007 1:19 PM
  •  

    Hi,

     

    This problem seems to be a naming issue. Could you please check that your servername is what used for the site address? if you have used host header check whether the name "mytest" is resolvable in your machine.

     

    if "mytest" is not your server name or an unresolvable name then change the name through the Alternate Access Mapping which can be found under the Operations tab in the Central Administration.

     

    regards,

     

    David Paul

    Thursday, December 27, 2007 3:13 PM
  • Sridhar, the site is crerated like http://mytest:80, means you your webserver name is mytest and you installed it on default port 80. You can check the following to resolve the problem:

    1. Check the user permission being used to create the new site and application pool. That user must have permission on SQL Server.

    2. Try to create a new web application (say TEST) on a different port, like 4004 (an unique port). Then create a site collection. after this, you can check from IIS Web Sites (run inetmgr) that a new web site is created with the given name of the web application (TEST in this case) which is using port 4004.

    Now run the URL: http://mytest:4004, it should show the site you just created provided the WSS is installed correctly and IIS setting is okay.

     

    Hope this helps, if not let me know.

     

    Regards,

     

    JC

     

    Friday, December 28, 2007 6:18 AM
  • Hi Sridhar,

    While creating application leave HOST HEADER blank. It should resolve the problem. If you are using host header you must edit your host header file on your host PC and add an entry with IP and host address.

    Hope this will help.
    Friday, December 28, 2007 1:23 PM
  • You can not directly view all application files in IIS... SharePoint applications are more secured and then normal ASP .net pages. You can only get access to these files using SharePoint Designer by opening OPEN SITE from file menu. All these files are stored in SQL server.

    For example : http://testsite:yourportnumber (OR) http://yourIPaddress:andyourportnumber.
    Friday, December 28, 2007 1:28 PM
  • hi

      presently i am new in sharepoint .i want to make a website in sharepoint in which when i click any link on page then this link will open page information in the middle pane window.how we can do that.

    Thursday, January 03, 2008 11:14 AM
  •  

    Thanks a lot everyone for your contributions.

     

    JC and SP UK- your replies were very useful.

     

    Now I hve one more query. Now my website is working fine, but when I try to access this site from another system connected via LAN, it should ask me for credentials to authenticate the user.

     

    Is it possible to use this website from a external system?

     

    For example the new site created is http://mytest:22234.

     

    Can I access this site from an external system?

     

    Please suggest.

     

    Thanks in advance

     

    Regards

    Sridhar

    Thursday, January 03, 2008 2:32 PM
  • Yes ofcourse you can authenticate users by their credentials. All you need to do is... while deploying application you need to uncheck ALLOW ANONYMOUS ACCESS check box. I am assuming that you are authenticating users from AD.

    If i got you right. When you say external system, does it means out site your network (Extranet?). If you want to achieve this you can choose publishing portal as site collections and assign a public IP in IIS.
    Thursday, January 03, 2008 8:34 PM
  • Hi Pankaj,

    Sorry i couldn't understand your question. Can you please reframe it again for me.
    Thursday, January 03, 2008 8:41 PM
  • Hi,

     

    Do I need to specify the webserver name and the port name for the website URL? Can I use some name specific to user needs.

     

    For e.g. my webserver name is (SharePointTV01) and the port where I have created the website is 505. Is it always required my website URL should be http://SharePointTV01:505/ ?

     

    Because when I am using a different naming for the URL like http://MySharePointSite, the page is not geeting displayed and "page can't be displayed" is coming.

     

    Any help is appreciated.

     

    Sabya

    Friday, January 04, 2008 5:30 PM
  •  

    Hi Sabya,

     

    Not always. You can use host headers to sort this issue. when you create a site you can mention the host header value. this way you can mask your httpTongue TiedharepointTV01:505/ with http://MySharePointSite.

     

    Even if you miss to provide a host header value while creating the site you can always do that in the IIS directly.

     

    regards,

    Friday, January 04, 2008 6:38 PM
  • David,

    Thanks for your input.

    Can I use the Alternet Access Mapping to solve my isuue.

     

    For a short recap of my issue: I have my sharepoint site up an running . Site URL is http://SharepointTV01:505/

    It is in the default zone. I just want to change the defaut URL to be http://MySharePoint .

     

    Do I need to make an  entry in the DNS zone for "MySharePoint" for name resoution.

     

    I am trying it but no luck so far ..

     

    Thanks 

    Sabya

    Friday, January 11, 2008 6:16 PM