locked
Iphone AcvtiveSync Issues after installing Exchange 2010 SP1 RRS feed

  • Question

  • Hi,

    I have a mix of iphone 3GS and iphone 4 users. We have been running Exchange 2010 RTM Rollup 4 with no issues the last 8+ Months

    Last night we installed Exchange 2010 SP1 on our production Exchange Server. All our iphone users are experiencing issues with activesync. All running IOS4.01

    We have 2x Palm Treo's that are not experiencing any issues with SP1.

    Mail is being delivered to the iphones - we can see users/subject/preview of email - but when opening the email item - no content is shown

    "this message has not been downloaded from the server"

    In the event log of the exchange server the following is logged:

     

    Watson report about to be sent for process id: 6268, with parameters: E12, c-RTL-AMD64, 14.01.0218.011, AirSync, MSExchange ActiveSync, Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain, UnexpectedCondition:ArgumentException, 2908, 14.01.0218.015.

    ErrorReportingEnabled: True

     

    Exchange 2010 with CAS/Hub/Mailbox

    Server 2008 R2

    Running on ESXI 4.0

     

     

    I have checked with www.testexchangeconnectivity.com and confirmed no issues ( + my palm treo users are fine)

    I have deleted the mail account from my iphone4 and also from the ECP deleted the partnership and waited for AD replication - issue still occuring

    I also ran the logging tool to see what was happenning

     

     

     Log Entry: 26

    -----------------

     

    RequestTime :

    08/27/2010 14:10:06

     

    ServerName :

    INTAKLEX01

     

    AssemblyVersion :

    14.01.0218.011

     

    Identifier :

    2FE2E7EE

     

    RequestHeader :

    POST /Microsoft-Server-ActiveSync/default.eas?User=sureshk&DeviceId=Appl83032REYA4T&DeviceType=iPhone&Cmd=Sync HTTP/1.1

    Connection: keep-alive

    Content-Length: 77

    Content-Type: application/vnd.ms-sync.wbxml

    Accept: */*

    Accept-Encoding: gzip, deflate

    Accept-Language: en-us

    Authorization: ********

    Host: owa.intrical.com

    User-Agent: Apple-iPhone3C1/801.400

    Ms-Asprotocolversion: 12.1

    X-Ms-Policykey: 2959627245

     

     

    RequestBody :

    <?xml version="1.0" encoding="utf-8" ?>

    <Sync xmlns="AirSync:">

    <Collections>

    <Collection>

    <SyncKey>2011467065</SyncKey>

    <CollectionId>7</CollectionId>

    <GetChanges>0</GetChanges>

    <Options>

    <FilterType>2</FilterType>

    <MIMESupport>2</MIMESupport>

    <BodyPreference xmlns="AirSyncBase:">

    <Type>4</Type>

    <TruncationSize>32768</TruncationSize>

    </BodyPreference>

    </Options>

    <Commands>

    <Fetch>

    <ServerId>7:4</ServerId>

    </Fetch>

    </Commands>

    </Collection>

    </Collections>

    </Sync>

     

    SyncCommand_GenerateResponsesXmlNode_Fetch_Exception :

    System.ArgumentException: imceaDomain must be a valid domain name.

       at Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain(String imceaDomain)

       at Microsoft.Exchange.Data.Storage.OutboundConversionOptions..ctor(String imceaDomain)

       at Microsoft.Exchange.AirSync.AirSyncUtility.GetOutboundConversionOptions()

       at Microsoft.Exchange.AirSync.SchemaConverter.Common.BodyUtility.ConvertItemToMime(StoreObject xsoItem)

       at Microsoft.Exchange.AirSync.SchemaConverter.XSO.XsoContentProperty.get_MIMEData()

       at Microsoft.Exchange.AirSync.SchemaConverter.AirSync.AirSyncContentProperty.InternalCopyFrom(IProperty sourceProperty)

       at Microsoft.Exchange.AirSync.SchemaConverter.AirSync.AirSyncProperty.CopyFrom(IProperty srcProperty)

       at Microsoft.Exchange.AirSync.SchemaConverter.AirSync.AirSyncDataObject.CopyFrom(IProperty srcRootProperty)

       at Microsoft.Exchange.AirSync.SyncCollection.ConvertServerToClientObject(ISyncItem syncItem, XmlNode airSyncParentNode, SyncOperation changeObject, GlobalInfo globalInfo)

       at Microsoft.Exchange.AirSync.SyncCollection.GenerateResponsesXmlNode(XmlDocument xmlResponse, IAirSyncVersionFactory versionFactory, String deviceType, GlobalInfo globalInfo, ProtocolLogger protocolLogger, MailboxLogger mailboxLogger)

     

    LogicalRequest :

    <?xml version="1.0" encoding="utf-8" ?>

    <Sync xmlns="AirSync:">

    <Collections>

    <Collection>

    <SyncKey>2011467065</SyncKey>

    <CollectionId>7</CollectionId>

    <GetChanges>0</GetChanges>

    <Options>

    <FilterType>2</FilterType>

    <MIMESupport>2</MIMESupport>

    <BodyPreference xmlns="AirSyncBase:">

    <Type>4</Type>

    <TruncationSize>32768</TruncationSize>

    </BodyPreference>

    </Options>

    </Collection>

    </Collections>

    </Sync>

     

    AccessState :

    Allowed

     

    AccessStateReason :

    Global

     

    ResponseHeader :

    HTTP/1.1 200 OK

    MS-Server-ActiveSync: 14.1

     

     

    ResponseBody :

    <?xml version="1.0" encoding="utf-8" ?>

    <Sync xmlns="AirSync:">

    <Collections>

    <Collection>

    <SyncKey>494803558</SyncKey>

    <CollectionId>7</CollectionId>

    <Status>1</Status>

    <Responses>

    <Fetch>

    <ServerId>7:4</ServerId>

    <Status>6</Status>

    </Fetch>

    </Responses>

    </Collection>

    </Collections>

    </Sync>

     

    ResponseTime :

    08/27/2010 14:10:06

     

    Friday, August 27, 2010 4:14 AM

Answers

  • OK, I got some more info on this issue and luckily there was a repro available as well, which we used to verify the issue and resolution. I am providing details below, please check them out and let us know if this helps you to resolve the issue.

    Please run the following command under Exchange Management Shell and verify that there is one domain marked as "Default" and it's DomainName & Name values are valid domain names. We were able to repro the issue by setting a domain name with a space in it, like "aa bb".

    Get-AcceptedDomain | fl

    If you also have an invalid domain name there (like one with a space in it), then taking out the space and restarting the server will fix the EAS, OWA & IMAP issues.

    Command to run under EMS would be:

    Set-AcceptedDomain –Identity <value> -Name “ValidSMTPDomainName”

    So for example it could be:

    Set-AcceptedDomain –Identity “My Company” –Name “MyCompany.Com”

    or:

    Set-AcceptedDomain –Identity “ABC Local” –Name “ABC.Local”


    Sr. Program Manager, Product Quality, Exchange Client Access Server
    • Proposed as answer by Jaajog Tuesday, August 31, 2010 5:40 AM
    • Marked as answer by Amir Haque [MSFT] Tuesday, August 31, 2010 3:21 PM
    Monday, August 30, 2010 9:33 PM

All replies

  • I have the same issue. Getting the following from the application log for MSExchange Common:

    Watson report about to be sent for process id: 5596, with parameters: E12, c-RTL-AMD64, 14.01.0218.015, AirSync, M.E.Data.Storage, M.E.D.S.InboundConversionOptions.CheckImceaDomain, System.ArgumentException, 9854, 14.01.0218.012.

    Also visible in OWA when sending a message, throwing an exception with the following:


    Request
    Url: https://my.domain.com:443/owa/forms/premium/SubPageEventHandler.aspx?ae=Item&a=Preview&t=IPM.Conversation&id=CID.8kJOYP%2bnTDmpGO632OGz4Q%3d%3d.LgAAAADfhxVJQ4RjS4KKIjngpfSYAQBmfEuQAzeLRIprDvYqe3RnAAmBy1uIAAAB.AQAACYHLW4QAAAAA458AAAAAAAA%3d&SP=1&subpage=ReadConversation.ascx
    User host address: x.x.x.x
    User: Peter Pan
    EX Address: /o=Company AS/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Henning
    SMTP Address: Henning@pan.com
    OWA version: 14.1.218.13
    Mailbox server: my.domain.com

    Exception
    Exception type: System.ArgumentException
    Exception message: imceaDomain must be a valid domain name.

    Call stack

    Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain(String imceaDomain)
    Microsoft.Exchange.Data.Storage.InboundConversionOptions..ctor(String imceaDomain)
    Microsoft.Exchange.Data.Storage.ItemConversion.TryOpenSMimeContent(MessageItem messageItem, String imceaDomain, Item& item)
    Microsoft.Exchange.Clients.Owa.Core.Utilities.OpenSMimeContent(Item smimeMessage)
    Microsoft.Exchange.Clients.Owa.Core.OwaSafeHtmlOutboundCallbacks.GetAttachmentCollection(Item item, UserContext userContext)
    Microsoft.Exchange.Clients.Owa.Core.OwaSafeHtmlOutboundCallbacks..ctor(Item item, Boolean userLogon, Boolean isEmbedded, String itemUrl, Boolean isJunkOrPhishing, OwaContext owaContext, Boolean isEditableContent)
    Microsoft.Exchange.Clients.Owa.Core.OwaSafeHtmlConversationsCallbacks..ctor(Item item, Boolean userLogon, Boolean isJunkOrPhishing, OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Premium.Controls.ItemPartWriter.GetSafeHtmlCallbacks(Item item)
    Microsoft.Exchange.Data.Storage.Conversation.LoadBodyScanner(Item item, HtmlStreamOptionCallback callback, Boolean isIrmEnabled, Int64 bytesLoadedForConversation, Int64& bytesRead)
    Microsoft.Exchange.Data.Storage.Conversation.CreateLoadedItemPart(Item item, IStorePropertyBag propertyBagFromTree, HtmlStreamOptionCallback htmlCallback, PropertyDefinition[] propertyDefinitions, ItemPartIrmInfo itemPartIrmInfo, Boolean isIrmEnabled, Int64 bytesLoadedForConversation)
    Microsoft.Exchange.Data.Storage.Conversation.LoadItemPart(MailboxSession session, StoreId objectId, IStorePropertyBag propertyBagFromTree, HtmlStreamOptionCallback htmlCallback, PropertyDefinition[] propertyDefinitions, Boolean isIrmEnabled, Int64 bytesLoadedForConversation)
    Microsoft.Exchange.Data.Storage.Conversation.LoadItemPart(IStorePropertyBag propertyBag)
    Microsoft.Exchange.Data.Storage.Conversation.RecursiveLoadBodyFragments(ConversationTreeNode treeNode, ICollection`1 itemPartsToLoad, Boolean& forceParentLoadBodyFragment)
    Microsoft.Exchange.Data.Storage.Conversation.RecursiveLoadBodyFragments(ConversationTreeNode treeNode, ICollection`1 itemPartsToLoad, Boolean& forceParentLoadBodyFragment)
    Microsoft.Exchange.Data.Storage.Conversation.LoadItemPartsOrBodySummaries(ICollection`1 storeIds)
    Microsoft.Exchange.Clients.Owa.Premium.ConversationUtilities.RenderItemParts(TextWriter writer, UserContext userContext, OwaStoreObjectId owaConversationId, Conversation conversation, OwaStoreObjectId[] expandedIds, Int32[] expandedInternetMIds, List`1 localItemIds, String searchWords, Boolean shouldRenderSelected)
    Microsoft.Exchange.Clients.Owa.Premium.ReadConversation.RenderItemParts()
    ASP.forms_premium_readconversation_ascx.__Render__control1(HtmlTextWriter __w, Control parameterContainer)
    System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
    System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
    ASP.forms_premium_subpageeventhandler_aspx.__Render__control1(HtmlTextWriter __w, Control parameterContainer)
    System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
    System.Web.UI.Page.Render(HtmlTextWriter writer)
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Saturday, August 28, 2010 1:40 PM
  • Could you please call Microsoft Support and report this issue, so that we can further investigate it. At this moment, we have no reports of an issue like this so far for Exchange 2010 SP1.
    Sr. Program Manager, Product Quality, Exchange Client Access Server
    Monday, August 30, 2010 5:05 PM
  • I upgraded Exchange 2010 to SP1 and it broke OWA and Active-Sync. I noticed in Exchange Powershell, running the command
    'Test-OutlookWebServices' that there were too many redirects. Problem was caused by IIS configuration. SP1 had marked the check boxes to redirect the web sites to themselves.  solution was to go in to IIS, select OWA and Active-Sync virtual directories (check them all while you are there), click on redirection, uncheck the box which redirects site to itself.
    Monday, August 30, 2010 6:07 PM
  • I started a support ticket this morning,

    REG:110082924128819

    At least 3 other users in here have this issue, all independent cases to the best of my knowledge.

    I have recreated virtual dirs for owa and activesync to no avail.

    Publishing to the internet with tmg, but problem still there with https://localhost/owa on CAS server. TMG is not to blame. (Payload, normalization etc)

    Using a split DNS structure with domain.as for namespace

    Using wildcard certificate bound to CAS and TMG

    OWA light works with no apparent issues.

    OWA premium is impacted together with active sync and throws the same exeption from Exhange common.

    I have 100+ users impacted by this.

     

    Henning

    Monday, August 30, 2010 6:36 PM
  • I and many other users in my organization receive the same error as DTSCAPS when clicking Reply/Forward in OWA. POP3 RETR also does not work, logging the error checkImceaDomain.

    2010 had been working for a few months, transitioned from 2007. No forefront, only roles on the server are Mailbox+HubT+CAS.

    Jaanus

    Monday, August 30, 2010 7:00 PM
  • My impacted site is also a transition from Exchange 2007 sp2  -> 2010 RTM  -> 2010SP1.

    Have a smaller site with a similiar setup that started with 2010 rtm and installed Sp1 with no issues.

     

    Henning

    Monday, August 30, 2010 7:14 PM
  • I'm having the same problem.
    OWA is broken. Everythings seems to work except for reply, reply all and forward. This makes OWA next to useless...

    Also see: http://forums.msexchange.org/m_1800537461/mpage_1/key_/tm.htm

    Monday, August 30, 2010 8:17 PM
  • OK, I got some more info on this issue and luckily there was a repro available as well, which we used to verify the issue and resolution. I am providing details below, please check them out and let us know if this helps you to resolve the issue.

    Please run the following command under Exchange Management Shell and verify that there is one domain marked as "Default" and it's DomainName & Name values are valid domain names. We were able to repro the issue by setting a domain name with a space in it, like "aa bb".

    Get-AcceptedDomain | fl

    If you also have an invalid domain name there (like one with a space in it), then taking out the space and restarting the server will fix the EAS, OWA & IMAP issues.

    Command to run under EMS would be:

    Set-AcceptedDomain –Identity <value> -Name “ValidSMTPDomainName”

    So for example it could be:

    Set-AcceptedDomain –Identity “My Company” –Name “MyCompany.Com”

    or:

    Set-AcceptedDomain –Identity “ABC Local” –Name “ABC.Local”


    Sr. Program Manager, Product Quality, Exchange Client Access Server
    • Proposed as answer by Jaajog Tuesday, August 31, 2010 5:40 AM
    • Marked as answer by Amir Haque [MSFT] Tuesday, August 31, 2010 3:21 PM
    Monday, August 30, 2010 9:33 PM
  • This resolves all my issues. OWA now works, iPhone works, etc..

    I spent the entire afternoon and 3 hours after work with MS Support, they went away after collecting all the trace logs, etc... and are calling back tomorrow.

    I did not use the scripts, I just selected a second domain and set it as default then changed the name of the orginal domain to a valild domain.com name and set the original domain back as default.

    This is gone: Exception message: imceaDomain must be a valid domain name.

    Thanks to everyone, the phone will be quite tomorrow!

     

    Tim

    • Proposed as answer by TimMapes Tuesday, August 31, 2010 1:13 AM
    • Marked as answer by skuttan Tuesday, August 31, 2010 2:49 AM
    • Unmarked as answer by Amir Haque [MSFT] Tuesday, August 31, 2010 3:22 PM
    Tuesday, August 31, 2010 1:13 AM
  • Hey Tim,

     

    Thanks for that - just done the changes and my iphone is working again! 

     

    Weird thing was - my OWA was working fine and my non-iphone users were fine as well - only thing that was broken was my iphone users activesync

    Glad its been sorted

     

    thanks

    Tuesday, August 31, 2010 2:51 AM
  • Same here. Problem solved.
    Tuesday, August 31, 2010 4:51 AM
  • Thanks, this was the issue indeed. Fixed the owa problem and the pop3 problem.
    Tuesday, August 31, 2010 5:42 AM
  • Same here, problem solved.

    Thanks.

     

    Henning

    Tuesday, August 31, 2010 5:56 AM
  • Tim, can you explain your procedure step by step to fix this bug ?
    Étudiant Informatique - http://jordanroy.fr - MCITP : Administrateur serveur en cours
    Tuesday, August 31, 2010 7:31 AM
  • Same here, upgraded org from 2007SP1-2007SP2-2010-2010SP1 and iPhone stopped working

    Mr Haque's suggestion worked, i had spaces in the name of my default domain, renamed it to my domain name, and after a server reboot, the iphone immediately started syncing again.

     

    Was quite a headache, spent about 12 hrs recreating owa directories, playing around with adsiedit, reinstalling the CAS role and even an entire new Exchange Server without SP1. The latter wasn't a solution, because the mailboxes have already been updated to Version 37 (SP1) and were not compatible to ActiveSync-pre-SP1 CAS.

     

    Tuesday, August 31, 2010 10:27 AM
  • Ok, now maybe all of you can help me with one more issue.

     

    After the SP1 update all my current users HomeMTA's are corrupt. They all point to a deleted confirguration. Any new users are created correctly.

    I need a script to replace all users HomeMTA in a specified OU with the correct information:

    cig.local/OU

    New HomeMTA

    CN=Microsoft MTA,CN=MAILSRV,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=CIG,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=cig,DC=local

     

    Tim

    Tuesday, August 31, 2010 3:11 PM
  • Ok, now maybe all of you can help me with one more issue.

     

    After the SP1 update all my current users HomeMTA's are corrupt. They all point to a deleted confirguration. Any new users are created correctly.

    I need a script to replace all users HomeMTA in a specified OU with the correct information:

    cig.local/OU

    New HomeMTA

    CN=Microsoft MTA,CN=MAILSRV,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=CIG,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=cig,DC=local

     

    Tim


    Hi,

    What exactly do you need the homeMTA attribute for, as I understand it is not needed and used in Exchange 2010?

    If you are having warnings about this in the server event log, try simply setting the value to <not set> and see if everything works.

    Jaanus

    Wednesday, September 1, 2010 9:11 AM
  • Hi Amir-

    The only spaces in my domain names are in the identity and not the name, yet I'm still getting the CheckImceaDomain error.

     

    Any other ideas?

     

    Thanks,

    joe

    Tuesday, September 14, 2010 12:53 PM
  • @ TimMapes--

    LDIFDE is your friend in this case.

    Here's a support link describing its use: http://support.microsoft.com/kb/237677/en-us

     

    I use csvde to export attributes that I want, then put the data in .ldf format.

    csvde -f homeMTA.txt -d "ou=users,OU=Internal,OU=companyOU,DC=domain,dc=com" -l "DN,homeMTA".  This will dump the attributes listed into a CSV file, then format in Excel to ldf.

    Tuesday, September 14, 2010 3:32 PM
  • I can report that changing the accepted domain settings and rebooting the server also fixed the issue for me.

     

    Thanks

     

    Monday, October 11, 2010 4:44 PM
  • We still had some Iphone 4 telephones that did not connect to the server.

    I found out that this users, did have a problem in the AD.

    After testing connection with the Exchange Remote connectivity Analyzer, there was a http 500 error.

    Read here: http://technet.microsoft.com/en-us/library/dd439375(EXCHG.80).aspx

    After changing the security, all was functioning.

    Leif

    Saturday, October 16, 2010 9:46 PM
  • I have checked this solution out but the "Identity" and "Name" Values are both set to the value "Primary Domain".  I attempted to run the "Set-AcceptedDomain" command (below) in EMS and it would return an error.

    Set-AcceptedDomain -Identity "<My Organization Name>" -Name "<mydomainname.org>"

    The operation couldn't be performed because object '<My Organization Name>' couldn't be found on '<Domain Controller>'
    .
        + CategoryInfo          : NotSpecified: (0:Int32) [Set-AcceptedDomain], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : F49C0A79,Microsoft.Exchange.Management.SystemConfigurationTasks.SetAcceptedDomain

    Obviously I have replaced the values I really used with placeholders, but I did follow the instructions precisely.

    Exchange Server 2010 v.14.01.0218.013 (SP1 with Rollup 1) on Server 2008 R2 with all updates to date.

    Here is the result of running the "Get-AcceptedDomain | fl" command:

    [PS] C:\Windows\system32>Get-AcceptedDomain | fl


    RunspaceId                 : 06aac4d3-8459-4590-9117-539b943c02dc
    DomainName                 : mydomainname.org
    DomainType                 : Authoritative
    AddressBookEnabled         : True
    Default                    : True
    AuthenticationType         :
    LiveIdInstanceType         :
    PendingRemoval             : False
    FederatedOrganizationLink  :
    MailFlowPartner            :
    OutboundOnly               : False
    PerimeterDuplicateDetected : False
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    Name                       : Primary Domain
    DistinguishedName          : CN=Primary Domain,CN=Accepted Domains,CN=Transport Settings,CN=MYDOMAINNAME,CN=Microsoft
                                 Exchange,CN=Services,CN=Configuration,DC=mydomainname,DC=org
    Identity                   : Primary Domain
    Guid                       : 4d893b68-4c3e-46fc-b404-a5114848fd1a
    ObjectCategory             : mydomainname/Configuration/Schema/ms-Exch-Accepted-Domain
    ObjectClass                : {top, msExchAcceptedDomain}
    WhenChanged                : 11/24/2010 4:39:22 PM
    WhenCreated                : 11/23/2010 1:30:51 PM
    WhenChangedUTC             : 11/24/2010 10:39:22 PM
    WhenCreatedUTC             : 11/23/2010 7:30:51 PM
    OrganizationId             :
    OriginatingServer          : <domaincontroller>.mydomainname.org
    IsValid                    : True

    Any other thoughts???

    Monday, November 29, 2010 11:28 PM
  • This resolves all my issues. OWA now works, iPhone works, etc..

    I spent the entire afternoon and 3 hours after work with MS Support, they went away after collecting all the trace logs, etc... and are calling back tomorrow.

    I did not use the scripts, I just selected a second domain and set it as default then changed the name of the orginal domain to a valild domain.com name and set the original domain back as default.

    This is gone: Exception message: imceaDomain must be a valid domain name.

    Thanks to everyone, the phone will be quite tomorrow!

     

    Tim


    Using the EMS method did not work so I tried this method.  It is still not working.  Any thoughts on my original post (Kitchen_Support)?

    Thanks

    Tuesday, November 30, 2010 4:01 PM
  • Ok, all is well. I had a "Monday" moment and did not restart IIS. OWA 2010 appears to be handling replies and forwards now. Thank you!
    Tuesday, November 30, 2010 4:20 PM
  • I had the same issue with Small Business Server 2011, which added a default accepted domain in Exchange during install with a space in the name.  I just changed the name of the domain in the Exchange Management Console, rebooted, and all is working well.  Thank you for the fix!
    Saturday, January 8, 2011 8:08 PM
  • We are running SBS 2011. Cannot compose, reply, reply to all, or forward messages in OWA.  Users with iPhones are unable to download messages to their phones, emails show up, but when they try and read the email they get the "message has not been downloaded."

    When I try the above using my information, I get a identity "cannot be found on servername".

    When I go into the exchange management console, I cannot remote the default accepted domain name because a email address policy is tied to it.  When I try and remove the email policy, I don't have an option to remove the default policy.

    We have updated our server with every hotfix, patch, etc from windows update site.  I need help with is affected 40 users and executives of a company. 

     

    Thank you in advance for your help.

    Friday, February 25, 2011 6:55 PM
  • I removed the entry to the default email address policy, which allowed me to remove the default accepted domain name, rebooted server but still not working.
    Friday, February 25, 2011 7:47 PM
  • Hi guys, thanks for the knowledge this worked for me!!!!! YAY

    Removed the IIS redirect and works like a charm.

    Friday, May 27, 2011 3:58 PM
  • Hi gk2inc,

     

    i ´ve the same issue...

    Is your gone or still there ?

     

    greets Gogo

    Monday, June 20, 2011 2:44 PM
  • Thanks.  That did it for me.  I actually just renamed my default domain within EMC and it resolved the issue.
    Wednesday, June 29, 2011 6:17 AM
  • Renaming the accepted domain name (with no space in) and restarting exchange services did the trick. previous I was getting emails headers only on iPhone 4 with Exchange 2010 SP1.

    Thanks guys.

     


    T.Ali
    Monday, July 18, 2011 3:40 PM
  • Hi Guys,

    I have this same issue and I had run all the steps mentioned above and the output is correct as server and domain name, with valid information.

    The strange thing is if I create new account and use POP3 login it works but for existing users pop3 does not work at all as well Active sync does not work, all blackbery users we need to change their settings to OWA url for server authentication.

    Can some one lend some help on this?

    Regards

    Santosh

    Monday, September 19, 2011 12:50 PM
  • FYI:

    I had the same problem:Exception message: imceaDomain must be a valid domain name.

    Changing the Accepted Domain(s) Names (i.e., removing the spaces from the name) fixed the problem.

     

    However, I wanted to get the system up and running ASAP without any downtime due to rebooting the server. In addition to restarting all the Exchange services, you also need to reboot IIS. That will get you back up and running without performing a full server reboot.


    • Edited by Netphemera Monday, December 5, 2011 6:54 PM
    Monday, December 5, 2011 6:47 PM
  • I am having problems applying this command, when l apply it l get a message saying  " The command completed successfully but no setting of "ABCDomain" have been modified. I would really appreciate your help.

    Tuesday, January 10, 2012 12:03 PM
  • I was having similar problems with a clients setup that were first identified when (after slow authenticating the account on the iphone) the headers would download , but content was not accessible.The situation deteriorated after a few changes to the point where we couldnt event authenticate. So after some digging anyone with iphon/exchange 2010 sp1 issues should check the following list of fixes: // these issues also manifest as a problem when forwarding or replying in owa.

    I looked over the whole installation of exchange and did the following:

    1. if you have set up the default accepted domain as "*.lincore.com"  change it to "lincore.com" (set the default domain explicitly - do not use a wildcard)

    // Note you will need to create an alternative domain and set as default then edit the default email policy , delete the accepted domain and re add it , then refix the default policy to set emails to the correct default domain and reset the default domain as default.//for reference my internal domain is corp.lincore.com. and my default domain and email policy are lincore.com.

    1.1  tip set the name and the accepted domain url as the same i.e. lincore.com -> lincore.com

    2. check your IIS ssl settings are basic / ssl accept cert (if using a locally issed certificate) and check that the corresponding exchange settings are the same, do this for owa , and Microsoft-Server-ActiveSync. 

    3. disable compression in iis for the ActiveSync application // try re-enabling afterwards.

    4. check that the default website https:// protocol is valid , mine didn't have the * for any incoming connection.

    5. make sure dns record for owa.lincore.com and activesync.lincore.com point the same ip as mail.lincore.com. dont use a cname // ps you should have seperate dns internally for corp.lincore.com and external dns for lincore.com . // The dns for corp should forward to the dns for lincore or another public dns.

    MX records only need to point to the correct relay server - I use a well known public company.

    6. check that the valid localhost/host ips are registered and excluded from "internal" smtp filtering

    7. Inheritable permissions - make sure normal user inheret the objects needed to create and manage device profiles. and not that superusers will have any rights removed after 1 hr - in otherwords only non admin accounts should use activesync. 

    8. set the internal and external uri's in exchange to https://owa.lincore.com/<servicenameasappropriate>

    9. add net.tcp as a protocol option on owa and activesync virtual apps in iis7

    10. use port 25 for smtp delivery from public smart host and 5xx for authenticated exchange users.

    11. remove ipv6 imap and pop3 incoming services.// probably irrelevant

    12. set the domain and realm for the activesync and owa basic auth.

    13. always use ssl, and set to accept when using locally issues certificates. (upgrade to verified asap)

    14. don't specify the domain when entering the iphone details.

    I would provide links instructions on the details of how to, but there is a lot on the web  already . what you really need to know it that these issues are not caused by a single problem - you need to install exchange, and hack its settings, IIS7 settings and tweak AD settings for users objects as above to make an iphone play nicely with activesync and owa.

    best regards all - and thanks for all the bits of information that got this working. the posts above were the final piece of the puzzle. (see point 1 above).

    jay

     

     

     

     

     

    Thursday, February 2, 2012 9:21 PM
  • More

    on the iphone - set a pin and also the time zone - then hard reboot the phone.delete any failed setup and reboot again before adding.

    in respect of the device profile - enable everything, then cut back once you have it working.

     

    Thursday, February 2, 2012 9:26 PM
  • I have the same issue, but there's no domain name with a space in it. What else could be causing this problem?

    RunspaceId                 : 1f747b94-dd90-44c7-b313-ff51ac4b52fe
    DomainName                 : birdus.local
    DomainType                 : Authoritative
    AddressBookEnabled         : True
    Default                    : False
    AuthenticationType         :
    LiveIdInstanceType         :
    PendingRemoval             : False
    FederatedOrganizationLink  :
    MailFlowPartner            :
    OutboundOnly               : False
    PerimeterDuplicateDetected : False
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    Name                       : birdus.local
    DistinguishedName          : CN=birdus.local,CN=Accepted Domains,CN=Transport Settings,CN=First Organization,CN=Microso
                                 ft Exchange,CN=Services,CN=Configuration,DC=birdus,DC=local
    Identity                   : birdus.local
    Guid                       : 0c11ed7f-35c7-4980-bc80-314e6db94f70
    ObjectCategory             : birdus.local/Configuration/Schema/ms-Exch-Accepted-Domain
    ObjectClass                : {top, msExchAcceptedDomain}
    WhenChanged                : 5/16/2011 11:40:00 AM
    WhenCreated                : 2/26/2011 10:26:15 PM
    WhenChangedUTC             : 5/16/2011 6:40:00 PM
    WhenCreatedUTC             : 2/27/2011 6:26:15 AM
    OrganizationId             :
    OriginatingServer          : MOE.birdus.local
    IsValid                    : True

    RunspaceId                 : 1f747b94-dd90-44c7-b313-ff51ac4b52fe
    DomainName                 : birdus.com
    DomainType                 : Authoritative
    AddressBookEnabled         : True
    Default                    : True
    AuthenticationType         :
    LiveIdInstanceType         :
    PendingRemoval             : False
    FederatedOrganizationLink  :
    MailFlowPartner            :
    OutboundOnly               : False
    PerimeterDuplicateDetected : False
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    Name                       : Windows SBS External Domain
    DistinguishedName          : CN=Windows SBS External Domain,CN=Accepted Domains,CN=Transport Settings,CN=First Organiza
                                 tion,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=birdus,DC=local
    Identity                   : Windows SBS External Domain
    Guid                       : 7c351e94-a0df-43a7-83b6-3994cf410b04
    ObjectCategory             : birdus.local/Configuration/Schema/ms-Exch-Accepted-Domain
    ObjectClass                : {top, msExchAcceptedDomain}
    WhenChanged                : 5/16/2011 11:40:00 AM
    WhenCreated                : 2/27/2011 2:11:39 PM
    WhenChangedUTC             : 5/16/2011 6:40:00 PM
    WhenCreatedUTC             : 2/27/2011 10:11:39 PM
    OrganizationId             :
    OriginatingServer          : MOE.birdus.local
    IsValid                    : True

    RunspaceId                 : 1f747b94-dd90-44c7-b313-ff51ac4b52fe
    DomainName                 : voterbraindump.com
    DomainType                 : Authoritative
    AddressBookEnabled         : True
    Default                    : False
    AuthenticationType         :
    LiveIdInstanceType         :
    PendingRemoval             : False
    FederatedOrganizationLink  :
    MailFlowPartner            :
    OutboundOnly               : False
    PerimeterDuplicateDetected : False
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    Name                       : voterbraindump.com
    DistinguishedName          : CN=voterbraindump.com,CN=Accepted Domains,CN=Transport Settings,CN=First Organization,CN=M
                                 icrosoft Exchange,CN=Services,CN=Configuration,DC=birdus,DC=local
    Identity                   : voterbraindump.com
    Guid                       : 47b5dc98-3df0-4255-9ab1-820cf4be409c
    ObjectCategory             : birdus.local/Configuration/Schema/ms-Exch-Accepted-Domain
    ObjectClass                : {top, msExchAcceptedDomain}
    WhenChanged                : 5/16/2011 11:40:23 AM
    WhenCreated                : 5/16/2011 11:40:23 AM
    WhenChangedUTC             : 5/16/2011 6:40:23 PM
    WhenCreatedUTC             : 5/16/2011 6:40:23 PM
    OrganizationId             :
    OriginatingServer          : MOE.birdus.local
    IsValid                    : True

    Saturday, February 2, 2013 5:20 AM
  • I discovered variation of the problem that this solution fixed;

    I spelled the name of the accepted domain (not the accepted domain itself though) with swedish letters, like in "Bergström". I got the same error with the iphones as OP. Deleting it and adding the accepted domain again, this time using "Bergstrom", it immediatly worked.

    Never in my mind could I imagine a name could have that effect.

    Monday, August 19, 2013 12:38 PM
  • I agree with you. We had this issue on Exchange 2013, but the difference is that our accepted domain was in wildcard format. *.domain.com and this caused the problem. I recreated the accepted domain name using just domain.com format instead and that fixed it.

    Another issue we had because of this also, was that messages were being stuck in the outbox of all mobile devices using ActiveSync. (Android phones, and Apple devices.)

    Our setup was Exchange 2013, all roles on a single box.

    Tuesday, November 12, 2013 6:05 PM
  • Thanks a lot, you just made my day! We had this issue with iOS 8.1, this error seems not to be fixed yet. But much more worse for us: also the IMAP functionality was down, both only because i have used wildcard-domains as accepted domains...
    Tuesday, December 9, 2014 9:13 PM
  • HI All

    I had a similar issue on one of a clients server, following article helped me resolve the issue. It also tells about the Accepted domains as explained below but some more details.

    http://www.grishbi.com/2015/03/this-message-has-not-been-downloaded-from-the-server/

    Thanks

    karan

    Tuesday, March 3, 2015 9:08 PM