none
Event ID 4027 MSExchange ADAccess Exchange 2013 RRS feed

  • Question

  • Process ForefrontActiveDirectoryConnector.exe (PID=1928). WCF request (Get Servers for chickbuns.com) to the Microsoft Exchange Active Directory Topology service on server (TopologyClientTcpEndpoint (localhost)) failed. Make sure that the service is running. In addition, make sure that the network ports that are used by Microsoft Exchange Active Directory Topology service are not blocked by a firewall. The WCF call was retried 3 time(s).

    Error Details 
     System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService. The connection attempt lasted for a time span of 00:00:02.0280035. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:890.  ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:890
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       --- End of inner exception stack trace ---

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          1/13/2014 8:57:01 PM
    Event ID:      4027
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DC4.chickbuns.com
    Description:
     Error Details 
     System.ServiceModel.EndpointNotFoundException: Could not connect to  net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService. The connection attempt lasted for a time span of 00:00:02.0280035. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:890.  ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:890
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       --- End of inner exception stack trace ---

    Monday, January 13, 2014 7:49 PM

Answers

  • Hi,

    According to the detail of the error, we can try the following resolutions:
    1. Check if there is some Windows firewall rule blocking certain port.
    2. Check if you’re having trouble allowing other computers to communicate with your computer through Windows Firewall, and you can try using the Incoming Connections troubleshooter to automatically find and fix some common problems.
    In Windows7, Open the Incoming Connections troubleshooter by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type troubleshooter, and then click Troubleshooting. Click View all, and then click Incoming Connections.
    3. Check if there is some service which doesn’t work.

    If you have any question, please feel free to let me know.
    Thanks, 


    Angela Shi
    TechNet Community Support

    Wednesday, January 15, 2014 4:48 PM

All replies

  • Hi

    Is the service running as indicated in the error? Any firewalls locally or AV? exclusions setup?

    Tuesday, January 14, 2014 4:23 AM
    Moderator
  • Only windows default firewall
    Tuesday, January 14, 2014 4:37 PM
  • Hi,

    According to the detail of the error, we can try the following resolutions:
    1. Check if there is some Windows firewall rule blocking certain port.
    2. Check if you’re having trouble allowing other computers to communicate with your computer through Windows Firewall, and you can try using the Incoming Connections troubleshooter to automatically find and fix some common problems.
    In Windows7, Open the Incoming Connections troubleshooter by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type troubleshooter, and then click Troubleshooting. Click View all, and then click Incoming Connections.
    3. Check if there is some service which doesn’t work.

    If you have any question, please feel free to let me know.
    Thanks, 


    Angela Shi
    TechNet Community Support

    Wednesday, January 15, 2014 4:48 PM
  • Enable IPv6 if it's disabled. Also make sure that your AD Subnet is configured properly as per your Exchange environment.

    OM (MCITP) | Blog

    Wednesday, January 15, 2014 6:50 PM
  • Resolved this by enabling IPv6. Thanks a lot.
    Wednesday, April 1, 2015 7:07 AM
  • Enable IPv6 if it's disabled. Also make sure that your AD Subnet is configured properly as per your Exchange environment.

    OM (MCITP) | Blog

    I had similar issue but it was my typo in AD subnet causing the issue. Your post made me revise the setting and resolve the issue.

    Thanks

    JK

     
    Tuesday, September 20, 2016 12:47 PM
  • I have resolution 
    Tuesday, February 13, 2018 2:54 AM
  • @smalfish,

    what is the resolution? i am having same issue.....

    Wednesday, September 5, 2018 3:55 AM
  • Add the Subnet in Site and Services (dssite.msc) which correspond to your topology.

    FF

    Friday, September 7, 2018 4:52 PM
  • If you want to keep IPv6 disabled, you need to do it from the registry as well and restart the server.

    http://blog.hitechcandy.com/index.php/2018/09/14/how-to-disable-ipv6-using-command-prompt/

    http://blog.hitechcandy.com/index.php/2018/09/14/how-to-disable-ipv6-using-registry-editor/


    Please mark as an answer if this answers your question .

    PREM RANA

    MCSE Exchange 2013, MCSA 2012 Server MCTS Exchange 2007,

    2010, MCITP Exchange 2007, 2010 MCSE 2003 Server,

    MCSA Exchange 2003 ITIL V3 Foundation

    https://ranaprem.wordpress.com/

    This posting is provided AS IS with no warranties and confers no rights.

    Friday, September 14, 2018 10:54 AM
  • It's working, thanks a lot.
    Saturday, October 27, 2018 6:23 AM