locked
Public Folder database wont mount on a CCR cluster

    Question

  • After performing a reboot of my primary node in a CCR cluster the Public Folder DB would no longer mount. When trying to manually mount the server I receive the following error:

     

    Failed to mount database 'Public Folder Database'.

    Public Folder Database
    Failed
    Error:
    Failed to mount (online) database 077058c2-e6f1-4fbd-9d7b-72c0db768f61. Reason: MapiExceptionADPropertyError: Unable to mount database. (hr=0x80004005, ec=2418)

    I have done a defrag using eseutil and integrity check and still unable to mount the DB. I have tried a restore and again no luck.


    In the end I tried deleting the database and creating a new Public Folder DB, but I can't even do that:

     

    The public folder database 'Public Folder Database' cannot be deleted.

    Public Folder Database
    Failed
    Error:
    The critical property 'PublicFolderHierarchy' is missing in the PublicFolderDatabase object 'NCO-EXMB\Public Storage Group\Public Folder Database'.

     

    Any ideas? I am totally stumped.

    Saturday, July 07, 2007 12:18 PM

Answers

  • Ok spoke with MS today and got this issue sorted (although it won't copy over to the passive node, but we will fix that tomorrow morning). This is what we had to do:

     

    Open adsiedit.msc.

     

    Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.

     

    Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:

     

    Create the "Folder Hierarchies" under the Exchange Administrative Group

     

    1. Right click on Exchange Administrative Group

    2. Select New Object

    3. Select msExchPublicFolderTreeContainer for the class and click Next

    4. Enter the following for the value: Folder Hierarchies, click Next

    5. Click Finish

     

    Create Public Folder Tree Object

     

    1. Right click CN=Folder Hierarchies -> New Object

    2. Selected msExchPFTree for the class

    3. For the value we entered, "Public Folders" and clicked next

    4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

    value to 1. Note: This is very important that this value is set to a value of 1 as

    this tells Exchange that this is a MAPI Tree

    5. Click Ok and then finish

     

    Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

    (Since this attribute is not directly editable, you have to follow the below steps

    to do this for each PF store)

     

    1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

    2. Copy the distinguishedname value to the clipboard and then click cancel.

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    5. Restart the Information Store Service

    6. Now try to  mount the PF store and see if we can access it fine now.

     

    Soon as the Information Store service was restarted it came online. Thankfully...

    Monday, July 09, 2007 11:09 AM

All replies

  • Do you have another server with all of the public folder replicas on it?

     

    Can you post the full event log item?

     

    It sounds like an attribute in AD has been changed either by permissions or value.

    Monday, July 09, 2007 1:22 AM
  • Events ID 9519:

     

    Error 0x972 starting database "Public Storage Group\077058c2-e6f1-4fbd-9d7b-72c0db768f61" on the Microsoft Exchange Information Store.

     

    Event ID 9518:

     

    Error 0x972 starting Storage Group /DC=root/DC=aun/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=Contoso/CN=Administrative Groups/CN=Exchange Administrative Group (FYDIBOHF23SPDLT)/CN=Servers/CN=NCO-EXMB/CN=InformationStore/CN=Public Storage Group on the Microsoft Exchange Information Store.

    MDB failed to start.

     

    From what I have gathered these relate to permissions, which I have attempted to get around but have no luck.

    Monday, July 09, 2007 4:03 AM
  • Getting the exact same error this morning - cannot remove the public folder either as I get the error message  The critical property 'PublicFolderHierarchy' is missing in the PublicFolderDatabase object '.....\Public Folder Database'

     

    Although my Exchange server is not on a cluster...

     

    Help!

     

    Monday, July 09, 2007 8:55 AM
  • Ok spoke with MS today and got this issue sorted (although it won't copy over to the passive node, but we will fix that tomorrow morning). This is what we had to do:

     

    Open adsiedit.msc.

     

    Select Configuration-Configuration-Services-Microsoft Exchange-Orgname-Administrative Groups-Exchange Administrative Group.

     

    Now we were missing the 'Folder Hierarchies' folder - how I still am unsure of. All we had to do was recreate it as follows:

     

    Create the "Folder Hierarchies" under the Exchange Administrative Group

     

    1. Right click on Exchange Administrative Group

    2. Select New Object

    3. Select msExchPublicFolderTreeContainer for the class and click Next

    4. Enter the following for the value: Folder Hierarchies, click Next

    5. Click Finish

     

    Create Public Folder Tree Object

     

    1. Right click CN=Folder Hierarchies -> New Object

    2. Selected msExchPFTree for the class

    3. For the value we entered, "Public Folders" and clicked next

    4. Clicked on the "More Attributes" button, selected msExchPFTreeType and set the

    value to 1. Note: This is very important that this value is set to a value of 1 as

    this tells Exchange that this is a MAPI Tree

    5. Click Ok and then finish

     

    Populate msExchOwningPFTreeBL attribute object of the PF Stores in the organization

    (Since this attribute is not directly editable, you have to follow the below steps

    to do this for each PF store)

     

    1. Get properties of the newly created "Public Folders" Tree object in ADSIEdit.

    2. Copy the distinguishedname value to the clipboard and then click cancel.

    3. Navigate to the Storage group that contains the Public Folder Store for this

    server and get properties of the server.

    4. Locate the msExchOwningPFTree attribute and paste in the value that was copied

    to the clipboard in step 2. Click OK.

    5. Restart the Information Store Service

    6. Now try to  mount the PF store and see if we can access it fine now.

     

    Soon as the Information Store service was restarted it came online. Thankfully...

    Monday, July 09, 2007 11:09 AM
  • Hi Sonny,

     

    Were you enabling the CCR replication on the Public Folder store?

    I had done this in my own VM lab and found that when I would frequently start up my 6 Exchange VM's I would find the Public Folder store not mounted. I had to go through and run the following commands to get it back up:

     

    Suspend-StorageGroupCopy -identity "ex2007-mbx\public folder store"

    Update-StorageGroupCopy -identity "ex2007-mbx\public folder store" -deleteexistingfiles

    Resume-StorageGroupCopy -identity "ex2007-mbx\public folder store"

     

     I had later read the pre-requisites of the setting up a CCR cluster and found that there were a fair few conditions around setting up CCR and Public Folders. You can find more information on this in this article:

    http://technet.microsoft.com/en-us/library/bb123996.aspx

     

    From my reading of this it sounds like you can only setup the Public Folder database on one of the CCR Cluster Nodes which would not help much if it fails over.

     

    Did you find any more in your discussions on whether you could setup Public Folders databases on both CCR Cluster Nodes?

     

    Cheers,

     

    Rhys

     

    Wednesday, July 18, 2007 10:58 AM
  • Thank you Sonny for saving me a support call.  Your detailed solution worked well.  I got a bit turned around on step 3 in the last segment, but then I realized that the msExchOwningPFTree atrribute was to be found as a property of the public folder object itself, not of the server.

     

    My problem arose after manually migrating to Exchange 2007 and then removing my legacy Exchange 2003 server and services from AD using ADSIEDIT.msc, with the direction of a Microsoft support rep.  The steps you detailed should be appended to the removal steps when an Exchange 2007 environment exists.  My users with Outlook 2003 clients received a dubious error message in Outlook stating "Your Exchange Server administrator has blocked the version of Outlook that you are using. Contact your administrator for assistance."  Note that this error didn't start appearing until I rebooted my Exchange 2007 Server a few days later.  After implementing your solution, Outlook 2003 users were immediately able to access their mailboxes, and I was able to mount our public folder store.

     

    Many thanks.

    Monday, July 23, 2007 3:43 PM
  •  

    Thanks a lot,

     

    I have the same problem but in a single exchange2007 server installed  on a same organisation than exchange 2003, the exchange 2003 has been disconnected, his attributes has has been removed manually with ADSIedit,

    The problem has been resolved:

    I apply the same procedure that Sonny, Just the step 4 for the last the msExchOwningPFTree is a Public Database attribute (child of storage group), I have not find it on server properties. I have done the change here and restrating Information store service.after all work correctly

     

    Thanks

     

     

    Friday, September 07, 2007 7:13 PM
  • Hi!

    msExchOwningPFTree is property of CN=Public Folder Database from Second Storage Group. I found it, change such Sonny recomend, then restart Inf store and my Public Folder Database has been mounted. Thanks Sonny

     

    Wednesday, September 12, 2007 4:21 AM
  •  

    I agree with all others, Sonny thanks for posting that information. It also saved me a great deal of hassle.

     

    Also, please note that my exchange issue is exactly the same as other Post-Sonny tip. It was related to manually removing an exchange server (2000 in my case) after installing Exchange 2007. 

    Thursday, September 27, 2007 3:22 PM
  • I agree too.

     

    After migration Exchange Server 2003 to Exchange Server 2007 i have boths Server running, then after 2 month I woul deinstall Exchange Server 2003, but i could not (ather reason).

    I manuell striped off all Exchange Server 2003 entries in the AD

    Days later, after er restart of the Exchange Server 2007 i got the problem ...

     

     

    Thanks

     

    Hans

     

    Thursday, October 25, 2007 11:42 AM
  • This was a great solution to my problem with public folders today, thank you!  However I have a problem likely related to it since it occurred at the same time.  When going to OWA 2007 I get this error:

    Failed to access the Active Directory configuration settings for virtual directory "owa" under web site "Exchange".

     

    Event Type: Error
    Event Source: MSExchange OWA
    Event Category: ADNotifications
    Event ID: 64
    Date:  12/10/2007
    Time:  10:22:39 AM
    User:  N/A
    Computer: EXCHANGE7
    Description:
    Failed to read and update the Outlook Web Access configuration settings. Virtual directory: "owa". Web site: "Exchange".
    Error message:
    "Failed to access the Active Directory configuration settings for virtual directory "owa" under web site "Exchange"."

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    This appears to be another AD issue since I never changed the IIS settings.  Any idea where I can find the fix using ADSIEDIT?  This MS Solution using the above link isnt plausable in my case.

     

    Monday, December 10, 2007 6:24 PM
  • From Exchange Management Shell enter Remove-OwaVirtualDirectory servername\owa* and then on a new line New-OwaVirtualDirectory.

     

    You will need a record of all your OWA virtual directory settings though, as this wipes them and creates a new OWA site with working default settings.

    Tuesday, January 08, 2008 12:44 PM
  • Hi - I have done the above mentioned procedure and its working, but now the 2 public folder trees cant see each other. When I try to pick the Exchange 2007 Public Folder tree (in order to replicate) from Exchange 2003 System Manager its not there, the same happens when I open the public folder management console from Exchange 2007 it cant find any folders, If I try to remove the public folder database from Exchange 2007 CCR I get the following error "Exchange cannot remove the public folder database cluster\second storage group\public folder database because it is the last public folder database in an organization that has pre-exchange 2007 server. Organizations that have pre-exchange 2007 server must have at least one public folder database" Any ideas how to get the two systems connected again. Thanks in advance Soren
    Tuesday, January 22, 2008 11:11 AM
  •  

    I'm in a slightly different situation, having walked into a migration in progress.  We're doing a GroupWise to Exchange 2007 migration with an Exchange 2003 server as an intermediary.  The first 2007 mailbox cluster was setup so that the PFDB is included in the CCR.  I've built a second mailbox cluster and moved all user mailboxes to that cluster so I can rebuild the first cluster.  What do I need to do with the Public Folder Database on the first cluster?  Exchange 2003 is still in place as the migration will go on for a few more months.  I'm assuming I can't rebuild the first MB cluster until I've done something with the PFDB that resides on it?

     

    Any help would be appreciated as we can't move forward with the migration until we've rebuilt the first cluster.  Thanks!

    Friday, February 29, 2008 5:25 PM
  • Sonny,

    I realize this your post is from quite a while ago, so you'll probably never see this, but THANK YOU for posting this information!  I can't begin to imagine how much time it saved me. 

    I had the exact same problem once I shut down our Exchange 2K3 server after migrating to 2K7.  Adding the public folders objects in ADSIedit worked perfectly.

    Again, THANK YOU.

    -Warren O.


    Wednesday, June 18, 2008 9:15 PM
  • I've have to thank Sonny for this too.  I was pulling my hair out after downing my 2k3 box and couldn't figure out why.  Althought the thread should change the subject because it's not just for Cluster.

     

    Monday, June 30, 2008 9:59 PM
  • Sonny you are great!!!
    I moved a server installed on VM and I got the same issue you had,
    All your steps worked fine.

    THANK YOU!!!!

    Wednesday, July 16, 2008 5:17 PM
  • Thank you, thank you, thank you! Our Public Folders were MIA after removing Exchange 2003 from AD. (http://technet.microsoft.com/en-us/library/bb288905.aspx) This resolved the issue!

     
    Friday, July 25, 2008 2:30 PM
  • Sonny - thanks a ton.  your solution worked great!  i removed an e2k3 server and then i couldnt remove the public folders from my new exchange 2007 server until i made your edits.

    Tuesday, September 02, 2008 6:25 PM
  • Thanks for sharing the info!

    Tuesday, October 07, 2008 1:14 PM
  • It has been solved the problem.

     

    Thanks

    Tuesday, October 28, 2008 7:22 PM
  •  

    Hi

     

    when I open adsiedit.msc. on the (only) 2008 server I do not have a CN=Configuration level. Am I looking in the wrong place?

    Monday, November 03, 2008 11:30 AM
  •  

    Thanks for this - really helped me out!

     

    Just in case anyone out there is in the same situation as me, I had carried out a transition from Exchange 2003 to 2007. All seemed well and so I uninstalled the old server. Unfortunately, after this I discovered that the public folders were inaccessible and received "PublicFolderHierarchy is mandatory" messages when trying to do anything with the Public Folder Database.

     

    Rebuilding the old server didn't help as I was unable to then replicate data to the new box. This solution however has sorted it all out! Wish I'd found it yesterday morning instead of today...

     

    K

    Tuesday, December 09, 2008 9:00 AM
  • Ive never posted on one of the technet forums before. I tend to read, soak up the info and then try to fix but on this occasion i thought it was worth the post. Many thanks to Sonny1 for posting the fix. I lost total connectivity yesterday after removing an old site which i thought was defunct. In fact it had the heirarchy hidden in it, so to say yesterday was a stressful day was an understatement when 1200 mailboxes could't connect!!!!. Again, thanks.
    Thursday, April 09, 2009 8:26 AM
  • Sonny1 you are a legend! Saved my bacon! Been sweating (swearing) over the last hour that I'd have to rebuild the old Ex2k3 server in a VM server to get all the public folders back!

    Worked for me!

    Thanks,

    Griff
    Sunday, June 14, 2009 10:20 AM
  • Well I guess we all had the same problem.  Removed Exhange E2K3 server and public folders disappeared from Exhange 2007.  Thanks for the concise fix.
    Monday, October 12, 2009 3:53 AM
  • This article worked perfect and saved my Office 2003 clients, Office 2007 clients were still able to connect.

    Thanks again.
    Thursday, October 15, 2009 9:06 PM

  • Thank you very much for your support.

    Everybody can trust this post becasuse this post 100% supported me.

    Wednesday, December 16, 2009 5:39 PM
  • This is one 100% perfect solution :)
    Thanks for posting it.
    Sunday, December 20, 2009 4:37 PM
  • 10x a lot, it still works!
    msExchOwningPFTree can be found under
    Configuration -> Configuration -> Services -> Microsoft Exchange -> your Exchange organization -> Administrative Groups -> the Exchange 2007 administrative group -> Servers -> the server containing a store -> Information Store -> your storage group
    Wednesday, February 17, 2010 10:40 AM
  • Great help, thanks!

    However, the path for the msExchOwningPFTree attribute in Exchange 2010 is different: Configuration ⇒ Services ⇒ Microsoft Exchange ⇒ <Exchange Organization> ⇒ Administrative Groups ⇒ <Exchange 2010 Administrative Group> ⇒ Databases ⇒ <Public Folder Database>

    Also, it is sufficient to restart the Exchange SA service instead of the Information Store.


    I posted aggregated instructions on my blog:
    http://www.vware.at/?p=169
    Wednesday, February 17, 2010 3:06 PM
  • Sonny very nice steps
    Friday, April 09, 2010 6:21 PM
  • Thank you Sonny1

    3 years later, this post helped us resolve missing Public Folder Hierarchies in Exchange 2007 for a client.

    We blogged our experience here http://wintivity.wigital.net/exchange/exchange-2007-public-folder-adsi-heirachy-causes-outlook-failure-cannot-connect/

     

    Thank you for your insights.

    Mark Raborn
    WIGITAL


    always to the glory of God
    Wednesday, April 14, 2010 1:54 PM
  • Thank you Sonny1

    3 years later, this post helped us resolve missing Public Folder Hierarchies in Exchange 2007 for a client.

    We blogged our experience here http://wintivity.wigital.net/exchange/exchange-2007-public-folder-adsi-heirachy-causes-outlook-failure-cannot-connect/

     

    Thank you for your insights.

    Mark Raborn
    WIGITAL


    always to the glory of God
    Wednesday, April 14, 2010 2:01 PM
  • July 10-2010

    Thanks a ton Sonny.

    I was cleaning out the old 2k3 servers and referances to stores that no longer existed and blew up our mail system.....

    Luckily i googled the error that got me here and your fix nailed the problem.

    kurt

    Saturday, July 10, 2010 8:33 PM
  • Rock On!

    Thanks Sonny1, this saved my bacon, and on SysAdmin appreciation day as well.

    Friday, July 30, 2010 6:01 PM
  • Hi Sonny: your solution ROCKS!
    Diego Castelli ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 13, 2010 11:01 AM
  • Best fitted to my scenario.

    thanks alot.

    Thursday, February 10, 2011 7:21 AM
  • My case was for exchange 2010. I studied the cause effect and found out that it was done by not only removing the EX2K3 servers but mainly because of roll-on 1 and 3. So all please be cautious before applying these 2 roll-outs from Microsoft, they normally give this problem for migration cases. I wasted a few nights, users were still able to connect, I lost control over recieve connectors and public folders, they all just disappeared.

    Sonny thanks again, your solution was for the public folder, the other one was because of Legacy account being deleted, which gives error Exchange group was deleted, for that the best solution was also from technet. i just had to use Ldp.exe and find Administrative group and my Admin group, in the properties just deleted the otherwellknown value and it rocked just like the post said. so thanks to technet, which gives the platform for so many well worked solutions.

    Thursday, February 10, 2011 7:31 AM
  • Awesome...  I was panic stricken when I removed the old exchange 2003 info using ADSIEdit. The Help Desk was reporting that Outlook 2003 clients couldn't connect with outlook 2003.  my Outlook 2010 lost connection to the public folders.  I stoped the public folder store and it would not restart. the fix you listed above fixed the issue the store would mount. and Outlook 2003 clients could connect... 
    Monday, March 21, 2011 5:51 PM