none
Can't upload multiple files in Sharepoint. RRS feed

  • Question

  • We have a user that is using Office 2013 Professional Plus 32 bit version & Internet Explorer 9.  The option for Upload Multiple Files is grayed out.  I tried uninstalling/reinstalling Office 2013 and it doesn't work.  I turned off protected mode in both the 32 bit & 64 bit versions of IE9 and still she can't access it.

    Is there another component or add-in that needs to be installed? 

    Tuesday, December 10, 2013 9:54 PM

Answers

  • (Changing Protected Mode is how you go from 32 to 64bit)

    Make sure the IE control, STSUpld.UploadCtl is loaded in the browser.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by MikeK321 Sunday, November 1, 2015 3:18 PM
    Tuesday, December 10, 2013 10:07 PM
    Moderator
  • We finally got it fixed.  There is a stsupld.dll hotfix but I think loading .net framework 4.5 helped.  Thank you! 
    • Edited by MikeK321 Thursday, December 12, 2013 8:15 PM
    • Marked as answer by tracycaiModerator Monday, December 16, 2013 10:01 AM
    Thursday, December 12, 2013 4:51 PM
  • Make certain that she's not using the 64-bit version of IE9. Only the 32-bit version of Internet Explorer 9 can take advantage of the Office integration add-ins.
    • Marked as answer by MikeK321 Sunday, November 1, 2015 3:18 PM
    Tuesday, December 10, 2013 9:57 PM

All replies

  • Make certain that she's not using the 64-bit version of IE9. Only the 32-bit version of Internet Explorer 9 can take advantage of the Office integration add-ins.
    • Marked as answer by MikeK321 Sunday, November 1, 2015 3:18 PM
    Tuesday, December 10, 2013 9:57 PM
  • It doesn't work in both versions.
    Tuesday, December 10, 2013 10:06 PM
  • (Changing Protected Mode is how you go from 32 to 64bit)

    Make sure the IE control, STSUpld.UploadCtl is loaded in the browser.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by MikeK321 Sunday, November 1, 2015 3:18 PM
    Tuesday, December 10, 2013 10:07 PM
    Moderator
  • I've read a couple kb articles and that control is loaded.  I've disabled & enabled it and that doesn't seem to fix it. 
    Tuesday, December 10, 2013 10:08 PM
  • Is Silverlight also installed and loaded? Also check for the SharePoint OpenDocument Class and SharePoint Stssync Handler controls.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, December 10, 2013 10:13 PM
    Moderator
  • Silverlight probably isn't installed on her pc but I will update it and check the other controls.  Thanks! 
    Tuesday, December 10, 2013 10:24 PM
  • Actually Silverlight is installed but the Sharepoint Opendocument class & Sharepoint Stsync handler controls are not in the list of Addon's.  Does InfoPath or something else need to be installed? 

    Wednesday, December 11, 2013 3:24 PM
  • You can install SharePoint Designer to get this functionality, if you need to do it for free. During the Office 32bit install, you need to select "SharePoint Support". It is under the optional section.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, December 11, 2013 3:59 PM
    Moderator
  • We may have disabled that option when we pushed it out to staff & faculty.  I will check that.  Thanks!
    Wednesday, December 11, 2013 4:01 PM
  • I checked the computer and it looks like Sharepoint support is installed.  I tried uninstalling it using X Not Available and reinstalling Sharepoint Support but the Upload Mulitiple Files option is still grayed out.  Very bizzare. 
    Wednesday, December 11, 2013 4:46 PM
  • did you restart your PC( i mean affected) after all the workaround?

    what i learnt from the post.

    You checked office directory saw the STSUPLD.dll is avaiable & STSUpld.UploadCtl control is enabled.(http://social.technet.microsoft.com/wiki/contents/articles/11234.sharepoint-2010-how-to-enable-uploading-multiple-documents-functionality.aspx)

    Also Silver Light Installed, and SharePoint OpenDocument Class and SharePoint Stssync Handler controls also their.

    you are using the Office 2013 with Sharepoint 2010.

    one more thing check if WebCLient services is running, if yes try to restart it. its in services console.




    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog


    Wednesday, December 11, 2013 5:05 PM
    Moderator
  • Latest version of Silverlight is installed.  All the controls (OpenDocument class, Stysync Handler, StsuploadCTL)and are enabled.  We are using Office 2013 & Sharepoint 2010. 

    Wednesday, December 11, 2013 5:09 PM
  • also check this blog, mentioned various fixes, i am sure you already applied couple.

    http://sharepointknowledgebase.blogspot.com/2013/09/upload-multiple-documents-is-disabled.html


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Wednesday, December 11, 2013 5:10 PM
    Moderator
  • Hi.

    Try this site here: http://qazimobeen.wordpress.com/2012/10/03/sharepoint-multiple-files-upload-feature/


    Rafael Nunes SharePoint Dev & Admin - MCTS (SP2010)

    Wednesday, December 11, 2013 8:16 PM
  • I don't have access to server side settings but I'll check the .NET framework software.  Thanks!
    Wednesday, December 11, 2013 8:20 PM
  • Hi,

    This issue could be corruption of the STSUPLD.DLL. You can rename the client STSUPLD.dll and do an office repair and check if it brings the functionality for uploading multiple documents.

    Additional, see (http://support.microsoft.com/kb/2691367) that suggest checking for missing permissions on the STSUPLD.DLL file in Office folder and IE add in of STSUpld UploadCtl Class. Check IE and verify if the IE add in is there.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Thursday, December 12, 2013 8:44 AM
    Moderator
  • I renamed the stsupld.dll file and ran a repair but that doesn't seem to help.   I checked and her domain account has admin permissions to C:\Program Files (x86)\Microsoft Office and C:\Program Files (x86)\Internet Explorer.  Her account actually has admin permission because of some of the MNSCU (Minnesota State Colleges & Universities) applications she has to use require admin permissions.  Still stumped.

    Thursday, December 12, 2013 2:54 PM
  • The user has full permissions to c:\program files x86\Microsoft Office\  and there is a stsupld.dll and a name.dll but there is no mso.dll file at all. 
    Thursday, December 12, 2013 4:46 PM
  • MSO.dll is located in C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE15\.

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, December 12, 2013 4:47 PM
    Moderator
  • We finally got it fixed.  There is a stsupld.dll hotfix but I think loading .net framework 4.5 helped.  Thank you! 
    • Edited by MikeK321 Thursday, December 12, 2013 8:15 PM
    • Marked as answer by tracycaiModerator Monday, December 16, 2013 10:01 AM
    Thursday, December 12, 2013 4:51 PM
  • Perfect.! I had the exact same situation for only a handful of users which drove me mental trying to figure out where does the problem lie as it worked flawlessly for rest of the users in the company. So, resolved the issues by installing .net framework 4.5 Thankyou for sharing your tip.

    We have SharePoint2010 Server Standard & Office 2013 on Windows 7 SP1.

    Thursday, August 6, 2015 9:01 AM