locked
Outlook 2007 keeps prompting for credentials

    Question

  • I've seen so many articles on this and it still plagues me.  I've had enough.

    I am in a pure Exchange 2007 environment.

    SCC Mailbox Server

    Hub & CAS are on a different Server but together.

    Outlook 2007 is installed on my workstation.

    I setup a profile using the auto-discover process (default) and I am prompted for a passwrod to my hub and CAS?  I enter in the CORRECT credentials and I am prompted again.  Remembering months ago that I was unable (or unwilling) to resolve this annoyance I hit cancel and chose to set it up manually.  this worked using the Exchange Clustered Mailbox name.

     

    As soon as the profile is setup and I am into Outlook I'm prompted again! wow, what is this? I enter in the CORRECT credentials AGAIN and i am repeatedly prompted.  after hitting cancel 30 times i continue on with my work. 

    ..but then I close and re-open Outlook, same process all over again.  the Windows prompt is prompting me for creds on domain.com (my domain)  what is going on here.  i have not even had a chance to configure (break) anything....is this default behaviour for exchange 2007/Outlook 2007?  I know I am missing something here but I just can't seem to get around this.

     

    I have tried most MS KB articles out there (can't find the links to provide)

    Yes, I'm on the Domain

    Yes, I have decided to set it up manually and chose not to use Auto-discover, which to me at this point is a terrible feature. 

    Yes, my bottom right corner of Outlook 2007 says "Online with Microsoft Exchange"

    Outlook 2003 clients do not have this problem which tells me this is something in Outlook.  I can uninstall Outlook 2007 and replace it with Outlook 2003, same workstation, same user logged in with no problems.

     

    Whats going on here?

    thanks

     

    Wednesday, November 14, 2007 1:24 AM

All replies

  • I think i have had a similar problem, i found that if you put the domain first then your username it solved the problem.  so domain\username and then your password as normal.

     

    Hope this helps

     

    Andrew

    Tuesday, December 11, 2007 11:05 AM
  • Im having the same issue. It was working fine untill i went trying to fix a cert issue for autodiscover. We do not get the cert warning anylonger but users on 2007 are being aked for user name and password. They can cancel and everthing appears to work fine.

     

    Thursday, December 27, 2007 5:04 PM
  • I went so far as to format and install Vista / Outlook 2007 fresh.  I used the manual profile setup and during the first synchronization it started again.  Using Exchange 2007/Outlook 2007.

     

    Notes:

    • I am using exchange active sync on my mobile phone (direct push).
    • Roaming user profile with GPO folder redirection including AppData.
    • The following event is logged on logoff:

    Log Name:      Application
    Source:        Microsoft-Windows-User Profiles Service
    Date:          1/14/2008 4:21:13 PM
    Event ID:      1530
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          SYSTEM
    Computer:      MCAD01.btcorp.com
    Description:
    Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards. 

     

    I do not know if any of these are the cause or contributor.

     

    -Rich E. Staples

    Tuesday, January 15, 2008 7:46 PM
  •  

    I found on mine at least that a SSL cert was required. Godaddy has one that i had to get reissued 3 time to work but was only $59 called a UCC cert it alled multi domain names on the cert so autodiscover.domain.com, mail.domain.com .ect installed using the powershell and it resolved my issue.
    Wednesday, January 16, 2008 3:51 PM
  •  

    I have a feeling that buying a 3rd party Cert will also resolve my issue, so I agree.  However, what if you were iona development/pilot environment doing proof of concept?  what if you were in a secure network where no public access was allowed?  why would you want to buy an SSL Cert for these scenarios?  I hope Microsoft is not requiring a public cert for all deployments.

     

    Thanks  to all for you're replies, the last resort is buying a cert, but this issue still plagues me.

    Saturday, January 19, 2008 4:39 PM
  • Except for the computer name and date given by Rich Stapels his posting applies equally to me.

     

    Alwyn Stroh

     

    Thursday, May 29, 2008 12:41 PM
  • A long overdue update.....drumroll please......DNS.

    Our internal DNS /DHCP client registration updates had some bad records.  Once I resolved them the Outlook client logon problems dissapeared.

    My foot is not tasty.

    -Rich
    Rich E. Staples
    • Proposed as answer by Rich Staples Friday, April 24, 2009 2:58 PM
    Friday, April 24, 2009 2:58 PM
  • Any way you could be more specific?
    Friday, August 21, 2009 6:01 PM
  • I got kind of a same issue, except that if i give user domain admins rights it works with no issues, as soon as i take off the administrator rights it starts asking for credentials.
    Thursday, August 27, 2009 4:23 AM
  • Rich,
    Can you be a little more specific as to what kinds of internal DNS/DHCP update problems you were having? This problem has been a thorn in our side for some time now and I sure would like to put it behind us.

    Monday, August 31, 2009 11:06 PM
  • Hey guys   ... this worked for me: -

    http://support.microsoft.com/kb/956531

    Keep well.

    Junior out.
    • Proposed as answer by JuniorM Friday, December 25, 2009 12:47 AM
    Friday, December 25, 2009 12:46 AM
  • Hello,

    1. Make Sure Outlook is close
    2. Then go to start/settings/Control Panel
    3. Double Click on Mail/Then E-mail accounts
    4. On the email tab highlight your username(Exp. example@abc.com) and hit Change
    5. Then Click on More Settings/Connection/Exchange Proxy Settings
    6. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the sstd:webmail.covad.com box will go grey.
    7. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    8. Open Outlook and Put in Domain\(Your username) and password.

    Hope below Microsoft Support link also help:
    http://support.microsoft.com/kb/956531


    Have a good year, Sachin Shetty| MCP|MCTS|MCITP| Please mark it as Answered and Vote as helpful. If you feel your question was truly answered, Thank you in advance.
    Saturday, January 30, 2010 7:13 PM
  • Hello,

    1. Make Sure Outlook is close
    2. Then go to start/settings/Control Panel
    3. Double Click on Mail/Then E-mail accounts
    4. On the email tab highlight your username(Exp. example@abc.com) and hit Change
    5. Then Click on More Settings/Connection/Exchange Proxy Settings
    6. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the sstd:webmail.covad.com box will go grey.
    7. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    8. Open Outlook and Put in Domain\(Your username) and password.

    Hope below Microsoft Support link also help:
    http://support.microsoft.com/kb/956531


    Have a good year, Sachin Shetty| MCP|MCTS|MCITP| Please mark it as Answered and Vote as helpful. If you feel your question was truly answered, Thank you in advance.
    Saturday, January 30, 2010 7:14 PM
  • Rich ,

    Please try the below steps.

    1. Make Sure Outlook is close
    2. Then go to start/settings/Control Panel
    3. Double Click on Mail/Then E-mail accounts
    4. On the email tab highlight your username(Exp. example@abc.com) and hit Change
    5. Then Click on More Settings/Connection/Exchange Proxy Settings
    6. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the sstd:webmail.covad.com box will go grey.
    7. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    8. Open Outlook and Put in Domain\(Your username) and password.

    Hope below Microsoft Support link also help:
    http://support.microsoft.com/kb/956531


    Have a good year, Sachin Shetty| MCP|MCTS|MCITP| Please mark it as Answered and Vote as helpful. If you feel your question was truly answered, Thank you in advance.
    Saturday, January 30, 2010 7:14 PM
  • Muhammas,

    Please try the below steps.

    1. Make Sure Outlook is close
    2. Then go to start/settings/Control Panel
    3. Double Click on Mail/Then E-mail accounts
    4. On the email tab highlight your username(Exp. example@abc.com) and hit Change
    5. Then Click on More Settings/Connection/Exchange Proxy Settings
    6. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the sstd:webmail.covad.com box will go grey.
    7. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    8. Open Outlook and Put in Domain\(Your username) and password.

    Hope below Microsoft Support link also help:
    http://support.microsoft.com/kb/956531


    Have a good year, Sachin Shetty| MCP|MCTS|MCITP| Please mark it as Answered and Vote as helpful. If you feel your question was truly answered, Thank you in advance.
    Saturday, January 30, 2010 7:15 PM
  • Hi Tony, the outlook client  may be connecting to Outlook Anywhere and the Defaul Authentication for OA on CAS is Basic. This info is pushed to the Client using Autodiscover service. Check your Outlook Client settings. you could either disable OA on the client or setup the proper Authentication method on the CAS. Both Authentication methos must match on Client and CAS. Hope this help. thanks.
    Tuesday, November 23, 2010 7:55 PM
  •  

    I agree with cont123

    You can download Outlook 2010. it has great feature , called Test E-mail auto configuration. It will show up, or not all url, that are needed and you will miss those, that are not configured.

    "

    If you have local CA. Create cert. request for that CA.  You can install Root CA to client and smartphone. They will not show error for trusted CA. Then from CAS server request Certificate.

    You can test solution, and be shure, that your official cert. request will incorporate all SAN names.   

    "

    Wednesday, November 24, 2010 7:50 PM
  • I've just had the same problem as this and external test of Exchange autodiscover was coming up fine. Internally it didn't work properly which pointed me towards a DNS issue. I checked the DNS console and somehow a new AD Integrated zone called remote.myexternaldomain.com had appeared. It was pointing the FQDN remote.myexternaldomain.com to the mailserver's internal IP address. I deleted this rogue zone and everything returned to normal.

    I have no idea how a new zone could have been created by itself???

    Kit

    Monday, March 14, 2011 7:07 PM
  • There are a couple of reasons why this could be happening, I have outlined them in my blog post here: http://demazter.wordpress.com/2010/02/09/outlook-continually-prompting-for-username-and-password-2/

    Another potential cause is the authentication setting used on Outlook & exchange, if they do not match then the same problem will be caused when using RPC-HTTPS or Outlook Anywhere, see my blog post here: http://demazter.wordpress.com/2010/11/09/outlook-prompting-for-username-and-password-when-using-exchange-2010/

    Whilst a 3rd part SSL Certificate is not a requirement, it can save a lot of problems when using RPC-HTTPS, and for the sake of $89 for a signed certificate from http://www.exchangecertificates.com is it really worth the hassle?


    demazter

    http://demazter.wordpress.com
    http://www.demazter.co.uk

    Monday, March 28, 2011 7:36 AM
  • ipconfig/flushdns  from the cmd prompt worked for me. No longer have this issue

    Thursday, June 23, 2011 6:39 PM
  • you asshole. you're one in a long line of people who just give a vague answer and expect the rest of us to magically know what you're talking about. fuck you.
    Thursday, August 18, 2011 4:32 PM
  • Know this is years old but thanks Panda1980, domain\username worked for me today.

    Wednesday, February 29, 2012 6:44 AM
  • That's the answer but i also found that you can do it with Outlook still open and making the changes in account settings. 

    After you close and start outlook again, the Proxy settings are added automatically. 

    Tuesday, May 22, 2012 12:48 PM
  • i solve this problem with this

    Kernel authentication Mode

    If you have all the above configured and you are still experiencing problems then the following procedure will more than likely fix it for you. It has been working a lot for me lately and also for people asking questions on Experts Exchange.

    In Internet Information Services (IIS) Manager locate the Exchange virtual directories, if you are using Small Business Server 2008 these will be under the SBS Web Applications website, if your not using SBS then they will be under the Default Website.

    The virtual Directories you are looking for are:

    1. Autodiscover
    2. EWS
    3. RPC
    4. OAB

    In turn highlight each of these virtual directories and double click the Authentication icon on the right hand side. Right click on Windows Authentication and select Advanced Settings. Place a check box in the box for Enable kernel-mode authentication. Do this for each virtual directory listed above.

    http://demazter.wordpress.com/2010/02/09/outlook-continually-prompting-for-username-and-password-2/

    Wednesday, May 14, 2014 9:28 PM