none
Can't map sharepoint in explorer (map network drive)

    Question

  • Hi , i've finished installing sharepoint 2007 enterprise on a windows server 2003.

    Next to this, I would like to map a network drive , more specific a URL.
    But when using the explorer, using map network drive, or using the wizard to connect with http: sites, it doesn't work.
    The you entered doesn't appear to be valid

    My sharepoint is simply installed at http://localhost/sites/ddc

    When I want to connect to another sharepoint site, which i have also done from my local desktop succesfully, the same issue happens.

    Is there a specific service/setting in windows server 2003 or sharepoint which is required to enable this?
    Business Intelligence professional
    Wednesday, November 25, 2009 9:02 PM

Answers

  • Sounds like you don't have WebDAV enabled on the machine your using.  Windows Server 2003 doesn't have WebDAV enabled by default.  To enable it, goto Computer Management -> Services and make sure that "WebClient" is started, otherwise you won't be able to map a drive to a SharePoint site.
    Tony Testa www.tonytestasworld.com
    • Marked as answer by GuYuming Friday, December 4, 2009 3:03 AM
    Thursday, November 26, 2009 2:08 AM
  • So, you've added the desktop experience feature.  Have you confirmed that the WebClient service is running?  This service is installed when you add the desktop experience.  Have you also tried mapping a drive from a command prompt?  For example,

    net use t: http://localhost/sites/ddc


    Randy - http://sharepointhawaii.com/randywilliams
    • Marked as answer by GuYuming Friday, December 4, 2009 3:04 AM
    Friday, November 27, 2009 9:58 AM

All replies

  • Hi,

    it's enabled using WebDav and you should be able to use that right away.

    Check your IIS settings and make sure that WebDav is allowed.

    Here's the step to map the drive:

    Windows Explorer > Select Tools / Map Network Drive > Select your drive letter > Under Folder : enter your url to your document library such as "http://sharepoint/Shared Documents"

    Cheers,
    Daniel Bugday

    Web: SharePoint Forum Blog: SharePoint By Bugday

    Wednesday, November 25, 2009 10:38 PM
  • Sounds like you don't have WebDAV enabled on the machine your using.  Windows Server 2003 doesn't have WebDAV enabled by default.  To enable it, goto Computer Management -> Services and make sure that "WebClient" is started, otherwise you won't be able to map a drive to a SharePoint site.
    Tony Testa www.tonytestasworld.com
    • Marked as answer by GuYuming Friday, December 4, 2009 3:03 AM
    Thursday, November 26, 2009 2:08 AM
  • Hi people,

    I found out webdav is unnecessary. Sharepoint 2007 automatically propagates this when you click the desktop experience feature when I look at several posts.

    Sadly, it still doesn't work ,even with webdav, even with desktop experience feature installed

    thanks

    Business Intelligence professional
    Thursday, November 26, 2009 8:59 PM
  • I agree with Tony that you should make sure the WebClient service is started in Computer Management -> Services. And the WebDav setting in IIS is not relevant for your issue.

     

    Why do you mention Desktop Experience feature? It is new in Windows Server 2008.

    Friday, November 27, 2009 1:20 AM
  • I have made a mistake, in my first post i mentioned windows server 2003 but am working at windows server 2008.

    Sorry for this.

    Anyway it should work with the desktop feature enabled, but it doesn't run as an application server
    Business Intelligence professional
    Friday, November 27, 2009 9:34 AM
  • So, you've added the desktop experience feature.  Have you confirmed that the WebClient service is running?  This service is installed when you add the desktop experience.  Have you also tried mapping a drive from a command prompt?  For example,

    net use t: http://localhost/sites/ddc


    Randy - http://sharepointhawaii.com/randywilliams
    • Marked as answer by GuYuming Friday, December 4, 2009 3:04 AM
    Friday, November 27, 2009 9:58 AM
  • Make sure that you are running Service Pack 2 for Windows 2008.


    Cheers,
    Daniel Bugday

    Web: SharePoint Forum Blog: SharePoint By Bugday

    Friday, November 27, 2009 12:39 PM
  • Hi,

    I've enabled desktop experience feature.
    Mapping a local drive works, mapping my sharepoint site doesn't work. I also tried to map to a sharepoint portal external, which I can do  from my client PC, but also doesn't work at the server.

    What causes the specific URL non-mappable behaviour? i'm confused.
    I'm using win2008 service pack 2
    Business Intelligence professional
    Tuesday, December 1, 2009 1:28 PM
  • I'm trying to eliminate the obvious here, but the account your logged into the server with, does it have access to the SharePoint site your trying to connect to?  If you log into the server with the SharePoint admin account and try to map a drive to the site do you get the same issue?
    Tony Testa www.tonytestasworld.com
    Tuesday, December 1, 2009 3:40 PM
  • Hi This is sharif

    I couldn't map the sharepoint drive.

    Please help me step by step.

    Tuesday, March 5, 2019 4:00 PM