none
Extra Columns in Excel (OneNote)

    Question

  • Hi community,

    I am working on an Excel sheet in OneNote 2013 (Insert -> Spreadsheet).

    OneNote embeds and shows the Workbook properly, except that some extra columns are visible on the right, which are empty and I don't want to see them.

    I have tried to resize the area, however it actually resizes the container of Excel workbook, distorting the font size and making it hard to read.

    Is there any way to set/limit the number of Excel workbook columns OneNote displays?

    Thanks in advance.

    Monday, June 03, 2013 12:49 PM

Answers

  • I have found a way to hide the extra columns that OneNote displays when an Excel document is embedded. All you have to do is hide all columns to the right of what you want to be displayed.  For instance, If I only want columns A-D to be displayed in OneNote, I need to hide columns E-XFD (This is for Excel 2013 which allows a maximum of 16,384 columns. For versions of excel before 2007 the last column is IV).

    The easiest way to hide all columns:

    1. Select the first column you want to hide by clicking on its header.

    2. Press END to enter end mode.

    3. Hold SHIFT and press RIGHT-ARROW. Release SHIFT.

    4. Right-Click any of the selected cells and select Hide.

    You can do the same with rows below what you want displayed, although I have never had a problem with OneNote displaying empty rows.

    • Proposed as answer by BunchOfSage Tuesday, April 01, 2014 4:05 PM
    • Marked as answer by Omid Shojaee Tuesday, November 18, 2014 2:30 PM
    Thursday, January 23, 2014 4:28 PM
  • Hi,

    Based on my research and test, it seems that it is by design in OneNote 2013.

    And there is no option to change the display range.


    Jaynet Zhang
    TechNet Community Support

    Tuesday, June 04, 2013 3:04 AM
    Moderator

All replies

  • Hi,

    Based on my research and test, it seems that it is by design in OneNote 2013.

    And there is no option to change the display range.


    Jaynet Zhang
    TechNet Community Support

    Tuesday, June 04, 2013 3:04 AM
    Moderator
  • I have found a way to hide the extra columns that OneNote displays when an Excel document is embedded. All you have to do is hide all columns to the right of what you want to be displayed.  For instance, If I only want columns A-D to be displayed in OneNote, I need to hide columns E-XFD (This is for Excel 2013 which allows a maximum of 16,384 columns. For versions of excel before 2007 the last column is IV).

    The easiest way to hide all columns:

    1. Select the first column you want to hide by clicking on its header.

    2. Press END to enter end mode.

    3. Hold SHIFT and press RIGHT-ARROW. Release SHIFT.

    4. Right-Click any of the selected cells and select Hide.

    You can do the same with rows below what you want displayed, although I have never had a problem with OneNote displaying empty rows.

    • Proposed as answer by BunchOfSage Tuesday, April 01, 2014 4:05 PM
    • Marked as answer by Omid Shojaee Tuesday, November 18, 2014 2:30 PM
    Thursday, January 23, 2014 4:28 PM
  • Thanks, this worked great.
    Thursday, February 20, 2014 6:47 AM
  • I have a similar problem as I use a fair number of embedded spreadsheets to track a lot of information.  Sometimes there are a lot of extra columns off to the right hand side whether I want or need them. 

    The other problem I am having is that when I save my spreadsheet, OneNote resizes the embedded view to be several times larger than the original.  This resize is not based on the zoom level, and the only way to fix this is to right-click on the "Edit" of the spreadsheet and tell it "Restore to Original size".  The odd thing is, it doesn't do this to every spreadsheet, only some of them.

    Is there any way to keep it from resizing my spreadsheet randomly when I save it?  I know I am not telling it to resize anything, it just happens whenever it feels like it.

    This seems like a bug that should have been fixed a long time ago.

    Friday, May 01, 2015 7:02 PM
  • In Office 2016 (not sure about 2013), create/format your data in a Table range.  Right clicking on the embedded spreadsheet in OneNote allows you to display everything or just certain assets, like Tables.  One Note then just displays the exact range.

    http://i.imgur.com/cUE6Hab.png


    • Edited by BobC_UK Tuesday, November 24, 2015 10:55 AM
    Tuesday, November 24, 2015 10:55 AM
  • Spot on! I was having the same issue and hid all the blank cells and now only the desired content is displayed on OneNote!

    Thursday, June 23, 2016 3:30 PM
  • OneNote 2016:

    Right click on the table (picture)

    Choose crop

    You can then adjust the size of the table picture.

    Monday, June 05, 2017 6:46 PM
  • Genious! Thanks so much, this worked.
    Thursday, June 15, 2017 3:50 PM