none
Fix "Title" Content Type RRS feed

  • Question

  • Hello,

    A while ago I accidentally altered the "Title" content type in MOSS.  It is now listed across the whole site collection in various web parts as "_Title" instead of "Title." 

    Does anyone know how to fix it?  In Item (content type) it says that the column name is reserved or already in use.

    Thanks!
    I hear and I forget. I see and I remember. I do and I understand.
    Friday, October 2, 2009 5:06 PM

Answers

  • I found this blog that explains how to change it (also using PowerShell) - I'm going to give it a try.

    http://blogs.inetium.com/blogs/bcaauwe/archive/2008/07/25/omg-where-did-my-quot-title-quot-go.aspx


    Just wanted to add that the script in the blog solved my problem with this line: 

    In order to change it back to, simply modify $field.Title = "Title" and process a $field.Update().  Below is a sample set of calls to reset the field back to "Title".

    **I did have to manually change all of the MOSS columns in each list to "Title," but it no longer gave that dreaded message ("The column name that you entered is already in use or reserved.  Choose another name.") anymore!
    I hear and I forget. I see and I remember. I do and I understand.
    • Marked as answer by buchay2019 Thursday, October 8, 2009 4:40 PM
    Thursday, October 8, 2009 4:39 PM

All replies

  • Can you clarify how you altered the Title content type?  If you specify the exact steps you took, we may be able to come up with a solution for you.

    Andre Galitsky, MCTS, Lexington, KY -- My SharePoint Blog: http://www.sharepointnomad.com
    Friday, October 2, 2009 6:26 PM
  • I can't remember where exactly I made the change - it was a long time ago (sorry).

    I do know that I typed in an underscore _ when changing the name of a column.  At the time I didn't know that it would change the column names for EVERYthing though! 

    I do know that it wasn't in the "Item" content type, because it won't allow me to change it there - is there a way to find which content type is reserving/using it ("Title")?  I've already clicked everything possible...

    Thanks again! 


    I hear and I forget. I see and I remember. I do and I understand.
    Friday, October 2, 2009 6:35 PM
  • It seems that you altered the base element of most of the lists.
    This , on it's own. is not so bad.

    However, somewhere in your portal, some used the name "Title" for a different column.
    And that's where that problem arrizes.

    Find the list(s) that have a Title column, rename that column and then you can change _Title back to Title.

    For future reference: it's better to change it at list level.
    Then the title is changed insted of the whole item

    Kind regards,
    eric
    Willing to learn everything about Sharepoint there is to learn. My blog : sharepoint.vanglabbeek.nl
    Sunday, October 4, 2009 7:39 PM
  • I agree with Eric - you are likely using "Title" column name somewhere else, and that's why you can't change it back at the item level.

    The following PowerShell script can be employed to find out which lists are using the "Title" column.  Remember that the comparison is case-sensitive.  You can easily tweak the script to search for other column names.

    [System.Reflection.Assembly]::Load("Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c") | out-null 
    
    [void][System.reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint") 
    
    # set-up working variables...
    
    # Enter your SharePoint site collection URL here...
    
    $TargetSiteUrl = "http://sharepoint_site_collection_URL" 
    
    
    # Enter the list column name you want to find here...
    
    $FieldToFind = "Title"
    
    # Starting search
    
    write-host "FieldName, ListName, ListURL"
    
    $spSite = new-object Microsoft.SharePoint.SPSite($TargetSiteUrl) 
    
    $colWebsites = $spSite.AllWebs
    
    foreach ($web in $colWebsites)
    {
    
    $colLists = $web.Lists
     
    foreach ($list in $colLists)
    {
    
    $fields = $list.Fields
    
    foreach ($item in $fields)
    {
    
    If ($item.Title.Contains($FieldToFind)) 
    {
    write-host  $item.Title, ";", $list.Title, ";", $list.DefaultViewUrl
    }
    
    }
    
    }
    
    }
    
    write-host "Finished."
    
    
     
    

     






    Andre Galitsky, MCTS, Lexington, KY -- My SharePoint Blog: http://www.sharepointnomad.com
    Monday, October 5, 2009 1:21 PM
  • Andre - your post helps to find the "Title" columns, but not how to change it.

    I found this blog that explains how to change it (also using PowerShell) - I'm going to give it a try.

    http://blogs.inetium.com/blogs/bcaauwe/archive/2008/07/25/omg-where-did-my-quot-title-quot-go.aspx

    Thanks, guys!


    I hear and I forget. I see and I remember. I do and I understand.
    Thursday, October 8, 2009 4:08 PM
  • I found this blog that explains how to change it (also using PowerShell) - I'm going to give it a try.

    http://blogs.inetium.com/blogs/bcaauwe/archive/2008/07/25/omg-where-did-my-quot-title-quot-go.aspx


    Just wanted to add that the script in the blog solved my problem with this line: 

    In order to change it back to, simply modify $field.Title = "Title" and process a $field.Update().  Below is a sample set of calls to reset the field back to "Title".

    **I did have to manually change all of the MOSS columns in each list to "Title," but it no longer gave that dreaded message ("The column name that you entered is already in use or reserved.  Choose another name.") anymore!
    I hear and I forget. I see and I remember. I do and I understand.
    • Marked as answer by buchay2019 Thursday, October 8, 2009 4:40 PM
    Thursday, October 8, 2009 4:39 PM
  • Hi ,

    how to enable Title Column in  document library in edit form.aspx.. but  it will be showing some files (.doc,.txt..) but it will not showing an .aspx extension files . it is any problem for .aspx extension files. how to fix it?  In Item (content type) ...

    Friday, February 1, 2013 2:08 PM
  • Hi, The Title Column is not showing in edit form.aspx  for .aspx files .The Title Filed is not showing for Logo pages.aspx files..but the reaming files it will be displaying.. what is probalm for that one


    • Edited by PS_L Monday, February 4, 2013 9:46 AM
    Monday, February 4, 2013 9:40 AM