Win 2003 EE Cluster - When adding 2nd node - Error 0x800706ba - RPC Server is unavailable


  • Hi Everyone -

    I'm  new to the cluster thing and thought everything was going smooth until I tried to add my 2nd node today, error details are below.  Any ideas?  Thank you -

    Date:  6/29/2007
    Time:  2:55:58 PM
    Computer: autism-cs02.autism.washington.edu
    Major Task ID: {7C5F0774-1611-42B5-AF3C-6E124AC4D36B}
    Minor Task ID: {3222E708-EEF3-4667-8CCE-BB0C9223130E}
    Progress (min, max, current): 0, 2, 2
    Adding this node to the cluster.
    Status:  0x800706ba
    The RPC server is unavailable. 
    Additional Information:
    For more information, visit Help and Support Services at http://go.microsoft.com/fwlink/?LinkId=4441.


    Friday, June 29, 2007 10:03 PM

All replies

  • That means there's a connectivity problem. Can you `net view` both machines in the cluster?

    Another thing to check is if the Firewall service is blocking any of the network traffic between the two nodes.



    Tuesday, July 03, 2007 11:06 PM
  • I am getting the same error. I added the first node in the cluster without problems, but when trying to add the second node I get the RPC server is unavailable with error code 0x800706ba.


    This is in a test lab enviroment and I have added the two machines to a test domain.

    I have setup the public and private adapters to have the same range ip's.


    Any suggestions ?




    • Proposed as answer by Ilya Shick Monday, December 28, 2009 3:37 PM
    Monday, January 07, 2008 1:28 PM
  • Hi Ivan,


    I have pretty much the same suggestions as before:

    -check connectivity (can you ping the other machine by IP?)

    -check name resolution (can you ping the other machine by name?)

    -check authentication (can you `net view` the other machine?)

    -check firewall rules

    -is the first node in the cluster healthy? Does the CSA (cluster service account) have the correct creds in services.msc?


    There may also be IPsec complicating things, but it's less likely in a test environment, since you'd have to specifically enable IPSec.


    For reference, the error code is RPC_S_SERVER_UNAVAILABLE.



    Tuesday, January 08, 2008 2:07 AM
  • Everytime that I have seen this error it has either been a network connectivity problem between nodes with either the public NIC or the private NIC not properly connected or it has been a windows firewall issue. So, turn off the firewalls on all network connections, then try using ping and net view to test the connectivity.


    Good luck.


    Friday, February 01, 2008 6:46 PM
  • Check RpcSs service is started,when you try to add the node from cluadmin-at commant prompt type netstat -n output will show  on which port node1 is comunicating with node2 or not.Try ping,nslookup,ping from fqdn.

    Friday, February 08, 2008 9:48 AM
  • I had this problem building a production cluster - turned out the base Win2k3 EE image had the NIC teaming already configured meaning all nodes had the same MAC address. Dissolving the teaming and recreating fixed the problem.


    Hope this helps someone.




    Wednesday, March 12, 2008 3:54 AM
  • Hi all!

    I had the same problem and I solved it changed computer names in all nodes.

    Then, I joined the computer to domain again. Account computer in the domain is the probem.


    Hope this helps someone too.


    • Proposed as answer by DineshSMehra Saturday, December 12, 2009 6:38 PM
    Sunday, August 24, 2008 12:22 PM
  • Hi all!

    I had the same problem and I solved it perform below steps.


    Problem look like Public NIC configuration need to select Append primary and connection specific DNS suffixes and select Register this connection's addresses in DNS in advance DNS tab And Select Enable LMHOSTS lookup & Enable NetBIOS over TCP/IP in WINS tab.
    Saturday, December 12, 2009 6:42 PM
  • Error on Event viewer is Cluster 0xc00706BA
    The RPC service is not unavailable. Micorsoft Exchange ... c103fc97
    It looks like a strange message
    I spent numbers of hours to find out after System Attendant was failed.
    It is not clear where RPC is failed
    Anyway  I run Microsoft Exchange Server Best Analyzer Tool.
    See connectivity test and see log.
    This log was showning <virtulServer.yourdomain>  remote network access (RPC)  to registry was on wrong path.
    Well, still not clear. But on other hand Domain Controller is connected and verified  remote registry on Exchange server.
    Verifed  access from Registry DC to Exchange and see if DC can recognize your <Virtual Server>.
    In my case I can see this Virtual Server but no connectivity.
    Try to to connect from Run \\VirtualServer\. DC says duplicate name exists 
    Because of this error I found  DNS cache Record was poisoned.
    After deleted IP address, Network Name from cluster and DNS Record from DNS sersers.
    Added new IP address, 'old network name' and DNS record, run second time MESBAT
    to see an error.
    After all System Attendant was added in few seconds. Just needs modify HTTP new IP address in IIS  

    • Proposed as answer by Ilya Shick Monday, December 28, 2009 9:33 PM
    Monday, December 28, 2009 4:04 PM