Windows cannot access the specified device when using Trend Micro 2007



    If you recently did a windows update and are now getting an error message stating "Windows cannot access the specified device, path, or file.  You may not have the appropriate permissions to access the item."  This is when you try any acces programs like office, users, windows firewall etc. 


    I talked to Trend and the solution was to go into the Console and click on Virus and Spyware Control.  Then click on Suspicious software alarm system, go to the exception list and allow explorer.exe or any other common files that might have been denied. 


    Good Luck


    Thursday, August 16, 2007 3:16 PM

All replies

  • Thanks so much, Robert. This did the trick!

    Sunday, August 19, 2007 2:27 PM

    But if I cannot access my programs, I can't open the Trend Micro Console either.  So, then what do we do?  Any ideas?  Thanks!
    Monday, August 20, 2007 8:43 PM
  • Robert


    I would like to thank you from the bottom of my Heart!1


    After trying everything in book from Malware, spyware, viruses and everything else in between.


    Having pulled out most of my hair.


    One I came acroos you message in this forum it worked, and damn am I happy.


    May the gods keep you safe & bless you with good fortune.


    I cant thank you enough


    All the Best



    Sydney, Australia




    Tuesday, August 21, 2007 12:55 PM
  •  RocLaura wrote:


    But if I cannot access my programs, I can't open the Trend Micro Console either.  So, then what do we do?  Any ideas?  Thanks!

    I am in the same place - I would like to go back prior to the update but I can't access anything.

    Thanks - I have searched and searched but found nothing to help since I can't access the Trend console.
    Wednesday, August 22, 2007 12:52 AM
  • Press Ctrl-Alt-Del and open the task manager.  Hold down Ctrl and click File > Run.  This will open a command prompt.  Type "C:\program files\trend micro\internet security 2007\pccmain.exe" (with quotes).  This will open the Trend PC-cillin console.

    Thursday, August 23, 2007 4:36 AM
  • Thank you so much for posting this and the resolution.  It happened to my son last night and the instructions helped me get his computer unlocked.  Trend had denied access to "explorer.exe."  As soon as they allowed access, everything is running as it should. 
      For those who cannot open the Trend console, simply double-click on the blue/white icon in the lower right task bar. Or, right click and select "Open main console."  From there, follow the instructions given in the first post of this thread. 
     I've written to Trend also as they need to find a way not to disable the operating system.  I've used the product for many, many years and this is only the 2nd time I've seen it do something really stupid. 
    Friday, August 24, 2007 3:03 AM
  • This solved my problems.  I can't thank you enough for your help.

    Friday, August 24, 2007 4:25 PM
  • Thanks mate


    You are my hero for the day!!!!!!!!


    Kind regards

     Martin De Jager

    Tuesday, August 28, 2007 12:59 AM
  • You Sir - are a legend! There are dozens of 'fixes'around for this problem - but this worked straight away. I'm just puzzled how an automatic change in Trend Micro could bring my PC to a crashing halt.


    Never mind - many thanks.

    Tuesday, August 28, 2007 10:33 AM

    May the force be with you Robert and the rest of this team. this site really helps and solved the exact problem with detailed instructions. You're the Great! cheers.
    Tuesday, August 28, 2007 8:34 PM
  • It seems this is not just a problem with Trend Micro 2007.  I am currently loading a collection of IBM Rational products and have run across the same problem.  I am not using Trend.  I've also searched the internet and have found this same error come up for many different products.  It seems that if an executable file is selected that has not already been added to the system prior to the update, this error appears.  I would really like some help with this because I'm stopped dead in the water.


    Wednesday, August 29, 2007 2:21 PM
  • Un-install IE Enhanced security from Windows Components, that did it for me on my 2003R2 server. XP doesn't have the same component, but thought I'd post for the 2003 server people looking for the fix. (found it on TechRepublic)

    Wednesday, August 29, 2007 6:33 PM
  • Thanks for the tip


    I have many users who are not really PC friendly and sure enough one had done just as this fix predicted.




    The IT geek for NFP


    Friday, August 31, 2007 2:54 AM
  • Hello Robert,


    You're an absolute star m8. Been rattling my brains and serching the internet for help. Your advice worked perfectly.


    Saturday, September 01, 2007 10:57 PM
  • I did this and when I click Virus and Spyware Controls then Trend goes into a freeze - won't open - won't do anything, so I have to Ctrl-Alt-Del and force it to quit.

    I can't get any further than this step. 

    Thanks to anyone who can help.
    Saturday, September 01, 2007 11:12 PM
  • That worked great. Genuis!!!!!!

    Wednesday, September 05, 2007 4:18 PM
  • When I tried running the suggestion, I received the following message:


    C:\programfiles\trendmicro\internetsecurity2007 refers to a location that is unavailable.  It could be on a hard drive on this computer or on a network.  Check to make sure that the disk is properly inserted, or that you ar econnected to the INternet or your network, and then try again.  If it still cannot be located, the information might have been moved to a different location.


    Now what?


    I am completely frustrated.  I get the "Windows cannot access the specified device...." regardless of what I do or which file, program, etc. I click on.  To check on these forums, I am using my laptop.


    Please help.




    Thursday, September 20, 2007 3:07 AM
  • I have trend micro PC-chillin, and I went to my suspious file. but didn't see the exception list to allow explorer.exe or anything. So what else could I do?

    Friday, September 28, 2007 6:37 AM

    Hi Robert !


    I am a part of the team which provides technical support for HP pavilion and Compaq presario notebooks , for the Australia and New Zealand region. Lately we have been getting a lot of calls with the same error message. We used to scratch our heads to find out the solution until I found the  solution that you provided. It just works fine and has been saving a lot of time on the call. Even the customers are absolutely happy to have their computer working back again. And the whole credit goes only to YOU Robert !

    I thank you very much also on behalf of my whole team.



    Thank you once again !




    Monday, October 01, 2007 7:05 AM
  • You can also try right clicking on the PCCMAIN.EXE file and "run as" administrator as this worked for me but i could not do it ( even logged in as Administrator) vie the other method.


    Thanks for the help - have had this happen on a couple of PCs I support over the last year or so





    Thursday, December 06, 2007 9:39 PM
  •  CBish wrote:

    Press Ctrl-Alt-Del and open the task manager.  Hold down Ctrl and click File > Run.  This will open a command prompt.  Type "C:\program files\trend micro\internet security 2007\pccmain.exe" (with quotes).  This will open the Trend PC-cillin console.


    You can also try right clicking the pccmain.exe and "rum as" administrator as even tho i was logged in as administrator i couldnt get the main console up any other way.




    Thursday, December 06, 2007 9:57 PM
  • Thanks! It is frustrating how a little thing like that can screw up Windows in such a big way!


    Sunday, January 06, 2008 5:26 AM
  • A friend has now encountered the same problem. Vista Home Basic on a new Dell laptop. McAfee Antivirus. No programs can be started now; all attempts bring up "windows cannot access the specified device, path or file. You may not have the appropriate permissions . . . ".


    Like Della, we are completely stuck. Would a windows re-installation be the only solution?

    Tuesday, January 22, 2008 11:46 PM
  • Hi Robert,


    Thanks so much for the post. Saved me from a re-install! Saved me from buying a new laptop (which is what one "computer savvy" mate recommended i do)! Was great, thanks mate!

    Wednesday, February 13, 2008 8:22 AM
  • Thanks a million Robert!!

    I actually have comodo firewall installed and accidentally set 'explorer.exe' and 'rundll32' to be 'isolated applications' instead of 'windows system applications'; when comodo was in training mode!!

    A simple mistake which wouldn't let me click and open any files, programs, control panel whatsover; was getting the 'windows cannot access the specified...' message. but they did open indirectly, if say, you clicked a link in a browser to open a .pdf or .doc file; or using task manager, file, run.

    Was scouring forums, thinking of malware, registry corruption, administrative problems!!.....

    Anyway, Thanks again for the insight...firewalls are indeed fiery...dead useful but dangerous in unskilled hands!!
    Monday, February 18, 2008 8:31 PM
  • This is great, I could not figure out what was wrong with the machine.

    Just an extra note if anyone has lost their Trend password. You can run the pcctools program in the Trend Micro directory which uninstalls without the need for the password.



    Thursday, May 29, 2008 9:53 PM