none
High CPU Usage in Word 2013

    Question

  • Hi everyone,

    I'm having an issue with Word 2013 and I'm hoping someone can help. Seen as I got fleeced for my TechNet subscription this year (the price given on the invoice doubled when I called up to pay!) I’d very much like to see a speedy fix from the Microsofties please! :D

    Recently, I've found that Word will consistently exhibit high CPU utilisation, ~50% on a dual core second generation Core i5.

    This continues, even when I’m not providing any input to or interacting with the Word window and even when the Word window is covered by other windows. Minimising Word causes its CPU usage to drop back down to zero.

    The strange thing is that, so far, I’ve only observed this with a single document. I started writing this document at the start of this week and it’s been authored exclusively on Word 2013. In fact I’m the only one who’s editing it and I’ve only used a single computer (and this one single install of Word 2013) to do so…

    There’s nothing particularly unusual about this document, and a different but similar document which uses the same themes and features (in fact the theme for the second document was created from the first one) doesn’t appear to cause the same issues. Both these documents are stored on SkyDrive, and are being edited directly from there.

    Initially I tried the much recommended tweaks of disabling hardware graphics acceleration and sub-pixel positioning, however neither of these has had any effect.

    I investigated a bit further using Sysinternals Process Monitor, and found that while Word is using a lot of CPU it’s actually looping very, very quickly polling for the existence of the registry key “HKCU\Software\Microsoft\Avalon.Graphics”.

    This key doesn’t exist on my system, and a quick test I conducted where I created it just lead to Word looping polling for more non-existent registry keys.

     

    My system is a HP Folio 13 running Windows 8 Pro x64 with Office 2013 (RTM, not Beta) 32 bit. Both Windows and Office are fully patched, as is everything else on the system.

     

    Thanks in advance for any help anyone can offer.

    Chris

    Friday, March 8, 2013 2:48 PM

All replies

  • Hello again,

     

    After working on my problematic document some more, I believe I’ve found the cause of the issue.

    @Microsofties – I think this one is either a bug or a dodgy OOTB template…

     

    I noticed that the high CPU usage only seemed to occur when the document’s footer was displayed. Experimenting with some careful scrolling and zooming to hide footer (without actually using the “hide white-space” option) seemed to confirm this so I investigated the footer a bit more.

    My document was using the standard Word “Facet (Odd Page)” footer template with a couple of fields added to suit my needs, namely “Publish Date” and a page number.

    The template seems to be structured such that the content of the footer is inside two nested text boxes (one inside the other). I also noticed previously that this footer template also appears to “jump” up each page and back down again as I scrolled.

    So I deleted the footer and its text boxes, and recreated the same content, in the same position (using the standard paragraph alignment tools) by hand without the nested text boxes. This has, so far, fixed the issue!

    I also noticed that the CPU usage dropped right down to idle the moment I deleted the nested text boxes.

     

    Altogether, this leads me to conclude that the “Facet (Odd Page)” footer template in Word 2013 is the source of my issue. Specifically, I believe that the use of nested text boxes in this template causes Word’s interactions with the .Net 4.5 WPF to go a bit nuts, as evidenced by the infinite loop of request for the non-existent “Avalon.Graphics” WPF registry key I mentioned previously.

     

    It would be nice to see some feedback on this one, Microsoft people, if only to know if this is actually a general issue or is specific to my document!

    Thanks, Chris

    Friday, March 8, 2013 3:34 PM
  • Hi Chris,

    This is a quick note to let you know that ng to involve someone familiar with this topic to look at this issue.


    Max Meng
    TechNet Community Support

    Monday, March 11, 2013 3:36 AM
    Moderator
  • Hi Chris,

    Based upon your information, I tried to test this out but was unable to. Could you provide me with exact steps to reproduce your issue?

    Thanks,

    Ross


    Ross - Sr. Support Engineer Microsoft Office

    Tuesday, March 19, 2013 3:23 PM
  • I have the same problem when a footer or header is displayed. I believe the header was created in a previous version of Microsoft Word but cannot say what version.

    The document that is displaying the header is not the same document that I am typing in. When I scroll the header out of view then my typing and cpu performance improve tremendously.

    My header only has two lines of text (company name, ABN) then a horizontal bar across the screen. Deleting the contents of the header did not improve anything.

    I cannot help further as I don't know where else to look for more information.

    Thursday, July 25, 2013 4:14 AM
  • Ross,

    I was able to duplicate the same behavior with the Ion template. It originally had even and odd headers/footers. Once I unchecked that box to make the headers and footers the same regardless of page number, my new Lenovo U430 Touch stalled typing. I was in Print Layout at the time. If I switch to Draft view, CPU goes to 0.

    When I switch to Print view, the lag on everything, including Ribbon activation of the Header contextual tab is significant. My doc is 41 pages long, 2000 words and a ton of graphics.

    If I turn on Different Odd and Even Page header/footer setting again, CPU drops to 0. It's only when I go from different heading/footers to the same header/footer on every page does the CPU peg.

    Hope this helps track down the issue. It's been there since Beta but I could never track down the steps.

    Treb Gatte, Project MVP | @tgatte | http://AboutMSProject.com

    Sunday, October 27, 2013 10:06 PM
  • Thanks for your query, because it helped me find that my high CPU was caused by Word not coping with spelling and grammar checks, so I switched the 'as your type' spelling and grammar options off and fixed my problem.
    Monday, December 23, 2013 12:21 PM
  • Similar issue for except mine occurred while I was typing 

    I got to tell you it had gotten so bad for me as I typed that I watched the CPU usage jump (I have the performance monitor up while working) and there was a major delay as I was typing so I couldn't see what I was typing until several letters later which became frustrating to say the least. I turned of the "as you type" proofing options and everything was fine... I have a similar issue in Outlook and am going to check those options to see what is causing these delays and turn those off as well. Thanks for the help

    Tuesday, January 28, 2014 1:43 AM
  • This is crazy... newest version of word runs worse than Word 6.0 on Win 3.1

    I have same problem. Win 8.1 / Word2013 / i5 / 8GB ram -- stalls as I type... can't see letters until after I've typed quite a number.


    JP

    Sunday, February 2, 2014 9:48 PM
  • Has anyone come up with a fix for this? If word is the active window with no typing it sits at 40%. When typing goes to 75%?
    Friday, February 21, 2014 4:44 PM
  • Also tried quit some solutions but nothing seems to help to lower the cpu usuage below the 50% for Word, even when I not type. But when I change the views in the view ribbon to Draft then the cpu usuage directly drops to below the 25%, using the print view and the CPU goes back to the more then 70% after release the mouse button.... al other solution like disabling grafice enhancer etc does not have any effect on my Windows 7 machine running Word 2013..
    Thursday, March 27, 2014 9:06 PM
  • It looks like the issue still exists. I installed initially Office 2013 64 bit and my Word was slowing down while typing which was not acceptable for me. I discovered then that the CPU usage is approx. 20-30% for no reason caused by WinWord. Then I came with an idea that this must be an issue with 64 bit office and after installing x86 version it was worse as CPU usage went up to 50-60%. I found then this thread and tried to change the footer as described in one of the posts and problem magically disappeared. What is interesting, the issue became more and more annoying while number of text boxes in the document grows. My document is 40 pages long, has typically 1 picture per each page and for each picture I use one or more text boxes. Together with textboxes in footer this must not be digestible by Word2013. Can somebody from Microsoft look at this?
    Monday, August 18, 2014 7:22 AM
  • I Had the same problem and opened a case with Premier. We found the problem (hotfix should be arriving)

    I could reproduce this error by:

    1) opening outlook
    2) Opening a word documnet in oultlook in PREVIEW mode
    3) document could not be openend in preview mode
    4) word "hangs" 1 core at 100% cpu time
    5) Close outlook and winword.exe disapears

    Problem lies with a reg key and you cannot access it (denied, try with process explorer)
    Option: Update fields before printing for word (Reg_WORD : refresh_5_1 = true)

    HKU/%USERSID%/Software/Policies/Microsoft/office/15.0/word/options/vprsu
    and
    HKCU/Software/Policies/Microsoft/office/15.0/word/options/vprsu

    Close outlook, kill word process

    Backup both keys, delete them and restart outlook.

    Try again.

    Problem should not occur anymore.

    Best regards

    Alexandre Delen


    Thursday, August 21, 2014 5:32 AM
  • could you try to "Disable" the "Show preview handlers in preview pane" ? following this link and let me know if that solve your pbs ? 

    http://www.eightforums.com/tutorials/35233-preview-pane-hide-show-preview-handlers-windows.html

    Friday, February 27, 2015 2:34 PM
  • September 2015, and this problem still persists, two and a half years later.

    So now I work with the footers off the screen....

    As I once said to my banker, the only reason you are still in business, is because everybody else is even worse than what you are.

    Wednesday, September 9, 2015 12:48 AM
  • Working on my 100+ page dissertation in Word 2013 is taking forever due to lag and sporadic crashes.  My issue is not footer-related because it only contains page numbers and turning footer off didn't help.

    I think the high CPU load is caused by another or multiple factors: 1) My word document is organized into Chapters/sections using headers and a table contents. 2) It contains over 100 referenced sources that are cited by Mendeley throughout the document. 3) The file contains over 20 JPEG graphic, some covering a single page. 4) Individual graphics are grouped with textboxes that are used to compile a table of figures. 5) Tracking of changes throughout ten drafts of the 100+ page document.

    Deleting the list of the references seems to have solved the problem!  Stopping tracking of changes has not solved the issue.  MS needs to patch this bug.... 

    Sunday, September 27, 2015 12:24 AM
  • idem in 2016...
    Monday, February 15, 2016 8:29 AM
  • I had the same problem (Word 2013 Dutch). It started after I uninstalled OneDrive for business (reinstalling OneDrive or Office doesn't help). If I open certain files containing a footer and I scroll through the document, Word will become unresponsive after 8 pages. CPU usage is up to 60% on a quad-core i7 CPU. The largest document I tested with contains 2457 words, 15 pages, chapters and an index, no images or tables.

    Spelling and grammar check were already turned off for the documents (File-->Options-->Proofing-->Hide spelling/grammar errors in this document only)  but I had to disable "checks spelling and grammar as you type" for Word to actually work.

    CPU usage is still up to 50% when scrolling through the document but this drops when I stop scrolling and Word won't become unresponsive. Turning "checks as you type" on again (while "hide spelling/grammar in this document only" is checked) causes Word te become unresponsive right away.


    Monday, February 15, 2016 1:19 PM
  • This is a thread from the year 2013.

    Regarding the issue in February 2016, a bad update from Microsoft was distributed.

    Solution: remove KB3114717 from Program and Features and restart


    Monday, February 15, 2016 2:40 PM
  • I can confirm uninstalling KB3114717 appears to have fixed this for me.
    • Proposed as answer by pakmingw Monday, February 29, 2016 9:46 AM
    Tuesday, February 16, 2016 8:47 PM
  • Hello!

    I want inform you all, that this issue is actual for Office 365 2013/2016 and at moment there is no fix for this.

    I opened incident in MS Parner support, and answer was: "Please wait for next update".

    Part of message from Microsoft:

    As we have talked the issue with a spike on CPU usage when working on Word application is related with our last updates from 2/9/2016. It is been investigated by our product group where they need to evaluate the implications of the possible fix, and then deliver it through a hotfix.

     

    The incident is cause by KB3114717, and the reason why it cannot be found is because on C2R versions of Office (which is the one installed on the affected machines on your environment), updates are being delivered as packages. The version you have installed 15.0.4797.1002, points out we are talking about the affected package on C2R installations.

     

    I cannot confirm an exact date when the hotfix will come, but the resolution of this issue is urgent for us so we will do our best for speeding this up.

     

    Thank you so much for your understanding.

    Wednesday, February 17, 2016 2:48 PM
  • Thank you!!  Uninstalling KB3114717 also seems to have fixed the High CPU usage for me.
    Wednesday, February 17, 2016 5:52 PM
  • Thanks. Uninstalling the KB patch solved the CPU utilization issue for me.

    My symptoms were >50% CPU usage over two of my four cores when I opened a 2nd document in word, and a 5-15 second delay to my keystrokes & mouse actions. 

    As soon as I removed the patch and rebooted, the system returned to normal operation, with less than 10% utilization with the same two documents open.

    Wednesday, February 17, 2016 6:49 PM
  • This was really causing me grieve as Word was performing real slowly and consuming an abnormal amount of processor (cpu) even when "idle". I see that KB3114714 has now be updated to reflect this issue too.

    support.microsoft.com/en-us/kb/3114717

    "Update 3114717 is no longer available because it causes Microsoft Office 2013 apps, such as Microsoft Word and Microsoft Outlook, to slow down or freeze. If you’ve installed this update and you're experiencing these issues, you can safely remove the update. To do this, see the "How to uninstall this update" section."


    • Edited by ranwel2 Thursday, February 18, 2016 7:00 PM
    Thursday, February 18, 2016 6:59 PM
  • Thanks for your query, because it helped me find that my high CPU was caused by Word not coping with spelling and grammar checks, so I switched the 'as your type' spelling and grammar options off and fixed my problem.

    This is the REAL SOLUTION to the PROBLEM.   I had the same problem with WORD 2000 pro version on WIN 8.1 pro.   Some word files when I open CPU was 0%  , but  one word file was CPU 30%  instantly after few seconds.   When I turn off  grammar  on that word file .... CPU turn down to CPU 0%.  

    Thank you very much.    


    Wednesday, February 24, 2016 9:02 PM
  • Has anyone come up with a fix for this? If word is the active window with no typing it sits at 40%. When typing goes to 75%?

    This is the REAL SOLUTION to the PROBLEM.   I had the same problem with WORD 2000 pro version on WIN 8.1 pro.   Some word files when I open CPU was 0%  , but  one word file was CPU 30%  instantly after few seconds.   When I turn off  grammar  on that word file .... CPU turn down to CPU 0%.  

    Thank you very much.    


    Wednesday, February 24, 2016 9:03 PM
  • CPU usage increases as soon as I start typing in Word.

    I disabled "Check spelling as you type" and "Mark grammar errors as you type".  Having any one of this options enabled increases CPU usage.

    Wednesday, February 24, 2016 10:35 PM
  • Is there a solution for this? I have the same with 7 Computers in the same Network. While they typing, the CPU increases to 25% and word starts to lag... after deactivate the Options "Check spelling" and "Mark grammar..." the Problem desapear.

    Thanks!

    Thursday, March 3, 2016 9:10 AM
  •  office 2013 high cpu
    Short and Simple

    Microsoft support suggested I uninstall three updates that cause excel 2013 , word 2013 or outlook 2013 to consume high cpu usage .
    uninstall the following KB's and you are good to go.

    KB3114717
    KB3114734
    KB3114736

    This solved my issue of excel 2013 high cpu usage. 

    http://devopssurf.blogspot.co.il/2016/03/office-2013-high-cpu.html

    Thursday, March 3, 2016 11:06 AM
  • http://devopssurf.blogspot.co.il/2016/03/office-2013-high-cpu.html

     office 2013 high cpu
    Short and Simple

    Microsoft support suggested I uninstall three updates that cause excel 2013 , word 2013 or outlook 2013 to consume high cpu usage .
    uninstall the following KB's and you are good to go.

    KB3114717
    KB3114734
    KB3114736

    This solved my issue of excel 2013 high cpu usage.


    Thursday, March 3, 2016 11:07 AM
  • http://devopssurf.blogspot.co.il/2016/03/office-2013-high-cpu.html

     office 2013 high cpu
    Short and Simple

    Microsoft support suggested I uninstall three updates that cause excel 2013 , word 2013 or outlook 2013 to consume high cpu usage .
    uninstall the following KB's and you are good to go.

    KB3114717
    KB3114734
    KB3114736

    This solved my issue of excel 2013 high cpu usage.
    Thursday, March 3, 2016 11:07 AM
  • http://devopssurf.blogspot.co.il/2016/03/office-2013-high-cpu.html

     office 2013 high cpu
    Short and Simple

    Microsoft support suggested I uninstall three updates that cause excel 2013 , word 2013 or outlook 2013 to consume high cpu usage .
    uninstall the following KB's and you are good to go.

    KB3114717
    KB3114734
    KB3114736

    This solved my issue of excel 2013 high cpu usage.
    Thursday, March 3, 2016 11:07 AM
  • This is a thread from the year 2013.

    Regarding the issue in February 2016, a bad update from Microsoft was distributed.

    Solution: remove KB3114717 from Program and Features and restart



    Thanks! This took care of my issue as well! Was driving me crazy!
    Thursday, March 3, 2016 9:38 PM
  • This is a thread from the year 2013.

    Regarding the issue in February 2016, a bad update from Microsoft was distributed.

    Solution: remove KB3114717 from Program and Features and restart


    Writing half a year later...

    Following this incident, and several like it with Office 2013 that seems not to interest MS anymore with good QA of updates, we upgraded the company to Office 2016 365 and never had any issue since.


    Tuesday, August 9, 2016 7:53 AM