locked
Cannot secure Edge Transport Server on Windows 2008 SP2

    Question

  • Hi,

    I've just installed an Edge Transport Server on Windows 2008 with Service Pack 2.

    Registering Exchange2007Edge_WinSrv2008.xml with scwcmd register fails because the "The specified OS version does not match with the version that is defined in the KBRegistration.xml file."

    I could hack the Exchange2007Edge_WinSrv2008.xml file, but I don't know the implications of doing so. Can anyone assist?

    Is Exchange 2007 Service Pack 1officially supported on Windows 2008 Service Pack 2 yet?

    Cheers
    Bod 
    Thursday, May 28, 2009 5:00 AM

Answers

  • Hi,

    Please ensure that you have run the command like below:

    Scwcmd register /kbname:Ex2007EdgeKB /kbfile:”%programfiles%\Microsoft\Exchange Server\Scripts\Exchange2007Edge_WinSrv2008.xml

    Regards,
    Xiu
    • Proposed as answer by Amit Tank Wednesday, June 3, 2009 7:27 AM
    • Marked as answer by Xiu Zhang Friday, June 5, 2009 1:45 AM
    Friday, May 29, 2009 7:59 AM
  • Hey Bod,

    If nothing woks then I guess you can edit the second line (like below) with ServicePackMajorVersion="1" to 2 and "Save As" the file with name Exchange2007Edge_WinSrv2008SP2.xml and run the command given by Xiu...

    <SCWKBRegistrationInfo OSMajorVersion="6" OSMinorVersion="0" ServicePackMajorVersion="2" ServicePackMinorVersion="0">

    Scwcmd register /kbname:Ex2007EdgeKB /kbfile:”%programfiles%\Microsoft\Exchange Server\Scripts\Exchange2007Edge_WinSrv2008SP2.xml

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com RSS

    • Proposed as answer by Amit Tank Wednesday, June 3, 2009 7:27 AM
    • Marked as answer by Xiu Zhang Friday, June 5, 2009 1:45 AM
    Friday, May 29, 2009 10:02 AM

All replies