none
Adding drivers to Windows 7 image with DISM RRS feed

  • Question

  • I'm trying to add Intel chipset drivers to a Windows 7 image (.wim file). I was able to add some Broadcom network drivers without any problems, but when I try to add the chipset drivers, I get this error:

    "Error - An error occurred. The driver package could not be installed. For more information, check for log files in the <windir>\inf folder of the target image."

    Here's an excerpt from the log file:

    >>> [Import Driver Package - c:\drivers\Chipset\tcrkusb.inf]
    >>> Section start 2011/05/06 14:04:54.454
        os: Version = 6.1.7601, Service Pack = 1.0, Suite = 0x0100, ProductType = 1, Architecture = x86
       cmd: C:\Users\b2pra\AppData\Local\Temp\56E388AA-F02D-4187-BB45-50C56E7C41D4\dismhost.exe {11D7C1E2-233E-4FF8-A893-3559C2D292E3}
       sto: Importing driver package into Driver Store:
       sto:   Driver Store  = C:\winimg\Windows\System32\DriverStore (Offline | 6.1.7601)
       sto:   Driver Package = c:\drivers\Chipset\tcrkusb.inf
       sto:   Architecture  = x86
       sto:   Locale Name  = neutral
       sto:   Flags     = 0x00000000
       inf: Opened INF: 'c:\drivers\Chipset\tcrkusb.inf' ([strings])
       inf: Opened INF: 'C:\winimg\Windows\System32\DriverStore\FileRepository\usbport.inf_x86_neutral_f9abf85fd00186bd\usbport.inf' ([strings.0409])
       inf: Opened INF: 'c:\drivers\Chipset\tcrkusb.inf' ([strings])
       sto: Importing driver package files:
       sto:   Source Path   = c:\drivers\Chipset
       sto:   Destination Path = C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc
       flq: {FILE_QUEUE_COPY}
       flq:   CopyStyle   - 0x00000000
       flq:   SourceRootPath - 'c:\drivers\Chipset'
       flq:   SourceFilename - 'tcrkusb.cat'
       flq:   TargetDirectory- 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc'
       flq: {FILE_QUEUE_COPY exit(0x00000000)}
       flq: {FILE_QUEUE_COPY}
       flq:   CopyStyle   - 0x00000000
       flq:   SourceRootPath - 'c:\drivers\Chipset'
       flq:   SourceFilename - 'tcrkusb.inf'
       flq:   TargetDirectory- 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc'
       flq: {FILE_QUEUE_COPY exit(0x00000000)}
       flq: {_commit_file_queue}
       flq:   CommitQ DelNodes=0 RenNodes=0 CopyNodes=2
       flq:   {_commit_copy_subqueue}
       flq:      subqueue count=2
       flq:      source media:
       flq:        SourcePath  - [c:\drivers\Chipset]
       flq:        SourceFile  - [tcrkusb.cat]
       flq:        Flags    - 0x00000000
       flq:      {_commit_copyfile}
       flq:        CopyFile: 'c:\drivers\Chipset\tcrkusb.cat'
       flq:           to: 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc\SET7554.tmp'
    !!! flq:        CopyFile: FAILED!
    !!! flq:        Error 5: Access is denied.
    !!! flq:        Error installing file (0x00000005)
    !!! flq:        Error 5: Access is denied.
    !  flq:           SourceFile  - 'c:\drivers\Chipset\tcrkusb.cat'
       flq:           TempFile   - 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc\SET7554.tmp'
    !  flq:           TargetFile  - 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc\tcrkusb.cat'
       flq:        {SPFQNOTIFY_COPYERROR}
    !!! sto:           Failed to copy file 'c:\drivers\Chipset\tcrkusb.cat' to 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc\tcrkusb.cat'. Error = 0x00000005
       sto:           File 'c:\drivers\Chipset\tcrkusb.cat' is not in use by any processes.
       flq:        {SPFQNOTIFY_COPYERROR - returned 0x00000000}
    !!! flq:        SPFQNOTIFY_COPYERROR: returned SPFQOPERATION_ABORT.
    !!! flq:        Error 2: The system cannot find the file specified.
       flq:      {_commit_copyfile exit(0x00000002)}
       flq:   {_commit_copy_subqueue exit(0x00000002)}
    !!! flq:   FileQueueCommit aborting!
    !!! flq:   Error 2: The system cannot find the file specified.
       flq: {_commit_file_queue exit(0x00000002)}
    !!! sto: Failed to copy driver package to 'C:\winimg\Windows\System32\DriverStore\FileRepository\tcrkusb.inf_x86_neutral_7736aa821aa7f9cc'. Error = 0x00000005
    !!! sto: Failed to import driver package into Driver Store. Error = 0x00000005
    <<< Section end 2011/05/06 14:04:55.140
    <<< [Exit status: FAILURE(0x00000005)]
    Am I doing something wrong? Thanks!
    Friday, May 6, 2011 6:28 PM

Answers

  • Hi,

     

    Did these drivers support to Windows 7? Could you please point where did you download the chipset drivers? I will make a test to add on my WIM to check if the drivers have problem.

     

    Furthermore, check if you really need these drivers for your computer:

    http://www.intel.com.../support/detect

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    And there’s the steps about How to add Chipsets drivers inside the image install.wim:

    1) Expand the file ***.zip

    2) You will see the files for Windows 7 inside the folder ***\WIN7

    3) Copy/paste all the files (.inf and .cat files) inside a folder (example: C:\Drivers\Chipsets)

    4) Mount the image you want to integrate the drivers (example above).

    5) Integrate drivers with the command line

    6) Unmount /Commit

     

    Hope that helps.

     

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 10, 2011 2:56 AM
    Moderator

All replies

  • Hi,

     

    Did these drivers support to Windows 7? Could you please point where did you download the chipset drivers? I will make a test to add on my WIM to check if the drivers have problem.

     

    Furthermore, check if you really need these drivers for your computer:

    http://www.intel.com.../support/detect

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    And there’s the steps about How to add Chipsets drivers inside the image install.wim:

    1) Expand the file ***.zip

    2) You will see the files for Windows 7 inside the folder ***\WIN7

    3) Copy/paste all the files (.inf and .cat files) inside a folder (example: C:\Drivers\Chipsets)

    4) Mount the image you want to integrate the drivers (example above).

    5) Integrate drivers with the command line

    6) Unmount /Commit

     

    Hope that helps.

     

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 10, 2011 2:56 AM
    Moderator
  • I had the same issue with:

    Failed to import driver package into Driver Store. Error = 0x00000005

    Turns out I needed to unblock all the inf files in the directory where I had my driver files.

    I used the following utility...after that I was fine.

    http://blog.nicholasrogoff.com/2010/09/01/how-to-bulk-unblock-files-in-windows-7-or-server-2008/


    • Proposed as answer by scevec Monday, January 16, 2017 10:37 PM
    Tuesday, May 6, 2014 7:51 PM
  • Thanks man!

    I was stuck on this problem for a few hours.

    Saturday, April 2, 2016 9:22 AM
  • Thank you... unblocking the files fixed my problem!
    Thursday, September 1, 2016 4:27 PM