none
SharePoint 2013 Language Pack Installation - Is Operating System Language Pack Install Required RRS feed

  • Question

  • Good Day,

    In documentation that covers language pack installation on legacy version of SharePoint (2007/2010), there are required steps to install the equivalent OS language pack before installing the SP language pack. However, when reading the SharePoint 2013 language pack documentation, I no longer see that requirement.

    Can somebody confirm whether or not the OS language pack needs to be installed before installing the SharePoint language pack? Also, sorry to double the question, but in a 3-tier farm, I will need to execute all steps on the app server and WFE server before running psconfig on the app server, correct?

    Thanks,

    Chris


    Thursday, February 20, 2014 7:46 PM

Answers

  • You need to re-install the SharePoint Dec CU as CUs also update language files (this is why they're so large in comparison to SharePoint Service Packs which only contain the language the SP targets).

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, February 20, 2014 8:26 PM
    Moderator

All replies

  • No, you do not need the OS LP installed to support SharePoint LPs. Even with 2010, that is not a requirement.

    Yes, install the LP and any LP Service Packs (must match your version of SharePoint), and re-install any deployed Cumulative Update on all SharePoint servers, then run the Config Wizard/psconfig.


    Trevor Seward

      

    Follow or contact me at...


    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.


    Thursday, February 20, 2014 7:59 PM
    Moderator
  • Thanks Trevor!

    Please allow me to clarify one bit of your very useful answer (which I will mark as such :) )

    I have the March PU + December CU installed. So, I understand from your post that I will need to install the LP plus the March PU/December CU for the LP if such a patch exists.

    The last statement you wrote throws me off a bit though. Are you writing that I will need to re-install the SharePoint March PU and December CU after the LP (plus update) installs?

    Regards and thanks again.

    --

    Chris

    Thursday, February 20, 2014 8:22 PM
  • You need to re-install the SharePoint Dec CU as CUs also update language files (this is why they're so large in comparison to SharePoint Service Packs which only contain the language the SP targets).

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, February 20, 2014 8:26 PM
    Moderator
  • Thanks Trevor.
    Thursday, February 20, 2014 8:36 PM