none
Office 2010 install error 1920, no OSPP service

    Question

  • I just built a computer on which I'm running Win 7 Ultimate x64.  I have all user accounts set to Admin (full control).

    I get the following error when trying to install Office 2010 Professional:

    Error 1920. Services "Office Software Protection Platform" failed to start.  Verify that you have sufficient privileges to start system services.

    Description:
      Microsoft Office Professional 2010 setup did not complete successfully. We are sorry for the inconvenience.

    Problem signature:
      Problem Event Name:    Office12Setup
      Problem Signature 01:    {90140000-002A-0000-1000-0000000FF1CE}
      Problem Signature 02:    14.0.4763.1000
      Problem Signature 03:    StartServices
      Problem Signature 04:    1603
      Problem Signature 05:    0x1920
      Problem Signature 06:    Error 1920. Service 'Office Software Protection Platform' (osppsvc) failed to start.  Verify that you have suffic
      Problem Signature 07:    X
      OS Version:    6.1.7600.2.0.0.256.1
      Locale ID:    1033

    Additional information about the problem:
      LCID:    1033

    From various posts, looks like I need the OSPPSVC service.  However, this does not show in my Services listing nor do I have a registry key for this service.

    How can I install the Office Software Protection Platform service?

    Tuesday, August 17, 2010 4:40 AM

All replies

  • Hi,

     

    ·         Open Run (Press Windows key + R) > type services.msc and click on OK

    ·         On the services MMC window right-click on Office Software Protection Platform and select Properties

    ·         Select the LOG ON tab > change the ‘Log on as’ information from ‘This Account’ (Network Service) to ‘Local System Account’

    ·         Click on Apply and OK

     

    Then, try to install Office program again.

     

    Best Regards,

     

    Sally Tang

     

    Wednesday, August 18, 2010 5:58 AM
  • Sally, thanks for the response.  However, as I noted in my initial post, I do not have the Office Software Protection Platform listed as a Service.  In fact, I can find no reference to this service in my Registry.

    So my question is, how do I get this service onto my computer?

    Thanks,

    Jim

     

    Here's the list of my Services in alphabetical order:

    Services (Local)

    ....

    Network Store Interface Service

    Office Source Engine

    Offline Files

    Parental Controls

    ...etc.

    Thursday, August 19, 2010 2:14 AM
  • I'm seeing the exact same thing. Does anybody have any other suggestions??
    Monday, September 20, 2010 3:22 AM
  • I just noticed that if I run the install up to the point of the 1920 error and then check the Services the Office Software Protection Platform actually is listed at that time. But if I perform the steps suggested by Sally Tang at that time it still does not work properly. It gets past the 1920 error but then just says "Office installation encountered an error" and all I can do is close the installation. It never completes successfully.
    Monday, September 20, 2010 3:29 AM
  • As you're using Win7 Ultimate, you should be able to give the 'Network Service' user full admin rights - this might solve the problem.

    Those of us using Win7 Home Premium don't have that option, alas... and MS don't seem to have any answer.

    Friday, October 01, 2010 10:46 PM
  • I am having this issue as well. I have tried to fix it through the service application, and through the running

    icacls "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform" /grant "Network Service:F" /t

    Neither seem to work, and it is increadibly frustrating

    I can access the Office Product Protocal bit from service only when it encounters the issue. Before then it does not show up. When I do change it, it just stops the installation saying there is an issue. Then it changes back when I try to install it again. Same as with cbass94.

    I am running Windows 7 Home Premium as well, I believe. And I gave everything full admin rights to try get past another error installing Office 2010. (Which I eventually figured out, running my computer in clean boot).

    I am very frustrated, I have spent far too much time trying to install a program that I have spent a lot of money on.

    Tuesday, February 14, 2012 3:10 AM
  • Me too.  I have tried everything I can find on the web about this.  icacls, registry permission fixes, using a different Admin user, "Run as Administrator" (that's a laugh, Microsoft does not give us full rights to the computer we own).

    I only bought the laptop a few days ago (new) so I took it back to the store, and they could not figure out how to install Office either.

    In case there was a problem with the version of Office I was installing, I downloaded the free trial - but that failed to install in the same way.

    Will Microsoft please respond with a fix which actually works?

    Thursday, May 10, 2012 8:01 PM