none
Cannot blind transfer inbound calls

    Question

  • Currently I am unable to transfer an inbound call to another external number.  The Lync client shows "Cannot complete the transfer" error ID 400 source ID 239.  I had to disable refer support in trunk configuration to be able to get blind transfer working on outbound calls.  Attended transfers also work.

    During the failed transfer scenario, the sip trace shows the invite to the second number, 100 trying, 101 progress report, and the 400 bad request all right away.  The new invite is never sent to the gateway.  There are no sip errors between the gateway and Lync on the existing call either.

    The bad request message contains:

    Service Unavailable";AppUri="http%3A%2F%2Fwww.microsoft.com%2FLCS%2FOutboundRouting";reason="Failed when constructing the outgoing request";

    I was able to find this: http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/0bce99ba-ceef-451f-a457-ae1f114f806d/ 

    Is there something esle on the Lync side that can be changed? If not, perhaps Lync doesn't like something in the original invite from the gateway.

    Can anyone help?  Thanks in advance.

    Tuesday, January 31, 2012 12:55 AM

Answers

  • Hi,Jif19

    Have you checked that initial a call between two Lync users then transfer the call to PSTN call works?

    Would you please verify the PSTN number in the From Field is displayed as E.164 format with + sign in the trace log?If not please check your PSTN gateway configuration and incoming rules.I have seen external call transfer issue in Lync caused by + sign missing on the From Field along with incoming PSTN number.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb
    Thursday, February 2, 2012 2:22 AM
    Moderator

All replies

  • Hello,

    Are you using a Lync Certified gateway?
    It might also be helpful to list what you are using.

     


    +Say thanks and observe basic forum courtesy:
    +If this post answered your question, Mark As Answer
    +If this post was helpful, Vote as Helpful

    windowspbx blog: my thots/howtos
    see/submit Lync suggestions here: simple and public
    Tuesday, January 31, 2012 1:18 AM
  • I have a non-certified ITSP and a cetified gateway, an AudioCodes Mediant 1000 MSBG, to act as the go-between.  I have opened a ticket with AudioCodes but I am looking for anything that can be done on the Lync side.  The other thread mentions that trunk to trunk transfer is not supported.  Is this true?  I could not find any supporting Microsoft documentation.

    Tuesday, January 31, 2012 7:15 PM
  • Hi,Jif19

    Have you checked that initial a call between two Lync users then transfer the call to PSTN call works?

    Would you please verify the PSTN number in the From Field is displayed as E.164 format with + sign in the trace log?If not please check your PSTN gateway configuration and incoming rules.I have seen external call transfer issue in Lync caused by + sign missing on the From Field along with incoming PSTN number.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb
    Thursday, February 2, 2012 2:22 AM
    Moderator
  • Thanks for your reply Sharon, you are awesome.

    I have discovered that it in fact is the from field that needs to have the + sign.  In my case, the ITSP is sending 10 digits, so prepending a +1 on the incoming 10 digit calling number in my media gateway will fix it.

    But before that I found something interesting as well.  If I leave it as is, without prepending the + sign.  It will work if I create a pool gateway dial plan with the very same translation rules that are in the global dial plan.  I tried it several times to be sure.

    Again, if I am matching a translation in the gateway dial plan, I do not need a + sign in the from field.  If I am matching an identical translation from the global dial plan, I do need a + sign or else I get the 400 bad request as described above.

    Is this by design or a bug or just something unaccounted for?  If you know of any documentation that describes this that would be great.

    Friday, February 3, 2012 3:28 AM
  • Hi,Jif19,

    Yes,normalization rule also works as long as the call number can be translated to the standard E.164  format when it through Lync.  E.164 is an internationally recognized standard for phone numbers,and Lync use this format to communicate with other phone systems,so it's not a bug just by design.

    Hope the Technet blog and   Ken's blog can help you clarify some questions.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb
    Friday, February 3, 2012 5:26 AM
    Moderator
  • Again, thanks for the reply!

    I understand the Lync needs E.164 argument, but it looks like gateway dial plans behave differently so I will rephrase my question regarding design.

    If the from field does not contain a plus, why does the gateway dial plan behave differently than the global dial plan even though the entries are the same?  Or in other words, why does having a gateway dial plan make it so I do not have to have a + sign in the from field?

    My feeling is they should be consistent, but if it is by design where can I find supporting documentation?

     

    Jeff

    Friday, February 3, 2012 9:32 PM
  • Hi,Jeff,

    The service level PSTN gateway dial plan is applied to the incoming calls from a particular gateway,Lync clients obtain dial plan scope levels through in-band provisioning settings provided when users log on to Lync Server,the global dial plan applies to all Enterprise Voice users, groups, and contact objects in your deployment unless you configure and assign a dial plan with more specific scope.Maybe that is why they behave differently.

    Here is another great blog post for your reference.

    http://voipnorm.blogspot.com/2011/01/more-on-lync-inbound-normalization.html

    BTW,I will mark my first post as answer to close this thread,I will also keep an eye on it if you have any further questions.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb

    Tuesday, February 7, 2012 7:11 AM
    Moderator