none
URL Rewrite to redirect SharePoint site RRS feed

  • Question

  • Hello --

    We are using SharePoint Foundation 2013 and currently have https enabled on the server. We used URL Rewrite to redirect the localhost and also AAM url to automatically redirect to HTTPS url. But the https works only for AAM URL but not for the localhost URL. What I meant here is, when I try http://webserversp01 it redirects to https://intranet.companyname.com but https://webserversp01 doesn't redirect to https://intranet.companyname.com. 

    What do I do to fix the issue here? Fix the alert template or add another rule using URL Rewrite? How to create a rule in this case?

    Thanks,

    Sirish

    Thursday, February 12, 2015 1:20 AM

Answers

  • Thanks for your your reply.

    Yes, I have it installed. 

    I was able to fix the issue by changing the Default url in AAM. I found that alert email uses Default URL thats given in the AAM so I went their and changed the URL. After making this change, I tested the alert to see if it adds the correct url and it did. Now when I click on any link on the email, it automatically redirects to HTTPS website. 


    Thursday, February 12, 2015 3:00 AM

All replies

  • Do you have a valid SSL certificate/IIS binding for "https://webserversp01"?

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, February 12, 2015 2:32 AM
    Moderator
  • Thanks for your your reply.

    Yes, I have it installed. 

    I was able to fix the issue by changing the Default url in AAM. I found that alert email uses Default URL thats given in the AAM so I went their and changed the URL. After making this change, I tested the alert to see if it adds the correct url and it did. Now when I click on any link on the email, it automatically redirects to HTTPS website. 


    Thursday, February 12, 2015 3:00 AM