none
Network: Change Adapter Options - Windows cannot access the specified device, path or file... RRS feed

  • Question

  • I've just installed a brand new Windows Server 2016 into an existing SBS2008 network.  After making the server an AD and assigning FSMO roles to it, I can no longer use Control: Network & Internet: Change Adapter Options.  When I navigate to that, I get the following error:

    -------------------------------------------------

    C:\Windows\system32\control.exe

    Windows cannot access the specified device, path or file.  You may not have the appropriate permissions to access the item.

    -------------------------------------------------

    I was able to access this before promoting the server to a DC and moving the FSMO roles.  I don't know whether the promotion and FSMO roles are related to the problem.  But Control: Network & Internet: Change Adapter Options worked at some point before because I successfully assigned the IP address to the adapter.  Now that no longer works.

    Just to be clear, I have restarted the server and verified that I am logged-in as Domain\Administrator and that the account is a member of both Domain and Enterprise Admin groups.  The account I am using has permissions to do everything.

    I do not think this is really a permissions issue - I think it's more likely to be an invalid path or shortcut problem.  I am basing that statement on the fact that I can use File Manager to navigate to C:\windows\system32, launch control.exe, click on "Network and Internet", "Network Sharing Center" and then "Change Adapter Settings".  That works without problem and without using "Run As Administrator".

    I can also just double-click on ncpa.cpl and that also works without bothering to use "Run As Administrator".  

    How should I further troubleshoot this issue?

    Thanks!


    Saturday, August 12, 2017 4:04 PM

Answers

  • I wish I had a better answer for this, but two years later, the problem remains.  And Windows Server 2019 has the same defect.

    The solution is to NOT navigate to the utility using the GUI.  Instead, type "control.exe" in the search box, right-click on the Best Match search result and choose "Run as administrator".  From there, you can navigate to the Network CPL and change adapter properties successfully.

    This runs a different version of the utility that looks significantly different from the utility displayed by the Windows "Modern" UI.  More importantly, that version of the utility actually works.

    Ken Morley

    • Marked as answer by KMorley Monday, April 22, 2019 2:40 PM
    Monday, April 22, 2019 2:40 PM

All replies

  • I'd check system and service health by running;

    sfc /scannow

    dism /online /cleanup-image /restorehealth

    also check the latest cumulative update is installed.

    http://www.catalog.update.microsoft.com/Search.aspx?q=KB4034658

     edit: also try to right-click on file (control.exe) properties and Unblock

     

      



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Saturday, August 12, 2017 7:57 PM
  • Hi KMorley,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 12, 2017 7:09 AM
    Moderator
  • I have the same issue for my 2016 Datacenter edition vm.  It's just a member server and I can get to Change Adapter however from this path: Control Panel\Network and Internet\Network and Sharing Center.  The above commands didn't help for me.
    Wednesday, September 20, 2017 8:37 PM
  • I have the same issue for my 2016 Datacenter edition vm.  It's just a member server and I can get to Change Adapter however from this path: Control Panel\Network and Internet\Network and Sharing Center.  The above commands didn't help for me.

    I'd start a new thread.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, September 20, 2017 8:44 PM
  • I've got this same problem. Did you ever get it fixed?

    A little nonsense now and then is relished by the wisest men.

    Wednesday, November 15, 2017 12:37 AM
  • I am experiencing the same problem.

    Didn't find any solution at this time.

    But I am able to change the adapter adapter settings if I use Network and Sharing Center instead.

    Friday, November 17, 2017 5:52 PM
  • I am experiencing the same problem.

    Didn't find any solution at this time.

    But I am able to change the adapter adapter settings if I use Network and Sharing Center instead.

    I'd start a new thread.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, November 17, 2017 5:54 PM
  • You may want to try this; it worked for me.

    Elevated command prompt, run gpedit.msc

    Navigate to Computer Configuration->Windows Settings->Security Settings->Local Policies->Security Options

    Enable "User Account Control: Admin Approval Mode for the Built-in Administrator account"

    Reboot and try again.

    Not sure exactly why, but this fixes the issue for me.

    • Proposed as answer by Ben Tungland Friday, March 16, 2018 4:05 PM
    Monday, January 1, 2018 2:58 PM
  • Thanks a ton, it worked very well and the problem is solved!!! :-) :-)
    Tuesday, March 6, 2018 3:04 PM
  • @DLH Consulting - Thank you so much for saving my sanity.  It worked!!
    Thursday, March 15, 2018 3:44 PM
  • This isn't exactly a fix, I was getting this error message in Setting, however, if I went to Control Panel\Network and Internet\Network and Sharing Center then change adapter settings it let me in without issue.


    • Edited by Colby Stewart Wednesday, April 4, 2018 12:13 AM html issue
    Wednesday, April 4, 2018 12:13 AM
  • This isn't exactly a fix, I was getting this error message in Setting, however, if I went to Control Panel\Network and Internet\Network and Sharing Center then change adapter settings it let me in without issue.


    I'd start a new thread detailing your issues .

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, April 4, 2018 12:22 AM
  • I'm sure you've got that sorted by now but just in case someone else has similar issue - 

    Elevated command prompt, run gpedit.msc

    Navigate to Computer Configuration->Windows Settings->Security Settings->Local Policies->Security Options

    Enable "User Account Control: Admin Approval Mode for the Built-in Administrator account"

    Reboot

    Friday, May 4, 2018 11:05 AM
  • Thanks! That happened to me on 2 different pc's -> Windows 10 fresh install + Spring Creators Update
    Friday, May 4, 2018 11:12 AM
  • Happening to me too. Aren't windows updates grand, just love constantly having issues after every "update" 
    Saturday, May 5, 2018 12:06 AM
  • Home edition user here, it doesn't have gpedit.msc What to do now?

    By the way it only happens after 1803 update.

    Wednesday, May 9, 2018 9:35 PM
  • Thanks alot, it works fine
    Wednesday, May 16, 2018 10:24 AM
  • Why would he start a new thread? This thread should contain the answer.

    Now I'm getting the same problem.  I knew I should have kept Windows 2016 out of my production environment.  This is only my FIRST one I've installed, and all the CTRL - I settings are bugged out.

    If I go to the control panel directly, it works fine.

    What really makes this annoying, is I was in the insider program last year, and this same problem was in Windows 10.  I reported it at least 3 times.  Yet they could not fix it.

    Huge fail Microsoft, to allow this into your server product line.

    Sunday, May 20, 2018 6:08 AM
  • Home edition user here, it doesn't have gpedit.msc What to do now?

    Same here.. I've been fighting with this issue for a long time now..
    Sunday, May 20, 2018 11:23 AM
  • I was having the same problem on a 2016 server.  I attempted the fix listed below and it did not work.  I then ran a procmon and found that I had missing registry values in the profile (HKCU registry hive).  I created a new admin account, then logged on with that.  We had no issues.  I then deleted the profile for the original admin.  After logging in as the original admin again the issue was resolved.

    If you are running into this problem, try creating another user account.  If the problem is not present, then just delete and recreate the user profile.


    I also posted an article to my blog with the solution.  It can be found here.
    • Proposed as answer by GlennWallace Wednesday, June 27, 2018 7:52 PM
    • Edited by GlennWallace Wednesday, June 27, 2018 8:19 PM update with link to fix.
    Wednesday, June 27, 2018 7:50 PM
  • I'm guessing you found a solution or, at least, a workaround for this by now. If not, you can follow these steps on your Windows 10 Home (It is basically the same solution suggested above using group policy, but in this case we can do it from the Registry since Home doesn't have gpedit.msc):

    1) Launch the Registry Editor (regedit.exe)
    2) Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    3) Change the value of FilterAdministratorToken (REG_DWORD) from 0 to 1 (If you don't see that key, you can create it by right-clicking on any empty space from the right panel and select New > DWORD value, type the name and set the value to 1)
    4) Reboot the computer and then it will be working fine.

    Hope this works for you as it did for me.

    Regards,

    Gabriel Gonzalez M.
    Microsoft Certified Professional

    Sunday, September 30, 2018 8:38 PM
  • And now, in Server 2019, the GP option that would fix this has been deliberately disabled by Microsoft.

    Fortunately, the registry edit did resolve the problem, so if you're encountering this issue and find the GP option is grayed out in your GPEDIT console, use the registry tweak and reboot to resolve the problem.

    It is asinine that Microsoft goes to the trouble of deliberately disabling a feature that fixes a broken UI element, but can't be bothered to fix, or even just REMOVE, the broken UI element. The effort spent on making it harder to get to the network interface configuration is unbelievable.

    Let me be explicitly clear here.

    This is an enterprise OS which has been released to production with a GUI interface element for accessing network interfaces that

    DOES.

    NOT.

    WORK.

    It has been broken and unusable for years. Now, with the new OS, it's STILL BROKEN, and they have DELIBERATELY disabled a way to fix it.

    It's not a misunderstanding, it's not a feature. This is deliberate jackassery. No excuses for this kind of customer-hostile arrogance.

    If you really don't want us using it, just REMOVE it, don't throw half-assed roadblocks in the way to break it.

    This is a server os, I'm not some granny trying to install Flash on my home computer. I don't need to be protected from my own network interfaces.

    • Proposed as answer by RGB480 Monday, January 28, 2019 8:23 AM
    Saturday, January 26, 2019 5:10 PM
  • Thank you, the reg edit worked. 
    I just ran into this with Server 2019. 

    Not sure why your message was "reported as abusive."  It's abusive that this has not been fixed, isn't easier to find, or has been removed from the GUI. 

    Microsoft doesn't seem to value the time of System Admins much these days.  
    Monday, January 28, 2019 8:23 AM
  • Worked for me. Thank you so so much
    Wednesday, January 30, 2019 1:53 AM
  • This works for me... thanks!!!
    Sunday, February 17, 2019 11:44 PM
  • I found a solution,

    I am using windows server 2019 standard evaluation,

    All I had to do is create a secondary Admin Account with Administrator and Domain Admins permissions, meeting password complexity requirements.

    (Not the built in Administrator Account)

    logged in with that account and made any changes I needed it.

    Sunday, March 3, 2019 5:55 AM
  • Thanks, DLH Consulting,

    enabling this option makes it much easier to work in my test environment as a domain administrator. Without this policy defined, there are lots of settings that you can't change in Windows Server 2019.

    Made my day :-)

    Tuesday, March 5, 2019 2:53 PM
  • Worked for me, Thanks so much :)

    Thursday, April 4, 2019 3:52 AM
  • Thanks alots. It worked for me too :) 
    Monday, April 22, 2019 1:17 PM
  • I wish I had a better answer for this, but two years later, the problem remains.  And Windows Server 2019 has the same defect.

    The solution is to NOT navigate to the utility using the GUI.  Instead, type "control.exe" in the search box, right-click on the Best Match search result and choose "Run as administrator".  From there, you can navigate to the Network CPL and change adapter properties successfully.

    This runs a different version of the utility that looks significantly different from the utility displayed by the Windows "Modern" UI.  More importantly, that version of the utility actually works.

    Ken Morley

    • Marked as answer by KMorley Monday, April 22, 2019 2:40 PM
    Monday, April 22, 2019 2:40 PM
  • Windows cannot access specified device... error is caused by built-in Administrator account, which seems not have proper permissions setup at the time of Active Directory install. This problem only shows up after active directory installed on Windows Server 2016 or 2019 and logged in with DOMAIN\Administrator.

    Solution:

    Login DOMAIN\Administrator, open Active Directory Users and Computers, go to Users under your Domain. Right click on built-in Administrator username, select copy and name new administrator account with new username (e.g. ABCadmin), enter your password and save new account. it will create new account in Active Directory with same administrators’ rights as built-in administrator.

    Logout and login with new created administrator account, all will work fine.

    Manjit Singh

    • Proposed as answer by tech.xpert Wednesday, May 8, 2019 12:56 AM
    • Edited by tech.xpert Monday, May 20, 2019 12:39 PM
    Sunday, May 5, 2019 2:21 PM
  • Thank you. This is the fix. Much appreciated.
    Tuesday, May 14, 2019 10:34 PM
  • New W2019. Problem started after promoted to DC.

    I confirm that using a user different from administrator works. Something related to UAC, sure.



    • Edited by Trapulo Friday, May 24, 2019 11:12 AM
    Friday, May 24, 2019 11:12 AM
  • DLH Consulting,

    Thanks!!! This had been driving me nuts ever since I first installed WS2019 in Nov. 2018.

    I should also add that this solved another problem I had:
    WS2019's Settings->System->Remote Desktop: The Enable Remote Desktop slider was stuck, and couldn't be moved to "on", even though RDP was de facto working.

    Regards,

    mlavie

    Monday, June 17, 2019 7:10 PM
  • Question:

    1) Does anyone know why only some installations are encountering this? I ask some IT friends, and they said they had never heard of this problem. I can state that my current all-WS2019 Domain is the result of a somewhat botched migration from our previous all-WS2008 (please don't laugh) Domain. Also, Exchange Server 2010 was less-than-elegantly migrated t Exchange Server 2019...

    2) Is there some Active Directory policy I can define for my Domain to push DLH Consulting's policy fix onto all Domain Servers?

    TIA,

    mlavie

    Monday, June 17, 2019 7:16 PM
  • OK,

    I managed to push the gpedit setting as a Domain policy - only to discover that this policy now means that I have to keep on approving each Admin action I make, as if I were on a Windows 10 client (instead of a server).

    This is actually more problematic and annoying for me than the original situation this was intended to fix. Isn't there some other way to fix this, without suffering from UAC? 

    TIA,

    mlavie

    Tuesday, June 18, 2019 9:39 PM