Visio internal error: #3400 Action 2011: Link Data to Shapes -- Windows SharePoint Services 3.0


  • I am trying to get my Visio 2010 32bit version to hook up to our WSS. 


    I am able to find the list, even choose a view if i want. But once i try to finish the connection wizard i get the error:

    Visio internal error: #3400 Action 2011: Link Data to Shape


    I have tried in a new document.

    I have tried the document on the local hard drive vs. the network location. 

    I have tried different lists.




    BTW I am running:

    Windows 7 Professional 64bit 

    Office 2010 Professional Plus 32bit

    Visio 2010 Premium 2010 32bit




    Monday, January 10, 2011 4:15 PM


All replies

  • I've tested this and I am not able to reproduce the error.

    Are you able to reproduce this from a different WSS or SharePoint site?

    Are other users able to connect to the SharePoint session after running the conneciton wizard without error?  If so, how many users are affected?

    If it's just one user affected, I'd consider doing a Repair of Office

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Microsoft Online Community Support

    Tuesday, January 11, 2011 11:08 PM
  • I have the exact same configuration and I am getting the exact same error.  We are running MOSS 2007 on the back end where the list data resides that I am attempting to connect to.

    I am also getting the error on a Windows XP SP3 system, 32 bit, Visio 2007.

    Are there any special SharePoint considerations for linking data to Visio?

    Tuesday, January 18, 2011 6:42 PM
  • David Parker did an interesting blog on linking data between a sharepoint list and a drawing, maybe this might help



    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Al Edlund Visio MVP
    Tuesday, January 18, 2011 9:41 PM
  • OK so I went to go try this process today and it worked. Not sure what changed. Sorry i can not help further. I hope the proposed answer helps others.
    Thursday, January 20, 2011 1:08 PM
  • Well, i hade the same issues lately and did some research. Finally i came to the conclusion that i did not use the appropriate version of Visio 2010. Only Visio 2010 Premium supports connections to Sharepoint Libraries but not Visio 2010 Professional.

    That finally solved my problem.

    Tuesday, July 12, 2011 2:25 PM
  • I am using Visio Professional 2007 and am having exactly the same error.    David Parker's blog shows he is using the same version as me.  So, what is going on?
    Thursday, September 01, 2011 9:28 AM
  • You need SharePoint 2010 to use the new datalinking feature of visio 2010.

    Don't forget the french visio blog

    Michel LAPLANE (MVP Visio)
    Friday, September 09, 2011 6:14 AM
  • You're wrong beginning with the professionnal you can use SharPoint features. The only features added to the premium are

    • Validation rules
    • Bpmn solution
    • Workflow diagram
    • Process repository

    Don't forget the french visio blog

    Michel LAPLANE (MVP Visio)
    Friday, September 09, 2011 6:20 AM
  • I don't think I ever saw an adequate answer to this: I'm getting this internal error connecting a visio diagram to a share point list: I'm using Visio premium 2010 32 bit with Sharepoint 2010 . Ive tried several different diagrams with a couple of list. I get all the way to the end and then I get the internal error when it try's to connect. It is not a permission issue as far as I can tell I'm the administrator of the share point site. and farm. The error feels like a catch all. I have some adobe PDF add ins I would not think they would affect this. Is there a process for getting more granular log data that could indicate were the error is occurring?

    David Foreman

    • Proposed as answer by David Foreman Friday, October 26, 2012 8:42 PM
    Thursday, October 25, 2012 4:24 AM
  • I have the same issue and don't find any answer to correct this.

    Did someone who encountered this "Visio internal error: #3400 Action 2011: Link Data to Shape" message achieve to solve this problem?


    My versions:
    Visio 2010 Premium 32 Bits
    SharePoint 2010 Server
    Wednesday, January 16, 2013 2:52 PM
  • I was getting this error using Visio Premium 32-bit and SharePoint 2010.  I don't know what caused the error but I ran a repair on visio by going to Control Panel-->Programs-->Programs and features-->Then select Visio and click "Change".  One of the options is repair.  Run the repair then reboot and that fixed the issue for me.

    Thursday, April 18, 2013 1:06 AM
  • I have discovered that any bad data in your lists may also cause this issue.  For instance if you are using calulated columns and have any items with #VALUE! resultant from calulating on a blank field.

    I discovered this by linking to another list with little data or a view of the list without certain fields.

    Try analyzing / cleansing any data in your lists as a potential solution.

    Saturday, June 01, 2013 6:12 PM