none
The user does not exist or is not unique RRS feed

  • Question

  •  

    Hi All,

    I've got a strange error while assigning a specific permissions to a document:

    While WSS finds the specific ntfs group I want to add (it passes the "Check Names"), it generates the "The user does not exist or is not unique" error while saving. 

    This group is not added before, and there is no parent group which allready has the same rights than this group.

     

    Does anyone has an idea what could be the cause of this problem? Adding other groups is no problem!


    PS: I'm using WSS 3.0

    • Edited by Mike Walsh FIN Thursday, October 30, 2008 5:38 PM Prefix removed from subject
    Friday, May 30, 2008 1:38 PM

All replies

  • Hello Michel.

    I was wondering whether you ever received a resolution to this "The user does not exist or is not unique" issue you had.

    I get exactly the same problem - WSS3.0 is able to identify an AD account (underline the account name in the section where you add a user to a specific group) but then throws the error when clicking the OK button.

    In my case we had a trust relationship with our parent/holding company which was then broken and had to be recreated. The account I am having problems with is an account in the Trusted domain.

    I've been battling with this issue for a few days now - did you by any chance get this resolved?

    Thanks
    Michiel Bester
    Bester
    Monday, September 8, 2008 11:53 AM
  • I had this issue with several users when trying to copy some unique permissions manually between 2 sites in the same site collection. When I looked in the User Profile Database in the SSP, the users were not there, which is why adding the users was failing.

    The issue is that the "User Information List" which exists for every site collection does not automatically remove users when deleted from A/D, unlike the User Profile Database which does. It also doesn't automatically push updates to account information either, but you can setup individual properties to udpate from SSP -> User Profile and Properties -> View Profile Properties and then edit the property as "replicable".

    To remove users from your site collection manually, at the site collection go to:
    Site Settings -> People and Groups -> All People

    Greg
    • Proposed as answer by Greg Lynn Thursday, October 30, 2008 5:02 PM
    • Unproposed as answer by Mike Walsh FIN Thursday, October 30, 2008 5:38 PM
    • Proposed as answer by James Milne Wednesday, June 13, 2012 10:14 PM
    Thursday, October 30, 2008 5:02 PM
  • Hi Michiel,

    I am having exactly the same problem in WSS 3.0 enivronment.... I am trying to add a user from a trusted domain and it identifies the AD account, but when I hit on OK, it gives an error 'the user does not exist or is not unique'....
    Did you ever found a solution to this problem? Any help is much appreciated...

    Thanks and Regards,
    Charan V
    Monday, January 11, 2010 5:47 PM
  • Hi All,

    Did anyone found solution for the above i am having the same issue when i try to add users in WSS 3.0 it is throwing "user doesn't exist or is not unique" this is the first time i am an adding user 

    i did the following after setting the sharepoint

    1)
    Created a group "clients" and user "abnuser"
    Login to sharepoint with admin user and created the same group clients and tried to create the same user 

    2) logged into sharepoint with admin user and created a new group which is not in active directory and tried to create a new user still i am getting the same error

    i am not sure why it throws this error my active directory has been setup in the same domain and login to site as administrator and this login is used in application acitive directory as well not sure what is wrong please help 

    i also tried the below
    stsadm -o setproperty -propertyname Peoplepicker-searchadforests -propertyvalue domain.name.com -url "http://servername/sites/sitename" 

    it's very urgent can someone please help???

    My Environment details

    Windows server 2003
    WSS 3.0
    IIS 6.0

     Please let me know any more details required.

    Friday, February 12, 2010 2:36 PM
  • I was receiving this error when I was trying to add the user by using the display name. When I tried using the actual domain and username then it was successful.
    Friday, May 7, 2010 1:57 PM
  • I've seen this error when trying to use the fully qualified domain object, but the string had spaces in it. So for instance we had limited our people picker to only search a certain OU. When set that to be "OU=test, DC=testad, DC=local". The command took, and the people picker would work, but actually applying rights to an object in that OU would fail with the error specified above. It seems that some of the object model can handle spaces, where others cannot. Changing that setting to be "OU=test,DC=testad,DC=local" solved the issue immediately.

    Now this might not be exactly what you are doing when you get your errors, but check to make sure that a space somewhere isn't an issue.
    Friday, May 7, 2010 6:03 PM
  • hi charan,

        i was facing same issue but i solved by adding the users appropriately from cmd prompt by stsadm -o adduser -url -userlogin -useremail -group -username. please fill the details correctly during this command if any thing is missing in -userlogin(domainname\userlogin) it gives error 'the user does not exist or is not unique'. this things you have to tally with ur ActiveDirectory. this will solve your problem. please let me know if ur issue is solved.

    Tuesday, May 25, 2010 4:13 PM
  • I have had the same error, but in simply trying to access my site. I get it when trying to connect to my site in BPOS. I am attempting to conenct from the Customer Portal, which is supposed to pass creds thru automatically. Oddly enough, this issue does not occur when I use Firefox to access the site. I'm thinking it's an IE error but I cannot nail it down.

    Any suggestions? I have tried clearing the cache, managing trusted sites, and even removed all cookies to be thorough.

    Tuesday, July 27, 2010 3:57 PM
  • Had the same problem today...

     

    To resolve the issue, i performed the following actions:

     

    1. launch powershell (with sharepoint add-ins) and type: Disconnect-SPConfigurationDatabase (followed by "y") and restart the server.

    2. Launch IIS manager and remove any sites that may still be lingering e.g. "SharePoint Web Services" (EXCEPT "Default Web Site")

    3. Remove all application pools that are still there (EXCEPT  "DefaultAppPool" and "Classic .NET AppPool")

    4. Check for any lingering sites under: C:\inetpub\wwwroot\wss\VirtualDirectories\  and remove.

    5. Run the sharepoint configuration wizzard to join the farm again or use the "Connect-SPConfigurationDatabase" cmdlet (powershell)

     

     

    hope this helps others out there....

     

    Kurt.


    P.S. If you are still having issues (and have configured object cache user accounts), check the credentials used and update if required i.e.

    $wa = Get-SPWebApplication -Identity "<WebApplication>"     i.e.(http://site.xxx.xxx.xxx)
    $wa.Properties["portalsuperuseraccount"] = "<SuperUser>"     i.e. (domain\useraccount)
    $wa.Properties["portalsuperreaderaccount"] = "<SuperReader>"    i.e. (domain\useraccount)
    $wa.Update()

    • Edited by Kurt Boswood Wednesday, October 12, 2011 12:51 AM
    Monday, October 10, 2011 5:13 AM
  • I had this issue when developing a SharePoint 2013 app. One of the lists had a people-picker and I didn't specify the selection scope. That means the user could select any user from the Active Directory, but when they tried to save the form, the validation was done against those users with access to the host site, which was only my team. They were getting the message: "The user does not exist or is not unique".

    The solution:
    In Visual Studio, edit the Schema.xml of the list with the problem. Look for the field with the problem and add the tag UserSelectionScope="0". It should look something like this...

    <Field Name="Sponsors" 
    ID="{1a3e043d-3d18-4828-99cf-2c2dff733470}"
    DisplayName="Sponsors"
    Type="UserMulti"
    UserSelectionMode="PeopleOnly"
    UserSelectionScope="0"
    Mult="TRUE" />

    Tuesday, July 8, 2014 12:02 PM