locked
Outlook 2007 incorrectly handles utf-8 text e-mail messages

    Question

  •  

    I apologize if this question was discussed already.

     

    From time to time I receive e-mails in Russian that Outlook 2007 can not handle - Cyrillic characters get lost or replaced with '?' marks.

     

    The following e-mail I sent to myself from Vista Windows Live Mail:

     

    Message-ID: <6A3C15403A814F31BF414C6446592744@diamond3>
    From: <npak@ispras.ru>
    To: <npak@ispras.ru>
    Subject: =?UTF-8?B?0J/RgNCy0L7QtdGA0LrQsCDRgNGD0YHRgdC60L7Qs9C+INGP0LfRi9C60LA=?=
    Date: Fri, 18 Jul 2008 16:23:09 +0400
    MIME-Version: 1.0
    Content-Type: text/plain;
     format=flowed;
     charset="UTF-8";
     reply-type=original
    Content-Transfer-Encoding: 8bit
    X-Priority: 3
    X-MSMail-Priority: Normal
    Importance: Normal
    X-Mailer: Microsoft Windows Live Mail 12.0.1606
    X-MimeOLE: Produced By Microsoft MimeOLE V12.0.1606

     

    Проверка русского языка

     

     

    Outlook 2007 shows Russian in the subject of this email but replaces Cyrillict with question marks in the body.

    Windows Live Mail displays this e-mail just fine, so this is the problem of Outlook 2007.

     

    My system: Vista Business Russian, Office 2007 Professional Russian.

    Any ideas on how to fix this?

     

    Best regards,

    Nikolay.

    Friday, July 18, 2008 12:30 PM

Answers

All replies

  • Hi,

     

    Please check whether the outlook’s profile is running in Unicode mode. Open Outlook, click Account Settings, double click the account, click More Settings button, in the Advanced tab, please view the description under Mailbox Mode.

     

    Thanks

     

    Allen

    Monday, July 21, 2008 9:38 AM
  •  

    Hi, Allen,

     

    this is a pop3 account, and it does not have Unicode mode.

     

    Best regards,

    Nikolay

    Monday, July 21, 2008 9:48 AM
  • Hi,

     

    Please refer to the following link:

     

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;198866

     

    Thanks

     

    Allen

    Tuesday, July 22, 2008 5:52 AM
  • Hey Nikolay,

    I'm adding this comment to help others that suffer from this problem.

    Allen is right about Unicode mode, and Outlook certainly has one also for POP3 users.

    Outlook 2007 supports Unicode/UTF-8 only for Outlook 2007-format PST files, not for Outlook 97-2002 format PST files. You need to convert your PST file to the new format, or create a new PST file and copy all your Outlook items to it. Instructions to do this can be found at http://office-outlook.com/outlook-forum/index.php/m/176634/. I suggest you go for Solution #3 as it will preserve all your views, category colors etc that will be reset to default if you create a new PST file as described in Solution #2.

    Cheers,

    Magnus
    Saturday, January 2, 2010 8:54 AM
  • This problem have place when you use old outlook 98-2003 .pst file in outlook 2007-2010.

    Here is easy solution -

    Create new outlook .pst file and move , export all your stuff.

    THAT'S IT!

     

    Good luck!

       

     


    • Edited by elybus Saturday, November 12, 2011 9:52 PM
    Saturday, November 12, 2011 9:51 PM