none
Can't open links in email Outlook 2007 Windows 7

    Question

  • Hello,

    I have a client who is unable to open links to URLs in email messages. When she does so, she gets this error:

    "This operation has been canceled due to restrictions in effect on your computer. Please contact your system administrator."

    She only uses IE and has no other browser installed.

    I have done quite a bit of Googling on this issue and not been able to resolve the problem. I changed her proxy settings in Internet Options from Auto to Off or No Proxy Server, I forget the wording.

    I have uninstalled and re-installed IE.

    I saw that there might be an issue with the dll's. I tried to register them manually and ran into an error. When I got to mshtml.dll, this was the error:
    "DllRegister Server entry point was not found"

    I did some investigation of this error and realized I was over my head. Can anyone help?

    Thanks,

    Shawn Lewis

     

     

    Tuesday, June 29, 2010 8:57 PM

Answers

  • Did you google the error message? You should get the right answer in the top 2.

    This is a problem with IE and Windows, its not an Outlook error. You need to reset your internet settings in IE's Tools, Internet Options, Advanced tab. (Or Control panel, Internet options, Advanced tab). If it occurred after uninstalling Firefox or Chrome (and any program that opens HTML files) you need to repair the registry.

    If resetting the Internet settings doesn't work (and they don't seem to for a lot of users), see http://www.slipstick.com/problems/link_restrict.htm for other things to try. Most people tell me that "Edit Registry part 2" was the fix they used.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Marked as answer by Sally Tang Thursday, July 1, 2010 7:48 AM
    Wednesday, June 30, 2010 2:03 AM

All replies

  • Did you google the error message? You should get the right answer in the top 2.

    This is a problem with IE and Windows, its not an Outlook error. You need to reset your internet settings in IE's Tools, Internet Options, Advanced tab. (Or Control panel, Internet options, Advanced tab). If it occurred after uninstalling Firefox or Chrome (and any program that opens HTML files) you need to repair the registry.

    If resetting the Internet settings doesn't work (and they don't seem to for a lot of users), see http://www.slipstick.com/problems/link_restrict.htm for other things to try. Most people tell me that "Edit Registry part 2" was the fix they used.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Marked as answer by Sally Tang Thursday, July 1, 2010 7:48 AM
    Wednesday, June 30, 2010 2:03 AM
  • Thanks for the link. I'll check those solutions out.
    Wednesday, June 30, 2010 6:04 PM
  • Ok. I have Windows 7 64 bits and Outlook 2007 and the same problem happened to me. I just fixed it doing the following:

    Call the REGEDIT and goto HKEY__CURRENT_ USER and CLASSES and look for all keys related like .htm, .html,shtml etc and on each one modify the key Google Chrome... with the word htmlfile.

    That should work... it worked for me

    Regards

    Francisco

    • Proposed as answer by RV-Howell Monday, March 28, 2011 6:59 PM
    Monday, December 6, 2010 5:51 PM
  • You can also try this free tool to fix issue without editing the Registry:
    http://www.reliefjet.com/Product/Features/OutlookTweaks
    Alexey Kuznetsov,
    Relief Software
    Monday, March 28, 2011 5:53 PM
  •  

    http://support.microsoft.com/kb/310049

    Microsoft Fix it 50388 download and run

     

    100% working

    sasanka
    • Proposed as answer by sasankau2 Monday, May 30, 2011 5:44 PM
    Monday, May 30, 2011 5:42 PM
  • Did you google the error message? You should get the right answer in the top 2.

    This is a problem with IE and Windows, its not an Outlook error. You need to reset your internet settings in IE's Tools, Internet Options, Advanced tab. (Or Control panel, Internet options, Advanced tab). If it occurred after uninstalling Firefox or Chrome (and any program that opens HTML files) you need to repair the registry.

    If resetting the Internet settings doesn't work (and they don't seem to for a lot of users), see http://www.slipstick.com/problems/link_restrict.htm for other things to try. Most people tell me that "Edit Registry part 2" was the fix they used.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Edit Registry part 2 worked for me.
    Friday, January 20, 2012 8:05 PM
  • did you try MS fix it ? 

    http://support.microsoft.com/kb/310049

    Microsoft Fix it 50388 download and run

     


    sasanka
    • Proposed as answer by HeinzDK Thursday, July 19, 2012 8:27 PM
    Tuesday, January 24, 2012 10:57 AM
  • It may have something to do with UAC in Windows 7. Click on Start on type in the Search field UAC. It should bring up "Change User Account Control Settings" and move down the slider on the left hand side to lowest which is "Never Notify". Then try again. Good luck
    Wednesday, February 15, 2012 4:52 AM
  • I used this fix and worked great, thanks. 
    Sunday, March 17, 2013 4:31 AM
  • This happened to me about a year ago when in an Adobe update. Google Chrome snuck into my machine I uninstalled it and that is when the problem started. After going round and round with Microsoft a friend suggested just restore the computer to a week ago, it worked. You do not have to mess with the registry or at least I didn't. The thing that grips me is that they, Microsoft, said "its a known problem.  So this time after I downloaded Google Earth and "Vosteran" snuck in I Googled it. Its difficult to find it on line but it can be done. It's a browser thief and tries to get you to get Chrome as a browser when I read that I uninstalled it and guess what sports fans can't open links in Outlook, well well. So I recovered the computer again to an earlier date no problem. Interesting both times it's a Google thing. Do they just want to take over everything.

    • Edited by Juan2no Thursday, November 20, 2014 10:33 PM
    Thursday, November 20, 2014 4:34 PM