none
Word 2013 - Track Changes - Not showing comment author's name

    Question

  • Hey folks,

    When I use the Track Changes feature in Word 2013 (running on Windows 8.1), and I create a new Comment, my name temporarily appears as the Author, but when I close and re-open the document, it switches the Author name to "Author" instead of my name. Also, my picture disappears in favor of a generic icon.

    What is going on here? FYI, I'm logged into Windows 8.1 using my Microsoft Account. I'm not sure if that matters. It seems to be pulling my name and account picture correctly, until I close and re-open the document.

    See the following screenshot: I changed some formatting, closed and re-opened the document, then inserted a new comment. My name shows up correctly when I make a new change, but disappears after closing the document.

    Cheers,

    Trevor Sullivan


    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Friday, November 15, 2013 1:29 PM

Answers

  • Try the following: Open the affected document. Click File tab | Options | Trust Center | Trust Center Settings | Privacy Options. Clear the check box next to "Remove personal information from file properties on save" and click OK.


    Stefan Blom, Microsoft Word MVP

    Monday, November 18, 2013 1:21 PM

All replies

  • Here's what I see if I hover over the tracked change (ignore the blacked out parts, for privacy).


    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Friday, November 15, 2013 1:32 PM
  • Please go to Review Tab > Click the icon in right-bottom of Tracking section > Check and tick the box of "Pictures By Comments" to solve the problem.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, November 18, 2013 7:55 AM
    Moderator
  • The Pictures By Comments checkbox is checked by default, and is still checked. What makes you think that, that would fix the issue? Did you also notice that the author name is disappearing?



    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Monday, November 18, 2013 1:16 PM
  • Try the following: Open the affected document. Click File tab | Options | Trust Center | Trust Center Settings | Privacy Options. Clear the check box next to "Remove personal information from file properties on save" and click OK.


    Stefan Blom, Microsoft Word MVP

    Monday, November 18, 2013 1:21 PM
  • Stefan,

    You are a winner! Unchecking the "Remove personal information from file properties on save" checkbox solved the issue. Thanks for understanding the issue, and solving it!


    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Monday, November 18, 2013 1:52 PM
  • I'm glad I could help!

    Note that the "Remove personal information..." option gets selected after you have run the Document Inspector on a document. You have to clear the option manually, or it will be sticky (as you have noticed).


    Stefan Blom, Microsoft Word MVP

    Monday, November 18, 2013 1:57 PM
  • Oh,I see. I've got the new point from the post as well. Thank you for your information, Stefan:)

    Tony Chen

    Tuesday, November 19, 2013 7:10 AM
    Moderator
  • Why? What purpose does this serve in a collaborative environment?
    Tuesday, September 23, 2014 4:16 PM
  • Why? What purpose does this serve in a collaborative environment?

       

    Define "this." Do you mean "Remove personal information..." or "Pictures by comments"? Or something else?


    Stefan Blom, Microsoft Word MVP

    Tuesday, September 23, 2014 5:45 PM
  • Hello Stefan,

    Thank you for sharing your knowledge, however, my box is unchecked and my user name is still not showing. This is the first time this has happened. I appreciate your help.



    • Edited by jdhamie Wednesday, October 29, 2014 2:09 PM
    Wednesday, October 29, 2014 2:09 PM
  • Hello Stefan,

    Thank you for sharing your knowledge, however, my box is unchecked and my user name is still not showing. This is the first time this has happened. I appreciate your help.

          

    Which version of Word are you using? If it is Word 2013, verify that your user name is correct on the General tab of File | Options and also select the option to "Always use these values regardless of sign in to Office."


    Stefan Blom, Microsoft Word MVP

    Wednesday, October 29, 2014 3:23 PM
  • Yep.  Since the "Remove personal information..." option is greyed out with the Document Inspector, this was the trick that fixed it for me.

    Thanks to both Stefan & Tony.  Between the two of you, I was able to find the flag and correct the problem.

    Sunday, January 11, 2015 3:14 PM
  • Can you tell me why the "Remove personal information..." option is greyed out and how it could be made active ?  I tried using the document inspector but to no avail.  How do I ungrey it ?

    Thursday, January 15, 2015 9:47 PM
  • Can you tell me why the "Remove personal information..." option is greyed out and how it could be made active ?  I tried using the document inspector but to no avail.  How do I ungrey it ?

      

    Do the following to start the Document Inspector in Word 2013: Click File | Info | Check for Issues | Inspect Document. In the list of content, make sure that "Document Properties and Personal Information" is checked and then click the Inspect button. Click Remove All (next to the "Document Properties..." item). Save, close and reopen the document. From then on, your user name will be replaced with "Author" each time you reopen the document.


    Stefan Blom, Microsoft Word MVP

    Thursday, January 15, 2015 10:36 PM
  • Our office has been struggling with a related problem that maybe you can solve. Basically, the same person is repeatedly given a different reviewer name as they work in a document (presumably every time the document is autosaved). For example, if I work for an hour adding edits or comments on a document by the time I'm ready to share it it will look like five different people made changes.

    The Inspect Document fix works great to remove all the extra reviewer names, but it changes them all to 'Author'. Do you know how to then either a) change 'Author' to the reviewer's actual name or b) stop Office from assigning multiple names to the same reviewer. Also, we've tried checking 'Always use these values regardless of sign in' under General to no avail.

    Thanks - your fix is the closest we've come to a solution and it's greatly appreciated.


     


    Thursday, March 05, 2015 7:09 PM
  • You can change the author names for comments using a simple VBA sub such as the following:

    Sub ChangeCommentUserNamesInWordDoc() 'Macro created by Stefan Blom, Word MVP

    Dim c As Comment For Each c In ActiveDocument.Comments c.Author = "Donald Donaldson" 'specify the name here Next c 'NOTE: The Author property is hidden in the Word 2013 'object model, which means that it won't be supported 'in the future. End Sub


    Changing the user names for revisions is a bit more complex. If your files are in the *.docx format, you can edit the reviewer names by modifying the document.xml file. (To access document.xml you have to change the filename extension from DOCX to ZIP so that you can open it.)


    Stefan Blom, Microsoft Word MVP


    Thursday, March 05, 2015 7:52 PM
  • Stefan; 

    Thanks that seems to have worked... This setting seems to have changed without provocation in my org!?  Is the only way to make an org wide setting change through office GPOs, to your knowledge?

    Wednesday, March 25, 2015 2:55 PM
  • Stefan; 

    Thanks that seems to have worked... This setting seems to have changed without provocation in my org!?  Is the only way to make an org wide setting change through office GPOs, to your knowledge?

       

    The "Remove personal information..." setting is document-specific. It gets selected after you run the Document Inspector on a document and choose to remove "Document Properties and personal information."


    Stefan Blom, Microsoft Word MVP

    Wednesday, March 25, 2015 2:58 PM
  • I'm having a similar problem and the above solution didn't work. For this particular Word file (Word 2013), my name and time stamp disappear on balloon comments when I reopend it, although new comments had my name and time stamp. (Of course I don't know what will happen to those new comments!)  Not only this, but when I used the Compare feature to another document, it would only come in Draft mode. I was unable to unclick the Draft icon.

    Any ideas? Thanks in advance!



    • Edited by drtravel47 Sunday, June 14, 2015 3:13 PM
    Sunday, June 14, 2015 3:09 PM
  • Hi Stefan,

    Would you be able to offer a global solution within the Word options to keep the personal user name for comments and track changes instead of the document specific fix? If possible, I would prefer to not have to manually uncheck "Remove personal information..." for my name to display in the comments.

    Thank you kindly,

    Erin

    Monday, July 06, 2015 6:48 PM
  • Hi Stefan,

    Would you be able to offer a global solution within the Word options to keep the personal user name for comments and track changes instead of the document specific fix? If possible, I would prefer to not have to manually uncheck "Remove personal information..." for my name to display in the comments.

    Thank you kindly,

    Erin

       

    If "Remove personal information..." is selected in all of your documents, then the Document Inspector has been run on the template you are using for new documents. Or perhaps you are using an existing document as a "template," by creating new documents from that document via File | Save As?

    In either case, what you have to do is deselect the option in whatever file you use as the basis for new documents. That fixes the problems for future documents based on the file in question.


    Stefan Blom, Microsoft Word MVP

    Monday, July 06, 2015 7:13 PM
  • hello stefan.

    u r sooo helpful! thank u - it worked wonders for me!  however, i would like the previous changes/commens to also show my personal name; those still show as author - is that even possible to see my name for old changes/comments?  

    i am new to this... how will i receive my response?  to my email - or must i check this thread?  thanks again.

    Sunday, August 30, 2015 8:44 PM
  • Changing the name for comments is easy. See the macro I posted above.

    Changing the author for revisions/tracked changes requires XML-knowledge and it is beyond my skills. Someone else may know how to do this safely.


    Stefan Blom, Microsoft Word MVP

    Monday, August 31, 2015 11:13 PM
  • The 'Remove personal information...' option is greyed out and I need to remove the personal information so that Author shows up.  What's the secret to doing that?

    Tuesday, November 24, 2015 5:45 PM
  • The 'Remove personal information...' option is greyed out and I need to remove the personal information so that Author shows up.  What's the secret to doing that?

          

    To enable that option you must first run the Document Inspector on the document (in Word 2013 or 2016, click File | Info | Check for Issues | Inspect Document) and choose the option to remove document properties and personal information.


    Stefan Blom, Microsoft Word MVP

    Tuesday, November 24, 2015 7:10 PM
  • This is great that there is an option to "Remove personal information from file properties on save", but who on earth thought it was a good idea to have this checked on by default? Idiotic! Now all the comments and edits made in my document are unidentified.
    Tuesday, May 17, 2016 5:27 PM
  • This is great that there is an option for this, but who on earth thought it was a good idea to have this checked on by default? Idiotic!

      

    If you are referring to the "Remove personal information..." option, note that for it to be selected by default, the Document Inspector must, at one point, have been run for the file from which the document was created.


    Stefan Blom, Microsoft Word MVP

    Tuesday, May 17, 2016 5:34 PM
  • Hi Stefan,

    I have the same problem - that the document changed my name to "Microsoft User" after having it the first time I used it.  I use Word for Mac in the 2016 version. I cannot find a File - Tab option and a search for Trust Center also gives me no result.

    Please advice what I should do

    Thanks,  Bala

    Monday, June 20, 2016 12:23 AM
  • Hi Stefan,

    I have the same problem - that the document changed my name to "Microsoft User" after having it the first time I used it.  I use Word for Mac in the 2016 version. I cannot find a File - Tab option and a search for Trust Center also gives me no result.

    Please advice what I should do

    Thanks,  Bala

      

    Since you are using MacWord, I recommend that you ask your question in the MacWord forum in the Community:

    http://answers.microsoft.com/en-us/mac/forum/macword?sort=lastreplydate&dir=desc&tab=threads


    Stefan Blom, Microsoft Word MVP

    Monday, June 20, 2016 9:51 AM
  • Stefan, great answer! thank you, took me a few hours to this blog.  But then again we all know how MicroSoft kind of likes to make life hard.   Thank you! youre one in a million and this really helped. Lets hope you dont get fired or let go for helping us little folk.

    Thursday, October 13, 2016 4:35 PM
  • Hi, Stefan. You seem to have solved a lot of other problems in this category so I am hoping you can solve mine, as well. I have Word 2013 and from the time I first started using it when I click on the Review tab and insert a new comment it would appear showing my name and my Microsoft “account picture” plus the typed comment. Now the account picture has disappeared and all you see is the icon of a generic person, along with my name. Because I’m a medical editor who is constantly working on files with comments from many different people the photo is actually useful because at a glance I can whiz through a 40-page document, just slowing down when I see the photo in order to see if people have responded to my comments. I have no idea why it disappeared. It may or may not be related to a time when one of the docs for whom I was doing editing asked me to substitute his name for the comments so it would appear that all the comments were from him. I later changed it back to my name and initials. I can’t honestly say if that’s when the photo disappeared but it was probably at least close to that. So….whether or not it’s related to that, any thoughts on restoring the photo? And yes, under “Track Change Options” “Pictures by Comments” is checked. I can turn that on or off but that just either shows the little generic icon or removes it. The picture that has always been there previously, the one associated with my computer and Microsoft account, does not reappear in place of the icon.  Thanks!  Lark
    Thursday, June 15, 2017 3:06 AM
  • Are you signed in with the correct account in Office?

    Stefan Blom, Microsoft Word MVP

    Friday, June 16, 2017 7:32 AM