none
Outlook 2010 and the age old winmail.dat problem

    Question

  • I've run into the the winmail.dat problem in the past, and the solution has always been to set the recipient's contact to "Let Outlook decide the best sending format".  I've got this happening now with a twist that I haven't seen before after upgrading a standalone client from Outlook 2000 to Outlook 2010.  When FORWARDING and ONLY FORWARDING an HTML message, the recipients are getting a RTF message with a winmail.dat file.  If the message is REPLYED to, the message goes through fine. Also, there are four email accounts setup on this outlook client.  Three e-mail accounts are POP and One is an MSN account/MAPI.  The problem does not seem to happen when forwarding from the MSN account. have tried everything I could think of or find on a google search:

    - Set Contact to "Let Outlook decide the best sending format".
    - In Options/Mail/Compose Messages in this format set to "HTML"
    - In Options/Mail When Sending Messages in RTF to Internet to "convert to HTML format"
    - Cleared entry from cache, exited outlook, and manually typed entry in
    - Added Key:
    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences]
    "DisableTNEF"=dword:00000001
    - Disabled Anti-virus e-mail scanning

    Since replying works, I gave this to them as a work around, but this is either some type of bug, some incomaptibility, or something I'm missing.  Does anyone have any idea what is going on?

    Thanks,

    Jeff

    Tuesday, November 09, 2010 4:39 AM

Answers

  • Having the same issue as everyone else, tried all the plaintxt fixes, edityed the regisrty, changed the font to Caibri, deleted the signature entirely, all to no avail.

    The issue is only from one Outlook 2010 account, when she sends word doc's they come through as the dreaed winmail.dat yet when anypne else sends to thesame people it comes across as the regular word doc.   Its when an exchange user sends to a webmail client so that may be the wrinkle but When i send to the same people it doesnt happen.  Our email hosting company is usless cause all they do is quote the KB articles even after I told them we did them all.

     

    any help or suggestions are greatly appreicated!

    thanks

    scott

     

     


    You have to delete the autocomplete cache (RTF settings are saved with the addresses.)

    This finally worked for me!

     

    • Proposed as answer by Scott Rossi Thursday, January 26, 2012 7:31 PM
    • Marked as answer by Jeffery Smith Tuesday, July 10, 2012 1:56 AM
    Thursday, January 26, 2012 7:31 PM
  • I found the solution:

    http://support.microsoft.com/kb/958012

    Only this is for Office 2007, so you have to use the Office14 string in the registry instead of the Office12.  It works!  I got it from this Microsoft technet Help:

    http://social.answers.microsoft.com/Forums/en-US/outlooksend/thread/f361b78c-6830-4d76-ac3d-c9d448c7d710

    Make sure back up your registry for prudence :)    (very easy to back up, file- export- save...)

     

    • Proposed as answer by artnascar7 Tuesday, November 16, 2010 1:10 PM
    • Marked as answer by Sally Tang Thursday, November 18, 2010 6:28 AM
    Tuesday, November 16, 2010 1:10 PM

All replies

  • Hi Jeff,

     

    This problem occurs because the Winmail.dat file is used to preserve formatting that the sending client includes in the message, but the receiving client does not recognize the Winmail.dat file. In Outlook, the Winmail.dat file includes Rich Text Formatting (RTF) instructions. This type of formatting is used with the Microsoft Outlook Rich Text format and when you use Microsoft Word as your e-mail editor.

     

    To resolve this problem, use the plain text format.

     

    For more information about this issue, you can refer to the following KB articles:

     

    Winmail.dat attachments are included in received e-mail messages in Outlook

    http://support.microsoft.com/kb/278061

     

    How to Prevent the Winmail.dat File from Being Sent to Internet Users

    http://support.microsoft.com/kb/138053

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     

    Wednesday, November 10, 2010 7:24 AM
  •  

    Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Friday, November 12, 2010 7:58 AM
  • Hi Sally

    I had this same problem w/ Outlook 2007 and just upgraded to 2010 in the hope it would have been fixed.  Unfortunately it's not.

    I have used the work-around you suggested, but, no offense, it's really not practical.  Not only do you have to remember to change to plain text for just the few recipients that have this problem, but you lose all the HTML formatting features - it's like going back to DOS.  Plus it's REALLY a problem to forward any kind of message that contains any pictures, graphics or links in the body.

    What I am looking for is a permanent fix that will enable me to send HTML emails to anyone.  By the way, do you have any idea what the factor is that causes this problem?  I would say that only 10% of my email recipients have this trouble and I can find no common denominator.

    Thanks.

    • Proposed as answer by ReySys Wednesday, March 20, 2013 11:07 PM
    • Unproposed as answer by ReySys Wednesday, March 20, 2013 11:07 PM
    Saturday, November 13, 2010 2:03 AM
  • Hello to all,

    I am having the same problem here at work.  I have been reading on the topic.  It seems as if it is RTF only.  So then HTML or plain text should solve this problem.  I am not having any progress.  However I find it is when a message is forwarded, new messages are not affected.

    HTML is very important.

    Thank you,

    Art

    Monday, November 15, 2010 3:58 PM
  • I found the solution:

    http://support.microsoft.com/kb/958012

    Only this is for Office 2007, so you have to use the Office14 string in the registry instead of the Office12.  It works!  I got it from this Microsoft technet Help:

    http://social.answers.microsoft.com/Forums/en-US/outlooksend/thread/f361b78c-6830-4d76-ac3d-c9d448c7d710

    Make sure back up your registry for prudence :)    (very easy to back up, file- export- save...)

     

    • Proposed as answer by artnascar7 Tuesday, November 16, 2010 1:10 PM
    • Marked as answer by Sally Tang Thursday, November 18, 2010 6:28 AM
    Tuesday, November 16, 2010 1:10 PM
  • Sally, Outlook users should be able to send formatted email to non-Outlook users. Apparently Outlook does not allow that. 

    Why can't Outlook send formatted HTML or RTF email to non-Outlook users? Why does it have to use winmail.dat? I don't understand how this could still be a problem at the end of 2010. There are email standards and protocols that clients should follow, no? I don't believe winmail.dat is part of an accepted standard.

    (For what it's worth, my company is considering Microsoft SBS and Exchange. This issue alone has actually caused me to say NO to Exchange + Outlook + SBS. Until this issue is fixed, we will have to pass on SBS.)

     

    Friday, November 19, 2010 1:32 AM
  • The problem is not what everyone's Mind-f*****g.  If you try the registry trick and it doesn't work, try changing your signature font to something that HTML recognizes like Outlook's default Calibri(body).  If you have any pictures or logos in your signature, you should remove those as well.  If you have any formatting in your signature, it will convert that into the "winmail.dat" file for Rich Text (as any signature formatting is actually rich text) and mess up the whole thing.

    That's what I did to fix it.

    Change your font back to Calibri (body) and remove any and all logos/pictures in your signature.

    Friday, July 22, 2011 4:27 PM
  • I wish people would stop just re-quoting http://support.microsoft.com/kb/958012

     

    this does NOT fix the issue and in any case the Office14 information is stipulated. The automated fix puts the code in that you'd otherwise manually have to but its correct.. And doesnt work

     

    I have a network of 50 users. ALL are using Outlook 2010 connected to Exchange 2007

    We have 1 important client in Ireland who is not using Exchange.

    They receive emails from 49 of us with perfect attachments and screengrabs etc all great

    one poor user (had to be the important finance manager) - no matter what she sends, her emails are received as windats and she has the same setup as the other 49 users

    HELP :(

    Thursday, October 06, 2011 4:12 PM
  • I've had this problem since starting work with a client using Lotus Notes. 90% of users receive my Outlook 2010 attachments OK, but 3 Users (incl. my Project Sponsor) has this problem.

    Tried the Calibri, No logo suggestion and not working. The rt-click Send Options is not available in 2010.

    Client's IT say they cannot fix it their end.

     

    Misery :(((

    Tuesday, October 11, 2011 3:58 PM
  • I've got the same problem. Outlook 2010. Set to HTML.  Win 7 (64).  Standard font.

    Only person who still uses Outlook Express gets the winmail.dat on occasion from my mail.  It's definitely not limited to Forwarded emails.  It's usually when I create an email for him and attach reduced size .jpg's.  After he complains, I'll then forward the same email I sent to him previously and it works fine without any winmail.dat file.   

    Of course, I can set the Outlook Mail option to Text Only, but that applies to everyone.  I can't find any way in Outlook 2010 to send Text Only just to him.  I would prefer to keep HTML for everyone so that I can use all the formatting. 

    Nor can I find any "Let Outlook choose" option for his email address.

    Obviously this issue is for those of us who use Outlook to send/receive emails.  Could his old Outlook Express email client also contribute to this problem? I notice that I cannot receive any embedded photos that he sends to me.  They are all blanked out and I can't even right click to allow them. 

    I used Norton 360.  He uses McAfee.

    Any other solutions that haven't been mentioned in this string?

    Thanks very much. Craig   

    Saturday, October 29, 2011 5:14 PM
  • Having the same issue as everyone else, tried all the plaintxt fixes, edityed the regisrty, changed the font to Caibri, deleted the signature entirely, all to no avail.

    The issue is only from one Outlook 2010 account, when she sends word doc's they come through as the dreaed winmail.dat yet when anypne else sends to thesame people it comes across as the regular word doc.   Its when an exchange user sends to a webmail client so that may be the wrinkle but When i send to the same people it doesnt happen.  Our email hosting company is usless cause all they do is quote the KB articles even after I told them we did them all.

     

    any help or suggestions are greatly appreicated!

    thanks

    scott

     

     

    Thursday, January 26, 2012 6:57 PM
  • Having the same issue as everyone else, tried all the plaintxt fixes, edityed the regisrty, changed the font to Caibri, deleted the signature entirely, all to no avail.

    The issue is only from one Outlook 2010 account, when she sends word doc's they come through as the dreaed winmail.dat yet when anypne else sends to thesame people it comes across as the regular word doc.   Its when an exchange user sends to a webmail client so that may be the wrinkle but When i send to the same people it doesnt happen.  Our email hosting company is usless cause all they do is quote the KB articles even after I told them we did them all.

     

    any help or suggestions are greatly appreicated!

    thanks

    scott

     

     


    You have to delete the autocomplete cache (RTF settings are saved with the addresses.)

    This finally worked for me!

     

    • Proposed as answer by Scott Rossi Thursday, January 26, 2012 7:31 PM
    • Marked as answer by Jeffery Smith Tuesday, July 10, 2012 1:56 AM
    Thursday, January 26, 2012 7:31 PM
  • this problem only come when u r sending on behalf of any other user ,

    Thursday, February 16, 2012 6:30 AM
  • Having the same issue as everyone else, tried all the plaintxt fixes, edityed the regisrty, changed the font to Caibri, deleted the signature entirely, all to no avail.

    The issue is only from one Outlook 2010 account, when she sends word doc's they come through as the dreaed winmail.dat yet when anypne else sends to thesame people it comes across as the regular word doc.   Its when an exchange user sends to a webmail client so that may be the wrinkle but When i send to the same people it doesnt happen.  Our email hosting company is usless cause all they do is quote the KB articles even after I told them we did them all.

    any help or suggestions are greatly appreicated!

    thanks

    scott


    You have to delete the autocomplete cache (RTF settings are saved with the addresses.)

    This finally worked for me!

    Hi Scott. Can you advise how to do this please?

    Thanks.

    Monday, July 02, 2012 7:28 PM
  • Found it. Did it. Fixed it.

    Thanks.

    Tuesday, July 03, 2012 12:06 AM
  • This is good information. I didn't know I was going to start such a controversial thread when I asked this question. J  To be fair, I did not try this solution, but it makes good sense for the problem I was having.  The client just started using the reply work-around instead of forwarding messages, so the problem dropped off my radar.

    Cheers,

    Jeff

    Tuesday, July 10, 2012 1:58 AM
  • Telling people to use plain text is not only not useful, its actually insulting.  Its as if someone told you that their front door on their house makes a squeaking noise when they open it and so you tell them to board it up and don't use it.  That's an idiotic response.  People obviously want to send emails with formatting and attachments embedded.  Don't tell us not to use those features.  Instead tell us how to fix it so that it works like its supposed to.  Sheesh!
    Friday, November 02, 2012 1:26 AM
  • Another way to resolve the problem is to Delete "broken" Contact from Outlook Contacts and create it again.

    Contacts were created in Exchange2003 & Outlook2003(-), and they were migrated to Exchange & Outlook 2010 environment and I had RTF problems with them(less than 0.2%).

    In the past there were a possibility to define message format per single contact, but now( i think) it is not possible. Somehow Exchange remembered the old parameters, but now you can't change it from MS Outlook(i think). If it Is possible to change it, It will be the another way to resolve the problem.

    • Proposed as answer by Masakrator1 Tuesday, November 13, 2012 12:36 PM
    • Edited by Masakrator1 Tuesday, November 13, 2012 12:56 PM
    Tuesday, November 13, 2012 12:31 PM
  • Found this, which seems to contain all the necessary fixes!

    http://help.em.ucla.edu/app/answers/detail/a_id/1196/~/preventing-the-winmail.dat-file-from-being-sent-to-your-contacts-in-outlook-2010

    • Proposed as answer by datpete Friday, November 16, 2012 2:13 PM
    Friday, November 16, 2012 2:08 PM
  • I have not found any perfect solution, and I've been seeing this problem since Outlook 2K.  This just happened again for another client communicating with a Mac user.  I told them to include a dropbox link in the e-mail to the files.  This seems to have worked.

    Jeff

    Monday, November 19, 2012 6:07 PM
  • I do the registry part but not working. Outlook 2010 in HTML format.

    Exchange 2003 Sp3 & Outlook 2010 Sp1

    What do the trick was to change in the Exchange 2003 server format option to not use RTF to never.


    MCP soon MCDBA, DCE 2 Stars, DCE 2k5 2 Stars, Technet 4 Stars

    Wednesday, March 20, 2013 11:10 PM
  • Hello -

    You need to do the registry part. DWORD for 32bit Outlook or QWORD for 64bit Outlook. Reboot. Then you need to delete the Autofill entry for the person that is receiving the winmail.dat.

    This has been successful for me on a few different accounts.

    Tuesday, March 26, 2013 5:10 PM
  • I've run into the the winmail.dat problem in the past, and the solution has always been to set the recipient's contact to "Let Outlook decide the best sending format".  I've got this happening now with a twist that I haven't seen before after upgrading a standalone client from Outlook 2000 to Outlook 2010.  When FORWARDING and ONLY FORWARDING an HTML message, the recipients are getting a RTF message with a winmail.dat file.  If the message is REPLYED to, the message goes through fine. Also, there are four email accounts setup on this outlook client.  Three e-mail accounts are POP and One is an MSN account/MAPI.  The problem does not seem to happen when forwarding from the MSN account. have tried everything I could think of or find on a google search:

    - Set Contact to "Let Outlook decide the best sending format".
    - In Options/Mail/Compose Messages in this format set to "HTML"
    - In Options/Mail When Sending Messages in RTF to Internet to "convert to HTML format"
    - Cleared entry from cache, exited outlook, and manually typed entry in
    - Added Key:
    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences]
    "DisableTNEF"=dword:00000001
    - Disabled Anti-virus e-mail scanning

    Since replying works, I gave this to them as a work around, but this is either some type of bug, some incomaptibility, or something I'm missing.  Does anyone have any idea what is going on?

    Thanks,

    Jeff

    The reason behind the automatic winmail.dat file attachment is when you try to send e-mail from an Outlook client, a file attachment called Winmail.dat may be automatically added to the end of the message if the recipient’s e-mail client cannot receive messages in Rich Text Format (RTF).

    Method 1: Change the default message format

    Method 2: Modify the recipient’s entry in the Personal Address Book

    Method 3: Set the Outlook Rich Text Format Internet e-mail setting

    Reference: http://www.ehowportal.com/avoid-sending-winmaildat-attachments-outlook/


    Sunday, November 17, 2013 7:36 AM
  • Thank you Scott Rossi!

    That worked for me however I also needed to delete the Outlook contact and recreate it again as the RTF settings must have been embedded in the email address there too.

    Cheers

    Mike

    Friday, January 17, 2014 5:13 AM