Visio 2010 Postscript No Image...& internal error 2147467259 Action 1010:print


  • Started with images not printing out, Just had x where the image was. Now it will not print at all and I have reopened the file and restarted visio no luck
    • Edited by badincite Wednesday, December 29, 2010 1:05 PM
    Monday, December 20, 2010 2:58 PM

All replies

  • Hi,

    I suggest you deleting the printer and recreate it to have a try. If it still not works, try to reinstall visio.


    Tuesday, December 21, 2010 2:55 AM
  • my experience is that when an 'X' is displayed for an image, the link to the source has been broken.



    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Al Edlund Visio MVP
    Tuesday, December 21, 2010 4:51 AM
  • Tried reinstalling visio, different files still same result
    Wednesday, December 22, 2010 2:36 PM
  • Re-formatted computer and re-installed adobe pro 9 and visio still same issue


    Update.. Prints fine to hp 5200 printer

    X appears printing to Konica Minolta  C450 Bizhib

    X appears printing to PDF from adobe

    Tuesday, December 28, 2010 6:11 PM
  •  After thinking about it the Konica and Adobe use postscript printers the 5200 is pcl, Which leads me to believe it’s a postscript issue



    MS Word 2010 Prints fine

    Tuesday, December 28, 2010 8:54 PM
  • anyone any idea's?
    Wednesday, December 29, 2010 12:59 PM
  • As Al Elund described, I had images in my file showing an x as the links to the images were broken.  I deleted the x'd images and was able to print. 

    The old version of visio (2002) that I used would simply print the x'd image as displayed on my screen.

    Monday, March 14, 2011 12:55 PM
  • I had a similar problem and resolved it this (ugly) way.

    I had built a (SharePoint Workflow) diagram in Visio Premium 2010 and could print it just fine.

    However, when I copied and pasted in a graphic image or inserted the graphic picture (.png or .bmp format)
    via Insert --> Picture menu option, the print would fail with the same error.

    To get a graphic image into my Visio drawing and have it print successfully, 
    this is what I had to do: 

    Go to Insert --> Object menu
    select Paintbrush Picture and Create New

    Once the Paint program opens, paste in the graphic image and then close the Paint program.
    Now, the graphic object that shows up in your Visio should print just did for me at least.

    Good luck 

    Tuesday, June 21, 2011 9:07 PM
  • Awesome solution!!
    Friday, November 01, 2013 5:57 PM