locked
[Win 2012] DNS Server BPA Error Can't Be Fixed RRS feed

  • Question

  • Hi,

    Environment:

    • Windows Server 2012 Standard EN-US acting as a sub-domain DC in a forest and DNS server.

    When I ran the Best Practices Analyzer for the DNS server, I get the following error:

    Title:
    DNS: DNS servers on 177-SRV001 NIC Team should include the loopback address, but not as the first entry.
    
    Severity
    Error
    
    Date:
    7/23/2014 3:54:27 AM
    
    Category:
    Configuration
    
    Problem:
    The network adapter 177-SRV001 NIC Team does not list the local server as a DNS server; or it is configured as the first DNS server on this adapter.
    
    Impact:
    If the loopback IP address is the first entry in the list of DNS servers, Active Directory might be unable to find its replication partners.
    
    Resolution
    Configure adapter settings to add the loopback IP address to the list of DNS servers on all active interfaces, but not as the first server in the list.
    
    http://go.microsoft.com/fwlink/?LinkId=188760

    The problem is that I get this message despite my "177-SRV001 NIC Team" NIC DNS configuration being correct. The server NIC DNS settings are:

    - Preferred DNS Server: 172.16.1.111 (one of the DNS server of the AD forest)

    - Alternate DNS Server: 127.0.0.1

    As you can see, the loopback address isn't the first DNS entry. I've tried to change the settings on and off, to reboot the server, but the message still remains. I fixed a similar issue on a Windows Server 2008 R2 that is DC/DNS Server in another sub-domain and it worked fine: the error message disappeared.

    Does anyone have a clue what's wrong here?




    • Edited by CuiZinieR Wednesday, July 23, 2014 9:38 AM
    Wednesday, July 23, 2014 9:35 AM

Answers

  • Hi,

    Please check IPv6 settings. You will also get this error if ::1 is listed first.

    Thanks,

    -Greg

    • Marked as answer by CuiZinieR Thursday, July 24, 2014 1:14 AM
    Wednesday, July 23, 2014 5:41 PM
  • Thank you Greg, it was indeed the cause of the message: ::1 was set in the IPv6 settings. I selected "Obtain DNS server address automatically" since we don't use IPv6 in our LAN and the error message disappeared in DNS BPA.
    Thursday, July 24, 2014 1:14 AM

All replies

  • Hi,

    Please check IPv6 settings. You will also get this error if ::1 is listed first.

    Thanks,

    -Greg

    • Marked as answer by CuiZinieR Thursday, July 24, 2014 1:14 AM
    Wednesday, July 23, 2014 5:41 PM
  • Thank you Greg, it was indeed the cause of the message: ::1 was set in the IPv6 settings. I selected "Obtain DNS server address automatically" since we don't use IPv6 in our LAN and the error message disappeared in DNS BPA.
    Thursday, July 24, 2014 1:14 AM