none
Lync 2010 and Exchange 2010 Integration error RRS feed

  • Question

  • I tried to follow the steps from Microsoft Site (http://technet.microsoft.com/en-us/library/gg420962.aspx)  but receives the error below.

    [PS] C:\Windows\system32>Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingServerName 'lync server FQDN' -InstantMessagingCertificateThumbprint 'Exchange server certificate thumbprint' -InstantMessagingType 1 -InstantMessagingEnabled $true

    A positional parameter cannot be found that accepts argument 'lync server FQDN'.
        + CategoryInfo          : InvalidArgument: (:) [Set-OwaVirtualDirectory], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Set-OwaVirtualDirectory

     

    Can some one please help me to finish this test.

    Thanks

    Bunnaks

    Thursday, October 20, 2011 9:59 AM

Answers

  • Hi ,

    Please go through below article , it might help .

    http://blog.schertz.name/2010/11/lync-and-exchange-im-integration/ 

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Thursday, October 20, 2011 10:13 AM
  • Hi,

    The exact CMD Let is,

    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingServerName <name of Instant Messaging server or pool to connect to> -InstantMessagingCertificateThumbprint <certificate thumbprint> -InstantMessagingEnabled true -InstantMessagingType 1

    add the Lync Server FQDD to the - name of Instant Messaging server or pool to connect to

    Exchange Certificate thumb Print - certificate thumbprint

    Thamara.

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:17 PM
    Thursday, October 20, 2011 10:17 AM
  • The reason the error is being generated is because you haven't actually put the FQDN and certificate thumbprint into the command.

    In the quotation marks for "lync server FQDN" you actually need to put the FQDN in i.e. lyncse1.contoso.com and in the "Exchange server certificate thumbprint" section you need to put the thumbprint of the certificate which will look something like AB2EH5DB4KH43H4 e.g. a value all in hex.

    The URLs the other guys have provided should assist you in getting the command right and help you find the FQDN and thumbprint also.


    Justin Morris | Consultant | Modality Systems
    Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:17 PM
    Thursday, October 20, 2011 10:53 AM
  • can you try this one,

    Set-OwaVirtualDirectory -Identity owa -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint EB924E2D7BC279F9F55ADBE4944403F0AAD96E14 -InstantMessagingServerName mylync.bunnaks.com

    Thamara.

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Thursday, October 20, 2011 1:36 PM
  • Hi,

    I alse encounter this issue when I deploy Exchange OWA integration with Lync.

    I find I need to use following parameters:

    Set-OwaVirtualDirectory -Identity owa(Default Web Site) -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint EB924E2D7BC279F9F55ADBE4944403F0AAD96E14 -InstantMessagingServerName mylync.bunnaks.com

    You need to add the parameters -Identity owa(Default Web Site), and only -Identity owa does not work.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Sean_XiaoModerator Friday, October 21, 2011 8:53 AM
    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Friday, October 21, 2011 8:52 AM
    Moderator

All replies

  • Hi ,

    Please go through below article , it might help .

    http://blog.schertz.name/2010/11/lync-and-exchange-im-integration/ 

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Thursday, October 20, 2011 10:13 AM
  • Hi,

    The exact CMD Let is,

    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingServerName <name of Instant Messaging server or pool to connect to> -InstantMessagingCertificateThumbprint <certificate thumbprint> -InstantMessagingEnabled true -InstantMessagingType 1

    add the Lync Server FQDD to the - name of Instant Messaging server or pool to connect to

    Exchange Certificate thumb Print - certificate thumbprint

    Thamara.

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:17 PM
    Thursday, October 20, 2011 10:17 AM
  • The reason the error is being generated is because you haven't actually put the FQDN and certificate thumbprint into the command.

    In the quotation marks for "lync server FQDN" you actually need to put the FQDN in i.e. lyncse1.contoso.com and in the "Exchange server certificate thumbprint" section you need to put the thumbprint of the certificate which will look something like AB2EH5DB4KH43H4 e.g. a value all in hex.

    The URLs the other guys have provided should assist you in getting the command right and help you find the FQDN and thumbprint also.


    Justin Morris | Consultant | Modality Systems
    Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:17 PM
    Thursday, October 20, 2011 10:53 AM
  • Thanks For all your posts, but as a fact i have followed the steps exactly but still got the same error.

    See below for details.

     

    [PS] C:\>Get-OwaVirtualDirectory | fl *instant*


    InstantMessagingEnabled : True
    InstantMessagingType    : Ocs



    [PS] C:\>Get-ExchangeCertificate|fl Services,Thumbprint


    Services   : IMAP, POP, IIS, SMTP
    Thumbprint : EB924E2D7BC279F9F55ADBE4944403F0AAD96E14



    [PS] C:\>Get-OWAVirtualDirectory

    Name                                    Server                                  OwaVersion
    ----                                    ------                                  ----------
    owa (Default Web Site)                  MYMAIL                                  Exchange2010


    [PS] C:\>Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint EB924E2D7BC279F9F55ADBE4944403F0AAD96E14 -InstantMessagingServerName mylync.bunnaks.com
    A positional parameter cannot be found that accepts argument 'EB924E2D7BC279F9F55ADBE4944403F0AAD96E14'.
        + CategoryInfo          : InvalidArgument: (:) [Set-OwaVirtualDirectory], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Set-OwaVirtualDirectory

    [PS] C:\>Get-OwaVirtualDirectory | fl *instant*


    InstantMessagingEnabled : True
    InstantMessagingType    : Ocs

    :::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

    This is a snapshot of the commands and error i received.

     

    Thursday, October 20, 2011 12:58 PM
  • Have you tried putting quotation marks around the certificate thumbprint you specify?

    Also make sure you put a space between -InstantMessagingEnabled and $true and remove the colon.


    Justin Morris | Consultant | Modality Systems
    Blog - www.justin-morris.net
    Twitter: @jm_deluxe
    If this post has been useful please click the green arrow to the left or click "Propose as answer"

    Thursday, October 20, 2011 1:26 PM
  • can you try this one,

    Set-OwaVirtualDirectory -Identity owa -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint EB924E2D7BC279F9F55ADBE4944403F0AAD96E14 -InstantMessagingServerName mylync.bunnaks.com

    Thamara.

    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Thursday, October 20, 2011 1:36 PM
  • Hi,

    I alse encounter this issue when I deploy Exchange OWA integration with Lync.

    I find I need to use following parameters:

    Set-OwaVirtualDirectory -Identity owa(Default Web Site) -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint EB924E2D7BC279F9F55ADBE4944403F0AAD96E14 -InstantMessagingServerName mylync.bunnaks.com

    You need to add the parameters -Identity owa(Default Web Site), and only -Identity owa does not work.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Sean_XiaoModerator Friday, October 21, 2011 8:53 AM
    • Marked as answer by BUNNAKS Friday, October 21, 2011 3:16 PM
    Friday, October 21, 2011 8:52 AM
    Moderator
  • Sorry for all, i forgot to upgrade the exchange to SP1

    The command worked best.

     

    Thanks for all your help.

    Friday, October 21, 2011 3:16 PM