none
user profile synchronization service stuck on starting RRS feed

  • Question

  • Brief info:

    SP enviornment:

    SP 2010  installed on Win 2008 R2 (just installed SharePoint 2010 SP1 tonight ....11/11/2011).  Database on seperate server

    I have one Farm Account:  SP_Admin.  This user is a domain admin and has local admin rights and logon rights too.

    Installed all Windows updates as of 11/11/2011

    Everything works fine expect the user profile synchronization service which is stuck on starting.

    I have read (a dozen times already) this website:  http://www.harbar.net/articles/sp2010ups.aspx (most people claim it's helped them a lot solving their issues).  It has not solved mine.

    Troubleshooting I've done:

    stop the service via Powershell w/the command Stop-SPServiceInstance <GUID>.  Start again from central admin, reset IIS, waited up to 1-2 hours only to find it's still "starting"

    Followed this guide (3 times):  http://sharepoint.tejic.com/2011/10/07/user-profile-synchronization-service-stuck-on-starting/  That did not solve my problem (used this website to help me figure out how delete it all and redo from scratch).

    I've double and triple checked my Farm account password (my SP_Admin account).  That checks out.  Logged into the server locally and domain using my farm account and did all the troubleshooting.  Nothing worked.  I've restarted the server too many times already.

    For the life of me, I cannot get this service started.  Thus, I'm unable to use My Sites and users are eager to start playing with it since I have service pack 1 installed now.

    What else could I do?  Am I missing something?  anyone have any other solutions?

    Thank you in advance.

    Steve

    Saturday, November 12, 2011 9:59 AM

Answers

  • check this with images : http://myspexp.com/2011/04/28/user-profile-synchronization-servicehangs-on-starting-i-fixed-it/


    To resolve it do the following things:

    • Stop the User Profile Synchronization Service
    • Open IIS (inetmgr)
    • Click on the server name and select Authentication
    • Selected Anonymous Authentication then choose Edit
    • Click the specific user, then enter “IUSR”
    • Add the service account to Local Admin group on the server
    • Add the service account to all the FIM groups
    • add the service account to the WSS_WSP and WSS_Admin_WPG group
    • Perform an IISRESET
    • Create a new User Profile Synchronization Service Application
    • Started the User Profile Synchronization Service

    Stop the User Profile Synchronization Service

    First you have to start SharePoint PowerShell

    • Go to Start
    • Microsoft SharePoint 2010 Products
    • Right click on SharePoint 2010 Management Shell
    • Choose “Run as Administrator” from the context menu

    Description: image

    Type in Get-SPServiceInstance then capture the GUID of the User Profile Synchronization Service as shown below

    Description: image

    Now that you have the GUID, type in Stop-SPServiceInstance <GUID> as shown below…

    Description: image

    Now your service is stopped…

    Description: image

    …But we are not yet out of the woods… We have a lot left to go…

    Open IIS (inetmgr)

    Go to:

    • Start
    • Type in “inetmgr

    Click on the server name and select Authentication

    Click on your server host name, then double click Authentication

    Description: image

    Selected Anonymous Authentication then choose Edit

    Click on Anonymous Authentication then click Edit…

    Description: image

    Click the specific user, then enter “IUSR”

    Add IUSR to the specific user account

    Description: image

    Add the service account to Local Admin group on the server

    Go to:

    • Start type in “compmgmt.msc
    • Go to Local Users and Groups
    • Go to Groups
    • Double Click Administrators

    Description: image

    Add the service account to your computer

    Description: image

    Click “OK” then keep the Computer Management window open

    Add the service account to all the FIM groups

    Do the exact same to all of the FIM groups as you did above

    Description: image

    Add the service account to the WSS_WSP and WSS_Admin_WPG group

    Again, do the same as you did above but for all the WSS_WSP and WSS_Admin_WPG groups

    Description: image

    Perform an IISRESET

    Go to:

    • Start
    • Type in “cmd
    • In the command shell type in “IISRESET”

    Create a new User Profile Synchronization Service Application

    Description: image

    Choose User Profile Service Application

    Description: image

    Add the following fields (I added 2 to any of the database table names as shown below)

    Description: image

    Click Create

    Perform an IISReset

    Open services.msc and restart ‘Forefront Identity Manager Service’ & ‘Forefront Identity Manager Synchronization Service’.

    Make sure you can get to this new application with out errors. It is very important that you can access this and that you know you can at this point. If you can not, then you will have to do further trouble shooting…

    Description: image

    Note: If still unable to get to the User Profile Application…

    If you are still unable to get to the User Profile Application service, you will want to check one more thing. That is to ensure that your WCF services are still running in IIS Manager, you will need to make sure the site has been started

    Description: image

    Perform another IISReset then try again.

    Open ULS Log Viewer to get ready…

    At this point in time, you will want to be ready to start tracing the User Profiles logs…

    In ULS Log Viewer, right click on the log area and choose Filter by Item. Then choose Category and type in “User Profiles”. This will allow you to filter out only what you need at this point.

    Description: image

    Started the User Profile Synchronization Service

    Now you must restart your service with the new user profile synchronization service application that you just created.

    • Navigate to Central Admin again
    • Under System Settings, choose Manage Services on Server

    Description: image

    • Click on Start under User Profile Synchronization Service

    Description: image

    • Enter your system account’s password twice
    • Click OK

    Description: image

    • Now in the ULS Log Viewer you will notice the following, this is good, it is rebuilding the FIM configuration (formally called ILM, but SharePoint never updated the name)

    Description: image

    And if you did everything correctly then you should see everything running as it needs to be:

    Description: image

    Don’t forget to configure your MySite information in the new User Profile Service Application you created. You will need to re-run all of your profile synchronization.

    Let me know if this has helped you!


    Viral Shah http://sharepointshah.blogspot.com

    • Proposed as answer by Viral23 Monday, October 29, 2012 11:17 AM
    • Marked as answer by Pratik VyasModerator Thursday, June 20, 2013 6:34 AM
    Monday, October 29, 2012 11:17 AM
  • User Profile service is a weird feature in 2010. The "Struck ok Starting" is a very Common issue. The best option would be to dissociate the SA. Delete the connections. Delete the SA. Create a new SA with new app pool and new Database. Publish it. associte web apps. this should work.

    thanks

    Nez

    Monday, October 29, 2012 3:29 PM

All replies

  • try this url

    http://myspexp.com/2011/04/28/user-profile-synchronization-servicehangs-on-starting-i-fixed-it/

     


    Regards, Fadi Abdulwahab. http://sqlgoogler.blogspot.com/ Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you
    Saturday, November 12, 2011 10:05 AM
  • Hi,

    Try this link to troubleshoot UPS:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-user-profile-sync-in-sharepoint-2010.aspx

     


    Regards
    Henrik A. Halmstrand
    sharepointrevealed.com
    getspconfig.codeplex.com
    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.
    Saturday, November 12, 2011 8:17 PM
  • This is the most common issue, to resolve this:
    Be sure that Service Pack1 and cumulative updates are installed.

    Mare sure that once you've updated hotfix for SharePoint 2010, you must use the command "psconfig -cmd upgrade -inplace b2b -wait" and then check product and patch installation status (Central Administration >Upgrade and Migration > Check product and patch installation status)
    For User Service Profile service account perspective, you must configure the following for this service account:

    • A member of Farm Administrator group
    • A member of Local Administrator group in the server you are running SharePoint 2010 as application server (Server Manager >Configuration > Local Users and Groups > Groups. R-click Administrators group and then select Add to Group. In the Administrator Properties windows, clickAdd and then select your User profile service account)
    • Log on locally policy in the server you are running SharePoint 2010 as application server (Start> Administrative Tools > Local Security Policy >Local Policies > User Right Assignment. R-clickAllow log on locally and select Properties. You will then do a few easily steps to complete configuration). Using the commandgpupdate /force to confirm the changes.

    You will then need to use the following command to stop User Profile Service Application due to "Starting" forever.
    Get-SPServiceInstance
    Stop-SPServiceInstance -Identity “service application GUID”
    Delete the existing User Profile service application and then re-provision one.
    After completely configuring properly permission for User Service Profile service account as well as re-provisioning a new User Profile service application, you start new User Profile service application and need to check FIM service. Make sure that two FIM services are started automatically. Don't force it to start because let User profile service automatically does.


    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Saturday, November 12, 2011 11:47 PM
  • Hi

    Try to follow the instruction on the following article may be you missed some point during configuration

    Configure profile synchronization (SharePoint Server 2010)

    Also take a look to the Harper article may it help

    “Stuck on Starting”: Common Issues with SharePoint Server 2010 User Profile Synchronization

    Also check that farm service account must be in the the following local groups for the service to start successfully

    Administrator

    IIS_IUSRS

    WSS_ADMIN_WPG

    WSS_WPG

    Regards.


    Ahmed Naji SharePoint Geek
    MCP|MCTS
    My Blog | DotnetFinder
    • Edited by Ahmed Naji Sunday, November 13, 2011 6:12 PM
    Sunday, November 13, 2011 5:58 PM
  • try this url

    http://myspexp.com/2011/04/28/user-profile-synchronization-servicehangs-on-starting-i-fixed-it/

     


    Regards, Fadi Abdulwahab. http://sqlgoogler.blogspot.com/ Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you

    Thanks Fabi.  Tried this befrom (found about 4-5 other websites w/the same solution) but sorry to report none worked.
    Monday, November 14, 2011 7:04 PM
  • This is the most common issue, to resolve this:
    Be sure that Service Pack1 and cumulative updates are installed.

    Mare sure that once you've updated hotfix for SharePoint 2010, you must use the command "psconfig -cmd upgrade -inplace b2b -wait" and then check product and patch installation status (Central Administration >Upgrade and Migration > Check product and patch installation status)
    For User Service Profile service account perspective, you must configure the following for this service account:

    • A member of Farm Administrator group
    • A member of Local Administrator group in the server you are running SharePoint 2010 as application server (Server Manager >Configuration > Local Users and Groups > Groups. R-click Administrators group and then select Add to Group. In the Administrator Properties windows, clickAdd and then select your User profile service account)
    • Log on locally policy in the server you are running SharePoint 2010 as application server (Start> Administrative Tools > Local Security Policy >Local Policies > User Right Assignment. R-clickAllow log on locally and select Properties. You will then do a few easily steps to complete configuration). Using the commandgpupdate /force to confirm the changes.

    You will then need to use the following command to stop User Profile Service Application due to "Starting" forever.
    Get-SPServiceInstance
    Stop-SPServiceInstance -Identity “service application GUID”
    Delete the existing User Profile service application and then re-provision one.
    After completely configuring properly permission for User Service Profile service account as well as re-provisioning a new User Profile service application, you start new User Profile service application and need to check FIM service. Make sure that two FIM services are started automatically. Don't force it to start because let User profile service automatically does.


    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal

     

    Sorry to report - none of this solved my issue either.  And I tried under my regular SP account which has domain admin rights and local rights on the server, and I used my sevice and farm accounts too.  What's interesting is when I run the stop-spserviceinstance - my two FIM servicess go for autonomic to disabled.  Thank you for the reply....my search continues....

    Tuesday, November 15, 2011 3:34 AM
  • What do you mean with "non" of this? what did you do exactly?
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Tuesday, November 15, 2011 10:16 PM
  • What do you mean with "non" of this? what did you do exactly?
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal

    I mean all the instrctions provided - I went through step-by-step and double and triple verified everything - and nothing worked.  My User Profile Service is still stuck in "starting."
    Wednesday, November 16, 2011 6:54 PM
  • Can you share your ULS log with us?

     


    Regards
    Henrik A. Halmstrand
    sharepointrevealed.com
    getspconfig.codeplex.com
    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.
    Thursday, November 17, 2011 11:20 AM
  • Hiya,

    When you recreated your UPS, did you create it with the same name or used different name?

    Thursday, November 17, 2011 11:54 AM
  • hi... check this out 

    http://blogs.msdn.com/b/yousefomar/archive/2012/01/17/10193985.aspx

    i hope be useful


    MBS - social.technet.microsoft.com Forum

    • Proposed as answer by DanKline Sunday, October 28, 2012 8:27 PM
    • Unproposed as answer by DanKline Sunday, October 28, 2012 8:27 PM
    Sunday, July 1, 2012 6:59 AM
  • It may be a fluke, but after battling this one and reprovisioning the Sync DB, I continued to face this issue, yet when I looked at the timer jobs, they looked like they were succeeding. Hmmmm?  So being stubborn, I did step one, I could not stop the synchronization service, because it said starting ( I suppose I could have with a net-stop).  I restarted the profile service to see if it would allow me to shut down the synchronization. The screen refreshed and both timers had started successfully.

    In short, before trying anything tedious and crazy, try stopping the User Profile Services in Services on server.


    Make it happen.

    Sunday, October 28, 2012 8:33 PM
  • check this with images : http://myspexp.com/2011/04/28/user-profile-synchronization-servicehangs-on-starting-i-fixed-it/


    To resolve it do the following things:

    • Stop the User Profile Synchronization Service
    • Open IIS (inetmgr)
    • Click on the server name and select Authentication
    • Selected Anonymous Authentication then choose Edit
    • Click the specific user, then enter “IUSR”
    • Add the service account to Local Admin group on the server
    • Add the service account to all the FIM groups
    • add the service account to the WSS_WSP and WSS_Admin_WPG group
    • Perform an IISRESET
    • Create a new User Profile Synchronization Service Application
    • Started the User Profile Synchronization Service

    Stop the User Profile Synchronization Service

    First you have to start SharePoint PowerShell

    • Go to Start
    • Microsoft SharePoint 2010 Products
    • Right click on SharePoint 2010 Management Shell
    • Choose “Run as Administrator” from the context menu

    Description: image

    Type in Get-SPServiceInstance then capture the GUID of the User Profile Synchronization Service as shown below

    Description: image

    Now that you have the GUID, type in Stop-SPServiceInstance <GUID> as shown below…

    Description: image

    Now your service is stopped…

    Description: image

    …But we are not yet out of the woods… We have a lot left to go…

    Open IIS (inetmgr)

    Go to:

    • Start
    • Type in “inetmgr

    Click on the server name and select Authentication

    Click on your server host name, then double click Authentication

    Description: image

    Selected Anonymous Authentication then choose Edit

    Click on Anonymous Authentication then click Edit…

    Description: image

    Click the specific user, then enter “IUSR”

    Add IUSR to the specific user account

    Description: image

    Add the service account to Local Admin group on the server

    Go to:

    • Start type in “compmgmt.msc
    • Go to Local Users and Groups
    • Go to Groups
    • Double Click Administrators

    Description: image

    Add the service account to your computer

    Description: image

    Click “OK” then keep the Computer Management window open

    Add the service account to all the FIM groups

    Do the exact same to all of the FIM groups as you did above

    Description: image

    Add the service account to the WSS_WSP and WSS_Admin_WPG group

    Again, do the same as you did above but for all the WSS_WSP and WSS_Admin_WPG groups

    Description: image

    Perform an IISRESET

    Go to:

    • Start
    • Type in “cmd
    • In the command shell type in “IISRESET”

    Create a new User Profile Synchronization Service Application

    Description: image

    Choose User Profile Service Application

    Description: image

    Add the following fields (I added 2 to any of the database table names as shown below)

    Description: image

    Click Create

    Perform an IISReset

    Open services.msc and restart ‘Forefront Identity Manager Service’ & ‘Forefront Identity Manager Synchronization Service’.

    Make sure you can get to this new application with out errors. It is very important that you can access this and that you know you can at this point. If you can not, then you will have to do further trouble shooting…

    Description: image

    Note: If still unable to get to the User Profile Application…

    If you are still unable to get to the User Profile Application service, you will want to check one more thing. That is to ensure that your WCF services are still running in IIS Manager, you will need to make sure the site has been started

    Description: image

    Perform another IISReset then try again.

    Open ULS Log Viewer to get ready…

    At this point in time, you will want to be ready to start tracing the User Profiles logs…

    In ULS Log Viewer, right click on the log area and choose Filter by Item. Then choose Category and type in “User Profiles”. This will allow you to filter out only what you need at this point.

    Description: image

    Started the User Profile Synchronization Service

    Now you must restart your service with the new user profile synchronization service application that you just created.

    • Navigate to Central Admin again
    • Under System Settings, choose Manage Services on Server

    Description: image

    • Click on Start under User Profile Synchronization Service

    Description: image

    • Enter your system account’s password twice
    • Click OK

    Description: image

    • Now in the ULS Log Viewer you will notice the following, this is good, it is rebuilding the FIM configuration (formally called ILM, but SharePoint never updated the name)

    Description: image

    And if you did everything correctly then you should see everything running as it needs to be:

    Description: image

    Don’t forget to configure your MySite information in the new User Profile Service Application you created. You will need to re-run all of your profile synchronization.

    Let me know if this has helped you!


    Viral Shah http://sharepointshah.blogspot.com

    • Proposed as answer by Viral23 Monday, October 29, 2012 11:17 AM
    • Marked as answer by Pratik VyasModerator Thursday, June 20, 2013 6:34 AM
    Monday, October 29, 2012 11:17 AM
  • User Profile service is a weird feature in 2010. The "Struck ok Starting" is a very Common issue. The best option would be to dissociate the SA. Delete the connections. Delete the SA. Create a new SA with new app pool and new Database. Publish it. associte web apps. this should work.

    thanks

    Nez

    Monday, October 29, 2012 3:29 PM
  • SharePoint User Profile Synchronization Service AutoFixer

    It stops the Synch service.

    Cleans SharePoint Cache.

    Removes All Forefrontidentitymanager certificates.

    Removes profile sync timerjob.

    Starts The synch for you (You will need to input the farmadmin pwd).

    Works on SharePoint 2010/2013.

    Thursday, June 26, 2014 7:14 AM