none
MS Outlook Calendar - Don't Forward Option RRS feed

  • Question

  • Outlook Team,

    Can you please give us option in outlook for meeting invites, so that people can't forward the invite to anyone else.

    We normally face this scenario in our company, where people forward invite meant only for them. We have to write in invite "Not to forward" and "Contact Organiser if you want other person to be included".

    It will really help us a lot. Thank you.

    We use MS outlook 2007.

    Manav

    Friday, August 31, 2012 2:32 PM

Answers

  • Unfortunately, Outlook does not have the functionality to selectively disable forwarding of meeting requests. 

    Thus, we are unable to allow forwarding of some meeting requests, and prevent forwarding of other meeting requests.

    Writing the Note in meeting requests wih highlight would be a workaround. Thank you for your feedback.

    Tony Chen

    TechNet Community Support

    Monday, September 3, 2012 6:50 AM
    Moderator

All replies

  • Unfortunately, Outlook does not have the functionality to selectively disable forwarding of meeting requests. 

    Thus, we are unable to allow forwarding of some meeting requests, and prevent forwarding of other meeting requests.

    Writing the Note in meeting requests wih highlight would be a workaround. Thank you for your feedback.

    Tony Chen

    TechNet Community Support

    Monday, September 3, 2012 6:50 AM
    Moderator
  • Can we look forward in newer versions/releases to add an option in Outlook, to "allow/not allow" for meeting requests.

    Like we have option "Request Responses" or "Allow New Time Proposals", just look forward to add that option like them.

    Just want it to be considered while upgrading MS Outlook.

    Thank you.

    Manav

    Thursday, September 13, 2012 10:28 AM
  • Can we create transport rule like

    If Message type equal Calendar.Item and (Field FROM not equal Field SENDER)

    than reject message with extended code "Forward meeting not allow"

    else pass message.

    Our customer really need disable forward meeting request!!!


    Truly, Valery Tyurin

    Friday, September 20, 2013 5:40 PM
  • Your solution is AD-RMS. 

    http://technet.microsoft.com/en-us/library/cc771307(WS.10).aspx

    http://waysaroundit.co.uk/2011/09/using-exchange-transport-rules-to-prevent-recipients-from-replying-to-or-forwarding-a-message/


    A+ | Net+ | Security+ | Cisco CCNA | MCTS Server 2008 | MCTS Windows 7 | MCTS Exchange 2010 | Citrix CCA

    Friday, September 20, 2013 7:39 PM
  • Hello!

    It's very difficult solution for so simple task and need license.


    Truly, Valery Tyurin

    Saturday, September 21, 2013 4:39 AM
  • Sadly, your solution works only for messages not calendar meetings.
    MS Outlook users really need disable forward meeting request!!!

    JulesB

    Thursday, March 27, 2014 3:44 PM
  • There is a way to do this, the functionality does exist and is quite straightforward to implement.  No license required, no extra special difficult steps, just two lines of code.

    Here's some instructions I just put together:

    Part 1 – Enable coding

    1. Open Microsoft Outlook 2010
    2. Click File -> Options -> Customize Ribbon
    3. In the right pane, find the Home (Mail) tab.  Right click and choose “Add New Group” from the popup menu.

    1. In the left pane, click the arrow under  “Choose commands from” and select “Main Tabs” from the dropdown menu.
    2. In the left pane, expand the “Developer” item and then expand the “Code” item that appears below it.

    1. Select the “Visual Basic” item from the left pane and click the “Add>>” button between the two panes.  The “Visual Basic” item will be added below the New Group created in Step 3.
    2. Click OK.  The “Visual Basic” item will appear in the “Home” tab of the ribbon

    Part 2 – Write the Code

    1.  Click the newly created “Visual Basic” button, the Microsoft Visual Basic for Applications window will open.
    2. In the Microsoft Visual Basic for Applications window, click Insert -> Module.

    1. Copy the code in the file “Disable_Forwarding.txt” and paste it into the white window in the Microsoft Visual Basic for Applications window.  See the bottom of this post for the code.

    1. Click File -> Save, or click the save icon on the toolbar.
    2. In the Microsoft Visual Basic for Applications window, click Insert -> Module.
    3. Copy the code in the file “Enable_Forwarding.txt” and paste it into the white window in the Microsoft Visual Basic for Applications window.  See the bottom of this post for the code.
    4. Click File -> Save, or click the save icon on the toolbar.
    5. Close the Microsoft Visual Basic for Applications window and return to Outlook 2010.

    Part 3 – Create the buttons in Outlook

    1. Open Outlook Calendar
    2. Click on New Meeting
    3. Click File -> Options -> Customize Ribbon
    4. In the right pane, find the Home (Mail) tab.  Right click on the item “New Group (Custom)” and choose rename from the popup menu.

    1. In the “Display Name” window, type “Forwarding Control”.  Click OK.
    2. In the left pane, click the arrow under “Choose commands from” and select “Macros” from the dropdown menu.
    3. Select “Project1.EnableForwarding” and click the “Add>>” button between the panes.
    4. Select “Project1.DisableForwarding” and click the “Add>>” button between the panes.

    1. In the right pane, left click the item “Visual Basic”, then click the “<<Remove” button between the panes.
    2. In the right pane, right click the item “Project1.EnableForwarding” and choose “Rename” from the popup menu.
    3. In the “Display name:” window, type “Enable Forwarding”.  Select the symbol highlighted in the image below and click OK.

    1. In the right pane, right click the item “Project1.DisableForwarding” and choose “Rename” from the popup menu.
    2. In the “Display name:” window, type “Disable Forwarding”.  Select the symbol highlighted in the image below and click OK.

    1. Click and hold down the left mouse button and drag the “Forwarding (Custom)” item so that it sits below the “Actions” group item. Release the left mouse button.
    2. Click OK.  The newly created button will appear to the right of the “Actions” group on the “Meeting” tab in an Outlook calendar meeting request, and in an Outlook calendar appointment request.
    3. To use the buttons, create a new meeting, fill out the meeting details as normal and, at any time, click the “Disable Forwarding” button.  An alert will inform you that forwarding has been disabled for that meeting.  Next, send the meeting.  All recipients will not be able to forward the meeting request, even if they use the “Disable Forwarding” button on their own Outlook application.

    Code: 

    Sub DisableForwarding()
        ActiveInspector.CurrentItem.Actions("Forward").Enabled = False
        MsgBox "Forwarding of this item has been disabled"
    End Sub

    Sub EnableForwarding()
        ActiveInspector.CurrentItem.Actions("Forward").Enabled = True
        MsgBox "Forwarding of this item has been enabled"
    End Sub

    G


    • Edited by GranEYb Friday, September 19, 2014 5:41 AM
    • Proposed as answer by GranEYb Friday, September 19, 2014 5:41 AM
    Friday, September 19, 2014 5:39 AM
  • Hi there,

    I have tried the above and sucessfully disabled "Forward". How do we get around "Forward as Attachment"? I have tried adding this as an argument to the code but so far no joy?

    Many thanks!

    Sarah

    Tuesday, October 21, 2014 3:21 PM
  • That's sad :-(

    Thursday, December 4, 2014 6:15 PM
  • Hi GranEYb,

    I use Outlook 2013, and this worked like a charm.  Thanks ever so much for the instructions!  You have no idea how much this will help me everyday!

    Tuesday, March 10, 2015 8:54 PM
  • Thank you so much for the step by step.  It makes absolutely no sense that this is not a standard feature in Outlook/Exchange.  
    Monday, March 30, 2015 9:55 PM
  • Hi G,

    I am unable to complete step 3 below to create the button on new meetings. The issue being i can't locate the Home(Mail) tab. 

    1. Click on New Meeting
    2. Click File -> Options -> Customize Ribbon
    3. In the right pane, find the Home (Mail) tab.  Right click on the item “New Group (Custom)” and choose rename from the popup menu.

    My system is a Windows 7, MS Outlook 2010.

    Help!

    Thursday, July 30, 2015 5:27 AM
  • Writing the Note in meeting requests wih highlight would be a workaround. Thank you for your feedback.

    This really isn't a workaround, you can put in all the notes you want, but people will still forward the meeting invites. 


    Chris

    Monday, December 14, 2015 6:04 PM
  • I was successful following your instructions.   I've shared this with several of my colleagues, thank you so much!  The only issue is, the recipient can still forward the meeting scheduler as an "iCalendar" attachment, do you have a code for that too?

    Much appreciated!

    Kay

    Tuesday, February 9, 2016 5:47 PM
  • Hi.

    Did you every get a useful answer on this - I am having the same problem, cannot see the Home(Mail) tab from inside a meeting invite.

    Thank you!


    • Edited by Wills Allan Tuesday, March 22, 2016 10:35 AM
    Tuesday, March 22, 2016 10:35 AM
  • Hi

    I´m using Outlook 2013 and I tried to create the stuff.

    All worked so far but when I want to run the VBA script I´m getting an error 91, Object variable or With block variable not set

    Do you have a solution herefore or does anybody elses have this error?

    Thanks for answers :)

    Tuesday, April 12, 2016 6:46 AM
  • I had the same problem with error 91. I found a partial solution without using any code. The only problem is that people can forward as iCalendar. http://answers.microsoft.com/en-us/office/forum/office_2007-outlook/prevent-forwarding-with-the-meeting-invite/0e44967f-e51b-4352-aa15-5dd7b0e11105?auth=1 
    Monday, May 2, 2016 10:15 PM
  • This is very unfortunate since iOS devices seem to randomly forward meeting invites to large groups of people and this seems to be the only way to stop it (other than deleting email and calendar off the phone and using Outlook for iOS).  This is a major problem with some people receiving 10 invites a day for the same meeting.  I know it's mostly an iOS problem but our hands seem to be tied
    Monday, June 19, 2017 1:41 PM
  • Hi ... this doesn't work with Office 365.  I followed these instructions and it all seemed to be setup correctly.  I emailed a colleague with a Meeting Invite and set to Disable forwarding.  He got it and then forwarded to another colleague who did receive it .... am i missing something ? 
    Monday, October 2, 2017 6:02 PM