none
Managed Metadata Navigation not showing to users RRS feed

  • Question

  • I created a Managed Metadata service and created group, term-set and terms

    I gave full access to application pool service account. read access to all the users via AD Security Group.

    I set up navigation to use Managed Navigation (Managed Metadata Service).

    I am logged-in as farm admin and able to view the navigation when i browse site. But user are not seeing navigation.

    i went to the hidden taxonomy list and gave read access to all users. but this didn't help.

    One thing i noticed is when i give users full access or designer access to site they will be able to see the navigation. but i don't want to give all users full access or designer access to the site.

    Am i missing anything here? Please help!!!!

    Friday, November 8, 2013 2:29 PM

Answers

All replies

  • Hi prakasnh,
     
    According to your description, you have created a Managed Metadata service and created group, term-set and terms, but the users who have read access, were not seeing the navigation.
     
    How did you grant the read access to the users? By a group or directly?
     
    For resolving your issue, please add the users to the site Visitor group, and compare the result.
     
    Here is a similar post for you to take a look at:
     
    http://social.technet.microsoft.com/Forums/en-US/d2aa85e1-93e0-4e12-8389-28e13b11e877/managed-metadata-navigation-permissions-issue?forum=sharepointadminprevious
     
    I hope this helps.
     
    Thanks,
     
    Wendy

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Monday, November 11, 2013 2:04 PM
    Moderator
  • Hi Wendy,

    i tried by granting permission to site visitor group (in my case Hope Visitors) and also by granting driectly.

    As soon as i put them in Hope Owners or Designer, they are able to see the navigation. Looks like there is a permission issue. what else could it be?

    Please help.



    • Edited by Pasa_Light Monday, November 11, 2013 4:54 PM
    Monday, November 11, 2013 4:51 PM
  • Please make sure your simple link or header is selected for the terms.

    • Marked as answer by Pasa_Light Wednesday, November 13, 2013 3:22 PM
    Wednesday, November 13, 2013 3:21 PM
  • Care to elaborate on why?

    I have multiple site collections within a single Web Application.   The root site collection (at http://mydomain/ ) uses managed metadata for its navigation and is term driven. That cannot change.  The termset was created in CA and uses the Managed Metadata Proxy service.

    Users with Visitor (Read) access can see and use the navigation with no problem.

    On all my other Site Collections (All are set up under http://mydomain/Sites/) any Managed Metadata used will not show up for Visitors with Read access.  The only things that will show from it are Simple Link or Header terms used as base nodes (parent terms).

    As soon as you give users contribute or greater permission levels (the Add Item Permission is a minimum requirement it appears) then they can see term-driven pages used within the Managed metadata.

    Why is this?  I have come across no good reason.  It's frustrating and from what I can gather yet another bug with the SharePoint managed navigation feature.

    Friday, January 17, 2014 5:04 PM
  • Hi there,

    Hoping someone can assist me, I am experiencing a similar issue in Office 365 (SharePoint online). I have managed metadata driven navigation and users with read only access can not see the third level navigation items?

    I read through all previous posts and ensured these items are all using the Simple Header Link option which takes them to a search results page with the relevant keyword filters applied.. As others are experiencing the user when added to the members group are seeing all levels of the navigation fine.

    Eg.    Fruit

             Apples     Green

                            Red

             Berries     Raspberries

                            Blueberries

                            Strawberries

    In the example above the read users cannot see the third level in bold unless they are made contributors... please can you tell me where I am going wrong.

    Thanks in advance,

    Angela

    Monday, April 7, 2014 9:42 AM
  • Please make sure your simple link or header is selected for the terms.


    I confirmed this answer fixed the problem. However, is it a bug Microsoft going to fix?
    Friday, December 19, 2014 9:23 AM
  • If you use the Term-Driven Page with "Friendy" URL (MS's typo, not mine), there are a couple things that must also be in place for it to show on the navigation for Users with just visitors rights:

    • In the Term Driven Pages tab of the Term Store Manager, you must have a target page assigned. If you have 'Friendly URL' marked, but no target page, the navigation will filter it from users to prevent bad links.
    • Visitors (users with read only) must have read access to the target page you assigned. The easiest mistake to make is to assign it to a template page that has never been published. That also results in an access denied scenario that will hide the navigation from the user.

    If both of the above are done, it will show the navigation menu for read access users.


    • Proposed as answer by JohnMcCaffrey Friday, April 3, 2015 5:34 PM
    Tuesday, December 30, 2014 10:27 PM
  • I am also facing the same issue for read/visitors group users (3rd level is not visible) have you find the solution for it ?
    Friday, April 17, 2015 12:01 PM
  • We're also experiencing the same issue but it's the 2nd level that is creating issues for us (however, it's still affecting the read/visitor group). For us the nodes becomes visible again if the user get "manage lists" permissions on the site, but this is not a viable solution. It definitely sounds like a bug but it would be great if someone has a solution/workaround for it?
    Wednesday, October 14, 2015 7:45 AM