Running application as non-admin from network share block network communication. RRS feed

  • Question

  • Hi

    I have a program used by several users and it is placed on a network share so they can share the data in the folder.
    The application have to contact a Oracle Database sometimes. The application worked under Windows XP, but now we are migrating to Windows 7.

    When I run the application from the network share as a administrator everything is working perfectly.
    If I run the application as a user the application start and everything looks fine until the application have to contact the Oracle server - No connection to the server.
    If I copy the application to the local disk everything works perfectly for the user account.

    I have tried to do the same with Putty from a network share and it is the same problem when trying to connect to a host.

    - I have added the UNC to IE Intranet sites but it dosent help.
    - Firewall off dosent help
    - Uninstall AV dosent help
    - Adding the user account to local admin group dosent help
    - Disabled UAC dosent help.

    I hope someone can point me in the right direction...

    Wednesday, October 6, 2010 12:50 PM

All replies

  • Have you tried setting it on as "Always run as Administrator" ? by going into the advanced properties of the icon?
    Wednesday, October 6, 2010 3:00 PM
  • Thanks for your reply.

    The application works with 'Always run as Administrator' but the problem is the user is asked for admin account credentials.


    Thursday, October 7, 2010 9:32 AM
  • So if I can summarize this correctly, it would not work with local admin credentials but it would work with domain admin credentials. (since you tell me that the user is already a part of the local admin grp) It looks to me like there is an issue with permissions on the share that hosts the Oracle database. Can you check to see the security rights to ensure that the necessary users have read/modify access?
    Thursday, October 7, 2010 2:48 PM
  • Yes. The application can only connect to the Oracle Database Server when I use a account with domain admin credentials.

    When I connect with the application to the Oracle Database it is the same Oracle user credentials I use everytime.
    So permission to the Oracle Database should not be the problem.

    If I copy the application to the local disk and start the application with a standard user there is no problem connecting to the Oracle Database.

    Something is blocking network traffic when the application is started from a network share as a standard user. 
    I can create the same problem with another application (Putty).

    Thursday, October 7, 2010 8:24 PM
  • We have similar error. Oracle application is installed on a network drive and it can't be run from there.

    We try to trace connection, but error is that application doesn't try to access network.

    After some digging I found this answer: "This is actually a permission problem. Let me explain by an example:

    Lets say your dfs share is \\dc.domain.com\share1 and on your fileserver the physical location of the share is d:\root\share1.

    The group 'mygroup' should have access to share1 and you add "Full permissions" to the group on d:\root\share1. On d:\root you don't give it any access.

    In that scenario you will not be able to do any network communcation from the share. But if you give 'mygroup' the "List folder / read data" advanced permission on d:\root, the problem goes away. If you don't want users to be able to list the content of the d:\root folder, just enable "Access-based enumeration"."

    Friday, August 7, 2020 11:53 AM