none
Skype for Business issue RRS feed

  • Question

  • After installing Skype for Business Preview everything seemed to work perfectly. After restarting the PC again the new interface didn’t load again and the old Lync 2013 interface appeared but with the new skype icon and the new emoticons.

    How can I get the new interface back?

    • Edited by Marius Davițoiu Wednesday, March 18, 2015 10:16 AM Removed html from message
    Tuesday, March 17, 2015 10:19 AM

Answers


  • Two areas you should look at:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI
    EnableSkypeUI:REG_BINARY
    01 00 00 00 (True)
    or
    00 00 00 00 (False)

    If the backend Front-End Pool is Skype for Business, you can today execute in PowerShell to control the default Lync/Skype for Business client UI:

    Set-CsClientPolicy -EnableSkypeUI $true

    Thanks / rgds,


    TechNet/MSDN Forum Moderator - http://www.leedesmond.com

    Tuesday, March 17, 2015 2:12 PM
    Moderator

All replies


  • Two areas you should look at:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI
    EnableSkypeUI:REG_BINARY
    01 00 00 00 (True)
    or
    00 00 00 00 (False)

    If the backend Front-End Pool is Skype for Business, you can today execute in PowerShell to control the default Lync/Skype for Business client UI:

    Set-CsClientPolicy -EnableSkypeUI $true

    Thanks / rgds,


    TechNet/MSDN Forum Moderator - http://www.leedesmond.com

    Tuesday, March 17, 2015 2:12 PM
    Moderator
  • seems that this settings is reset to False after a restart of the Skype for Business client

    any ideas?

    Tuesday, March 17, 2015 4:52 PM
  • Hi Marius Davitoiu,

    Did you run the command that Desmond Lee suggested ?

    If you did not do that, please run the command and test again.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, March 18, 2015 3:12 AM
    Moderator
  • If it keeps on getting reset, means it is due to server end. I guess the Skype UI is disabled from server end or still not updated.

    Cheers,
    Chris.

    Wednesday, March 18, 2015 4:25 AM
  • the back end servers are Lync 2010, so EnableSkypeUI policy is not available

    I guess that the client detects it and adjust the registry accordingly to run the Lync UI

    Wednesday, March 18, 2015 8:28 AM
  • Hello,

    This worked, thank you very much.

    Have a nice day,

    Marius

    Wednesday, March 18, 2015 10:11 AM
  • Hello,

    Yes, I have modified the registry key and now it works.

    Regards,

    Marius

    Wednesday, March 18, 2015 10:13 AM
  • Hello Marius,

    when you stop Skype for Business then restart it (after a power on/off of your computer for example), did your Skype client start with the Skype UI?

    Thursday, March 19, 2015 2:43 PM
  • To CONFIRM - if the backend is Lync 2010 with the latest updates - the SKYPEUI will not toggle as per the policy.   Is that correct?

    The only way to put the SKYPE UI  back enabled is via the registry.  Is that the expectation?

    Thursday, April 9, 2015 3:09 PM
  • All of my FEs are up-to-date on Lync 2013 and they still revert even though EnableSkypeUI is set to True in every client policy. The registry key also reverts whether I delete it or set it to true.




    Wednesday, April 15, 2015 12:57 PM
  • Hi Chris,

    I have make it work permanently (skype for Business 2015) :) tested by restarting system :),

    Given below steps will help you to set Skype for bushiness even it's disabled by Admin or you are on Lync server 2013.

    1) Open registry --> HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI 

    change value from 0000  00 00 00 00 to 0000  00 00 00 10. 

    2) now go to HKEY_CURRENT_USER\Software\Microsoft\Office\Lync --> right click --> permission --> click on add --> deny "everyone" --> apply --> 

    Now restart your system and check.  steps are funny but this will work for everyone.

    please check and revert. 

    Regards

    Vasim Tamboli



    Monday, April 20, 2015 12:44 PM
  • Hi BrandonSHall,

    I have make it work permanently :) tested by restarting system :), given below steps will help you to set Skype for bushiness even it's disabled by Admin or you are on Lync server 2013.

    1) Open registry --> HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI 

    change value from 0000  00 00 00 00 to 0000  00 00 00 10. 

    2) now go to HKEY_CURRENT_USER\Software\Microsoft\Office\Lync --> right click --> permission --> click on add --> deny "everyone" --> apply --> 

    Now restart your system and check.  steps are funny but this will work for everyone.

    please check and revert. 

    Regards

    Vasim Tamboli



    Monday, April 20, 2015 12:45 PM
  • The Lync for Business is not by default disabled on Lync server 2013.

    Two areas you should look at:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI
    EnableSkypeUI:REG_BINARY
    00 00 00 01 (True)
    or
    00 00 00 00 (False)

    If the backend Front-End Pool is Skype for Business, you can today execute in PowerShell to control the default Lync/Skype for Business client UI:

    Set-CsClientPolicy -EnableSkypeUI $true

    you need to have installed the latest cu for Lync 2013 Server


    • Edited by jorgmsn Tuesday, April 21, 2015 1:03 PM
    Tuesday, April 21, 2015 1:01 PM
  • Change registry-setting:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

    to: "Lync"="reg add HKEY_CURRENT_USER\\Software\\Microsoft\\Office\\Lync /v EnableSkypeUI /t REG_BINARY /d \"01000000\" /f && \"C:\\Program Files (x86)\\Microsoft Office\\Office15\\lync.exe\" /fromrunkey"

    Makes sure the value is added each time before Lync/Skype starts.

    Wednesday, April 29, 2015 1:55 PM
  • Hello,

    hope you are enjoying Skype for business even if your Administrator blocked this option for you yet you can use Skype for Business. you need to follow given below steps

    1) Open registry --> HKEY_CURRENT_USER\Software\Microsoft\Office\Lync\EnableSkypeUI 

    change value from 0000  00 00 00 00 to 0000  00 00 00 10. 

    2) now go to HKEY_CURRENT_USER\Software\Microsoft\Office\Lync --> right click --> permission --> click on add --> deny "everyone" --> apply --> 

    you don't need to repeat these steps, just change reg rights option and Enjoy Skype for business.

    Thanks 

    Vasim Tamboli

    Wednesday, May 6, 2015 10:12 AM