none
2013 Excel Slow To Open Files When Double Clicked. RRS feed

  • Question

  • I am running O365 Office enterprise edition. I have a Pentium 7 computer with 32gb of Ram with SSD drives. I installed Windows 10 today and after the install it brought back an old problem that I had about a year ago. When I double click an Excel file on my local C drive or a network drive it takes anywhere from 45 seconds to 2 minutes to open the file. If I ope the same file from within Excel it opens instantly. I had this problem once before and found the fix online but for the life of me I can't remember what I did. I have already unistalled and reinstalled Office after the upgrade to Windows 10 with no luck. Any help would be appreciated.
    Thursday, July 30, 2015 9:32 PM

Answers

  • Hello Kelly,

    Thanks to Andrew at http://www.tenforums.com/members/andrew87.html, the problem appears to be Cortana Voice.

    Try the following which worked for me, but eliminates talking to Cortana:

    1. Disable Cortana Voice    
      Cortana/Settings/
      "Hey Cortana" switch to off
    2. Stop Cortana Service
      Open Task Manager
      Find and Right-Click Cortana Service
      End Task

    From here forward Excel should be back to normal even after Cortana restarts.  Some users have had similar issues with other voices services like Lenovo's so bear that in mind.

    Good Luck

    Wednesday, August 5, 2015 6:59 PM
  • Yep, I'm having the same problem too - Excel (and only Excel - other Office apps are fine) and Windows 10. Excel takes anywhere between 10-30s to open a small file when you double click it in Windows Explorer, but if you open Excel first and then use File>Open the file opens instantly.

    What I have found that is strange:

    1. In Windows Explorer select the View tab, and enable Preview Pane

    2. In Windows Explorer single-click on an xlsx file, and in a second or two the file will be previewed in the Preview Pane

    3. Now you can double-click any Excel file in Windows Explorer (or single-click shortcuts), and the file will open almost straight away!

    Unfortunately it's not a real solution because as soon as you close the Explorer window Excel goes back to opening files slowly. Suggests that the problem is maybe more of an Explorer problem than an Excel problem?

    Sunday, August 2, 2015 7:16 AM

All replies

  • Hi Kelly,

    Based on your description, did this issue only appear in Excel?

    First please open the Word file in safe mode, if it works fine try to disable add-ins in Word.

    Then go to File- Options- Advanced- check "Disable hardware graphics acceleration" option & Tick the option "Ignore other application that use Dynamic Data Exchange" 

    Please try this method first and check if it works for you.

    I'm glad to help and follow up your reply.

    Regards,

    Emi Zhang
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs. Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 31, 2015 8:33 AM
    Moderator
  • Thanks Emi I should have addressed this is my original post. This is only happening in Excel and I have disabled any add-ins. I have disabled graphics acceleration and also ticked the option "Ignore other applications that use Dynamic Data Exchange". All after trying all of this I still have the issue. I somehow think it must be tied to the registry because I fixed it once before and the problem did not return until I installed Windows 10, leading me to believe that something was changed back. I'm running an identical machine next to it that has never experienced this problem.
    Friday, July 31, 2015 2:18 PM
  • I have the exact same problem after installing Windows 10. Excel is very slow to open on Office 365 Home Edition. It was perfectly fine before the upgrade.
    • Edited by accote Saturday, August 1, 2015 11:41 PM
    Saturday, August 1, 2015 11:41 PM
  • Yep, I'm having the same problem too - Excel (and only Excel - other Office apps are fine) and Windows 10. Excel takes anywhere between 10-30s to open a small file when you double click it in Windows Explorer, but if you open Excel first and then use File>Open the file opens instantly.

    What I have found that is strange:

    1. In Windows Explorer select the View tab, and enable Preview Pane

    2. In Windows Explorer single-click on an xlsx file, and in a second or two the file will be previewed in the Preview Pane

    3. Now you can double-click any Excel file in Windows Explorer (or single-click shortcuts), and the file will open almost straight away!

    Unfortunately it's not a real solution because as soon as you close the Explorer window Excel goes back to opening files slowly. Suggests that the problem is maybe more of an Explorer problem than an Excel problem?

    Sunday, August 2, 2015 7:16 AM
  • Yes I tested the preview pane and if works exactly as you described. Not a fix but an interesting find.
     The other thing I find strange is I have updated 5 pc's and I'm only having this issue on 1.
    Sunday, August 2, 2015 7:24 PM
  • Hi RAB,

    Thanks for sharing the experience here!! It's a new discovery, and we will pay attention to this issue. Any updates we will let you know.

    We recommend users to install the latest updates of Windows 10 and upgrade to the latest version of Office.

    Regards,

    Emi Zhang
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs. Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 3, 2015 6:55 AM
    Moderator
  • I am encountering the same problem described with Access.  30-60 second delay.  Delays increase substantially when opening a second or third database concurrently.  This was not an issue on Windows 8.1.
    Monday, August 3, 2015 2:08 PM
  • Me too. Only started to happen once Windows 10 was installed
    Tuesday, August 4, 2015 12:24 AM
  • Same exact problem here. It happens when opening Excel, Access, and Project files from File Explorer. But opening Word, PowerPoint, Publisher, and Visio files is unaffected.

    In addition, launching ALL files from the OneDrive site (for instance, clicking "Edit in Microsoft Word") is ludicrously slow (takes about 30 seconds). It appears to be a related problem.

    This happened as soon as I upgraded to Windows 10.

    Also, it is appears to be a local issue. I created other accounts on the computer and files open in those accounts just fine.


    -C. Moya


    • Edited by CMOYA Tuesday, August 4, 2015 2:52 AM
    Tuesday, August 4, 2015 2:49 AM
  • Hello Kelly,

    Thanks to Andrew at http://www.tenforums.com/members/andrew87.html, the problem appears to be Cortana Voice.

    Try the following which worked for me, but eliminates talking to Cortana:

    1. Disable Cortana Voice    
      Cortana/Settings/
      "Hey Cortana" switch to off
    2. Stop Cortana Service
      Open Task Manager
      Find and Right-Click Cortana Service
      End Task

    From here forward Excel should be back to normal even after Cortana restarts.  Some users have had similar issues with other voices services like Lenovo's so bear that in mind.

    Good Luck

    Wednesday, August 5, 2015 6:59 PM
  • Hello Kelly,

    Thanks to Andrew at http://www.tenforums.com/members/andrew87.html, the problem appears to be Cortana Voice.

    Try the following which worked for me, but eliminates talking to Cortana:

    1. Disable Cortana Voice    
      Cortana/Settings/
      "Hey Cortana" switch to off
    2. Stop Cortana Service
      Open Task Manager
      Find and Right-Click Cortana Service
      End Task

    From here forward Excel should be back to normal even after Cortana restarts.  Some users have had similar issues with other voices services like Lenovo's so bear that in mind.

    Good Luck

    This is very interesting. This worked!... although I had to End the Cortana task a couple of times to see the effect. Excel, Access, and Project now load up instantly. Thank you!!!!

    Note to Microsoft Engineers: total shot in the dark, but I suspect this issue is caused by Cortana hogging up the ancient DDE cross-process channel for some reason (roots in Windows 3.0!) and which Excel inexplicably uses to load up files when launched from explorer rather than a simple cmd %1 shell command, like Word uses. I could be wrong. But it would explain why I often see "Waiting for DDE... to close" when restarting the computer. I dunno.

    P.S.

    Also, the issue is not entirely caused by "Hey Cortana." The second I enabled Cortana, period, on one of the accounts on my computer, the issue surfaced on that account. I didn't even complete the Cortana wizard (signing into Microsoft Account).


    -C. Moya


    • Edited by CMOYA Wednesday, August 5, 2015 7:53 PM More info
    Wednesday, August 5, 2015 7:50 PM
  • Unfortunately, after a reboot, the problem returned. :-( Even with "Hey Cortana" disabled. 1) It does seem to be Cortana related regardless and 2) DDE Server Window related IMHO. I hope the MS engineers monitor these forums. 

    [EDIT] I take it back. While the problem seemed to exist for the first 5 minutes after reboot, it went away. I have not tried reenabling "Hey Cortana." The above suspicions concerning DDE stands.


    -C. Moya


    • Edited by CMOYA Wednesday, August 5, 2015 11:11 PM
    Wednesday, August 5, 2015 8:56 PM
  • Hello Kelly,

    Thanks to Andrew at http://www.tenforums.com/members/andrew87.html, the problem appears to be Cortana Voice.

    Try the following which worked for me, but eliminates talking to Cortana:

    1. Disable Cortana Voice    
      Cortana/Settings/
      "Hey Cortana" switch to off
    2. Stop Cortana Service
      Open Task Manager
      Find and Right-Click Cortana Service
      End Task

    From here forward Excel should be back to normal even after Cortana restarts.  Some users have had similar issues with other voices services like Lenovo's so bear that in mind.

    Good Luck

    Awesome, this worked for me! Thank you so much, spent hours trying to figure this out. Did Office repair, changed every other setting possible and nothing worked.  

    Edit: It seems if I turn on "Hey Cortana", excel sheets take a while to open up when double clicking on an excel file. :(

    Once again, thank you!



    • Edited by Woozzy Thursday, August 6, 2015 1:21 AM
    Thursday, August 6, 2015 1:08 AM
  • Hello Kelly,

    Thanks to Andrew at http://www.tenforums.com/members/andrew87.html, the problem appears to be Cortana Voice.

    Try the following which worked for me, but eliminates talking to Cortana:

    1. Disable Cortana Voice    
      Cortana/Settings/
      "Hey Cortana" switch to off
    2. Stop Cortana Service
      Open Task Manager
      Find and Right-Click Cortana Service
      End Task

    From here forward Excel should be back to normal even after Cortana restarts.  Some users have had similar issues with other voices services like Lenovo's so bear that in mind.

    Good Luck

    Yes indeed - this worked for me!
    Thursday, August 6, 2015 5:47 PM
  • If you look further down you will see that disabling Cortana resolves the problem  Also explains why there was no problem in W 8.1. 

    I think MS need to get on top of this one (as well as Edge which is close to unusable).

    Saturday, August 8, 2015 5:45 PM
  • I'm sorry it has taken me so long to reply, my wife has been in the hospital. I did try this and it seems to have resolved my issue. After a reboot the issue seems to come back but I'm still tweaking it. Thanks for all the help.
    Monday, August 10, 2015 1:09 PM
  • Yes -- I've been annoyed by the exact same problem with Excel ever since upgrading to Windows 10 (also using Office 365 - Small Business). I've got all updates applied, tried turning off anti-virus, turning off graphics acceleration in Excel, etc. The one suggestion that immediately fixed this problem was turning off Cortana: now I can double-click an Excel filename and Excel will once again open immediately and load the file. Turn Cortana back on, and I'm back to a 10 to 20 second pause before Excel loads when I double-click a filename.

    A shame to have to turn Cortana off, but having efficient use of Excel is more important to me. Hoping a fix is found so I can turn Cortana back on without this problem resurfacing!

    - Jon

    Saturday, August 22, 2015 3:03 AM
  • bingo
    Thursday, August 27, 2015 7:19 AM
  • Disabling "Hey Cortana" fixed the Excel slow startup when opening files for me also. I had the problem on 3 different laptops after upgrading to Windows 10 and enabling Cortana (a Lenovo ThinkPad W520, a Sager laptop, and a Microsoft Surface Pro 3). I had wasted a few hours searching the Internet and trying various proposed fixes (editing registry keys, etc.). But disabling "Hey Cortana" was finally the solution that worked for me. Surprised that Microsoft hasn't fixed this issue yet.
    Sunday, August 30, 2015 4:36 PM
  • I have been on the phone with Windows and Office technical support for a couple of weeks about this. They have no resolution. They've had me uninstall/reinstall Office, disable virus programs and add-ins, etc. None of it has worked. I also just disabled "Hey Cortana" on my end and that does not help my situation. Files still take some 30 seconds to open if I double-click them vs. open from within Excel. The latest Microsoft support person is actually now trying to blame me, saying I have hardware issues (without validating it) and then tried to tell me it's normal now because Windows 10 was installed as an upgrade to Windows 8.1. Their reasoning was because of an upgrade vs. clean install I have less hard drive space so Excel takes longer to find the file. I hung up on them... This is only isolated to Excel - the rest of Office works normal as do other applications (i.e., Adobe suites, browsers, etc., etc.). It's very, very annoying this hasn't been resolved.
    Tuesday, September 8, 2015 6:45 PM
  • Well it is not hardware related.  Running a new DEll XPS and have this same issue, but it does not happen on a much older machine I have sitting next to it.  annoying it is.  

    I was not able to disable Cortana, I end the task and it just restarts on its own

    I do not believe it is excel, but rather something with windows explorer but beyond my ability to fix.  

    Monday, October 12, 2015 10:49 PM
  • There is no possible way this is a hardware problem, unless three different manufactures have the same fault. I have a Microsoft surface pro 3, and two hp laptops, cortana has never been enabled on either of these machines. This is a full almost year after these posts and this problem is still present. Microsoft your blatant disregard for this problem is appalling and Microsoft should be ashamed as a manufacture of both consumer and commercial software. I have previously tried every single solution int his form and still not fix to this problem. I believe it is an API issue in their program, I would be able to figure this out in a debugger but I have not the time nor the desire to fix Microsoft's shortcomings. 
    Tuesday, July 19, 2016 5:41 PM
  • And still this issue persists with new hardware, clean Win 10 CU x64 Pro, and Office 2016 (365 Business Premium)

    One of my customers is going nuts (as am I!)

    Will try killing Cortana processes.  Disabling "Hey bi*ch" doesn't work

    Wednesday, May 3, 2017 4:38 PM
  • RDP'd to users PC, and no Cortana process running.

    argh

    Wednesday, May 3, 2017 4:52 PM
  • I did have the issue. If your files are stored in cloud and if your are tying to open the file ... it takes years. First copy the file to your desktop and open it..It worked for me!

    The file was in onedrive, and it was not opening, or taking time to open. 

    When the location was changed to local folder.. it workrd

    Thursday, January 25, 2018 12:33 PM
  • Ok everyone, the solution to this problem is none of these, the Cortana fix helps in windows 10 but it also happens in Windows 7 and 8

    The problem is a broken DDE call environment, this happens due to multiple reasons, mostly programs you have installed, give up, you cant fix it.

    HOWEVER......

    I stumbled on a fix by accident, i've always hated the forced "if you want 2 documents open they need to be inside the same excel window", so long ago i came up with a fix to do this.. which aparently also fixed the broken loading problem.

    For those who care.. the problem is this:

    In the registry theres this entry:

    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\EXCEL.EXE\" /dde

    This command uses the windows DDE subsystem to send the file name to the excel client so it can open it when you double click it in windows explorer, this is done by sending the command via a DDE broadcast to all enabled EXE files running in your computer and waiting for all of them to acknowledge or timeout that they have something to say about it before finally sending it to Excel to be open, if a program has DDE enabled but is not properly coded for it (which happens way too much), what happens is windows waits for this program to respond or timeout, if there's more than one wrongly coded program, the timeout stacks, making it take up to minutes to fully time out, not sure why this behavior is this inefficient but what ever... 

    On to the fix, if you want to fix this AND at the same time get the ability to open multiple excel windows simply create a text file, paste this code in and save it as a .reg file, then execute it. it will solve your problem instantly.

    If your excel is a different version to this fix navigate to the proper registry key and change the appropriate location.

    I'm posting this because after hours of online searching i didn't find any real solution, and Microsoft clearly does not care enough to fix it so here you go guys, i hope you enjoy this fix as much as i do, opening 2 excel windows on a multi monitor setup is BASIC software functionality, not sure why we have to do these hacks to make it work, im glad it also fixes the DDE problem.

    if you like this fix up vote it so others can find it faster!

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    ; for other versions of excel change the location to wherever the excel.exe is at
    @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\EXCEL.EXE\" /e \"%1\""
    "command"=-
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec]
    @="[open(\"%1\")]"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec\application]
    @="Excel"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec\topic]
    @="system"
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command]
    ; for other versions of excel change the location to wherever the excel.exe is at
    @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\EXCEL.EXE\" /e \"%1\""
    "command"=-
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec]
    @="[open(\"%1\")]"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec\application]
    @="Excel"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec\topic]
    @="system"
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.5\shell\Open\command]
    ; for other versions of excel change the location to wherever the excel.exe is at
    @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\EXCEL.EXE\" /e \"%1\""
    "command"=-
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.5\shell\Open\ddeexec]
    @="[open(\"%1\")]"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.5\shell\Open\ddeexec\application]
    @="Excel"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.5\shell\Open\ddeexec\topic]
    @="system"
    



    • Proposed as answer by XionicFire Monday, March 5, 2018 4:46 AM
    • Edited by XionicFire Monday, March 5, 2018 4:47 AM spacing
    Monday, March 5, 2018 4:45 AM
  • Hi,

    it seems that it apparently works under Windows 8.1. My .reg file is different a bit: I have 32bit Office installed. It's a wise thing to export the original registry settings for the Excel.Sheet.12, Excel.Sheet.8 and Excel.Sheet.5. Then the original Excel path can be copied from the exported .reg file into the new one for replacing you have set in yours one.

    The problem is the same at the Word documents. Is it needed to do this registry changes for it also? 

    And the second question is that what about the Windows Explorer: When I open a folder or a file on a shared network drive the experience often the same.


    Thursday, March 21, 2019 2:52 PM
  • After having tried approximately 15 other solutions (deactivating WaveSound Service/Cortana, etc, etc.) this solution seems to work: Only had to select Excel as the application that open xlsx afterwards.

    Thanks!

    Saturday, June 27, 2020 9:02 AM