none
Hybrid configuration wizard single forest two domain trees RRS feed

  • Question

  • Hi all,

    as I have read there is only one hybrid per forest possible.

     I have  following  setup. One forest. Two domains in the forest each with separate exchange  servers. Each with different  email domain.

    So let say..

    Single forest : Two domains    A.com && B.com

    Two exchange servers   in each domain : with email a.com and b.com

    Each O365 Tennent has only  self  domain registered. So tenant A has only !.com registered and Tennent b has only B.com registered.

    On A.com was run full  Hybrid to  A.com Tennent.

    Now  B.com would like to setup tenant to B.com

    Is there any option to have  B.com ability to setup some extend of Hybrid ? Or what would be recommended steps. 

    Thank you,

    Stane

    Thursday, March 22, 2018 12:42 PM

All replies

  • Hi Stane,

    Yes, it's supported to sync A.com account to Tenent A, and sync B.com account to Tenent B. Figure as below:
    单个林的筛选拓扑

    However, we cannot deploy two hybrid instance on single one Exchange forest with two Office 365 tenant.

    If you want to achieve your goal, I suppose that we need to deploy hybrid environment with one Office 365, then remove it and build a new hybrid with other Office 365. Or, deployother migration method.

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, March 23, 2018 12:17 PM
    Moderator
  • Do you get the answer as you want?

    If so, please mark the helpful reply as answer. Thanks for your cooperation.


    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, March 28, 2018 2:43 AM
    Moderator
  • Any further help we can do for you?
    If it's solved, would you please post the solution here to share it with us? Thanks.
    Also, please free to mark the useful reply as answer. Thanks again. :)

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Borut2009 Monday, April 2, 2018 5:58 PM
    Monday, April 2, 2018 2:24 PM
    Moderator
  • One domain tree has Exchange 2013 installed and Hybrid configuration wizard has run.

    Second domain has Exchange 2010, no HCW was run

    Each domain or let say Exchange has different urls, mail domains etc.

    Ok  because it is same forest  its same organization.

    Each has different O365 subscription .

    Problem that I have is mail flow  for Exchange 2010.

    I crated a send connector on Exchange 2010  and mail is delivered to O365.

    If I crate outbound or partner connector  on O365  and define  Exchange 2010 to delivery smtp server,  get error if I send to  mail domain  that  is resisted on perm organization. Error  is generic “550 5.7.1 Client does not have permissions to send as this sender” I have try different combinations including partner including   that domains are not authoritative…  But it work if I send mail for example to Gmail.

    Temporary workaround is, that I set  in O365 as outbound connector to use  Exchange 2013 public SMTP access point. And then is mail routed internally.

    I know that Exchange 2010 in hybrid require internal relay domain. But I don wont to run HWC, because I will then  disrupt  Hybrid for Exchange 2013 organization. Is there any option to run only part related to mail flow ?

    Br,

    Stane

    Thursday, April 5, 2018 9:15 PM
  • Hi,

    I've found the same threads of yours, does it help?

    Thanks.


    Best Regards,
    Jason Chao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, April 6, 2018 3:18 AM
    Moderator
  • Well,

    not really.

    First post was related to  if there is possibility to create a hybrid and especially free/busy etc..

    Now I’m stuck with simple mail flow…

    I can not send ANY domain that  on perm is registered directly to Exchange 2010. Mail flow is blocked directly on MBX Office server. There is no connection from Office to on prem server.

    I can send to gmail or similar.

    The only way that is working is to set  send mail to  Exchange 2013, which is registered with second  tenant.

    I was hoping to make at list this work.

    This is generic error :

    EventId:FAIL

    Source:SMTP

    MessageSubject:Test-E-Mail f?r die Connector?berpr?fung

    MessageId:<38e3d20b-91cc-4772-ba43-4788eb5e6a50@VI1PR0401MB2301.eurprd04.prod.outlook.com>

    Recipients:test@Adomain.com

    RecipientCount:1

    RecipientStatus:[{LED=550 5.7.1 Client does not have permissions to send as this sender};{MSG=};{FQDN=smtp.Adomain.com};{IP=182.31.22.78};{LRT=4/4/2018 1:59:12 PM}]

    SourceContext:

    Sender:O365ConnectorValidation@Adomain.com

    EventData:E2ELatency:6.172, ExternalSendLatency:0.531, Microsoft.Exchange.Hygiene.TenantOutboundConnectorCustomData:Name=Outbound to OnPrem_Test_2018/04/04 14:36:57;ConnectorType=OnPremises;UseMxRecord=False, OutboundIpPool:1701, ToEntity:HybridOnPrem, FromEntity:Unknown, ToEntity:HybridOnPrem, FromEntity:Unknown, MsgRecipCount:1, IncludeInSla:True, OutboundProxyTargetIPAddress:182.31.22.78, OutboundProxyTargetHostName:smtp.Adomain.com, OutboundProxyFrontEndIPAddress:25.152.4.27:25, OutboundProxyFrontEndName:DB5EUR01FT037, OutboundTlsDetails:TLS=SP_PROT_TLS1_0_CLIENT TLSCipher=CALG_AES_256 TLSKeyLength=256 TLSKeyExAlg=CALG_ECDH_EPHEM, IsSmtpResponseFromExternalServer:True, DeliveryPriority:Normal, Oorg:Adomain.com, OriginalFromAddress:<>, AccountForest:EURPR04A004.prod.outlook.com

    I have try to set on domain as non authoritative  on perm and cloud,  chose partner , same error

    But it work in other direction, so I can send mail to cloud, through dedicated Exchange 2010 connector…

    REMEMBER : 

    It is block on mail server in O365 !

    Br,

    Stane

    Friday, April 6, 2018 7:32 AM