locked
Add-Ins and Store Greyed Out RRS feed

  • Question

  • Hello, 

    I am admin/MSP for two users that are having issues with getting add-ins to Outlook. The add-in store and MS store was previously unavailable in the ribbon at all, but now that I have added them to the ribbon they are greyed out and not clickable. Users are using the Office 365 personal yearly subscription on their machine and are connected to their companies Exchange Server.

    Anyone have any ideas?

    Friday, October 25, 2019 12:37 PM

Answers

  • For GPO, the policy is in this path: User Configuration > Policies > Administrative Templates > Microsoft Outlook 2016 > Outlook Options > Other

    >> Tested with another user account and it is also greyed out.

    Do you mean this issue happen to specific Outlook desktop client or specific users?

    If other users without problems logs on this client, will same issue occur? This could help check whether this issue lies on client side or server side.

    If it occurs to specific client, we can try opening Outlook in safe mode to see if the issue continues. Please exit Outlook, press Win key + R to open the Run command, type outlook /safe and then press Enter. This helps eliminate whether the problem lies on any third party add-ins.

    Besides, I found this similar thread which mentions to make sure “User owned Apps and Services” is enabled.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by AnnieDs Monday, November 4, 2019 6:32 AM
    • Marked as answer by Edward van BiljonMVP Tuesday, November 12, 2019 6:04 PM
    Tuesday, October 29, 2019 5:52 AM
  • Hi

    As a test, have you tried uninstalling office completely on a machine and logging into the office 365 portal and re-installing it?

    Any GPO in place to prevent store from working?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, October 25, 2019 6:22 PM

All replies

  • Hi

    As a test, have you tried uninstalling office completely on a machine and logging into the office 365 portal and re-installing it?

    Any GPO in place to prevent store from working?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, October 25, 2019 6:22 PM
  • Does this only happen to Office 365 accounts? How about trying to test with another Exchange account like an outlook.com account on problematic client and check the result?

    What’s the detailed version of Office? Please install available updates to see if it helps.

    Besides, check if you’ve set any permissions or GPO polices to disable Store option. For example, storeButtonInRibbonHomeTabAllowed registry key.

    On Office 365 client, you should see it as “Get Add-ins”. Do you see this option?

    If you are using Office 365, I'd like to recommend you try SARA tools to run tests to resolve many different problems.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Edited by Perry-Pan Monday, October 28, 2019 6:02 AM
    Monday, October 28, 2019 6:02 AM
  • I have not tried uninstalling and reinstalling. There are two different users/machines/installs having the same issue. Where in GPO would I find something like this? I looked and didn't see anything related to the store. Thanks for the response.
    Monday, October 28, 2019 8:40 PM
  • Version 1909 (Build 12026.20344 Click-to-run) 

    Do not have the add-in option. It is greyed out.

    Tested with another user account and it is also greyed out.

    Monday, October 28, 2019 11:01 PM
  • This is what it looks like when I add it to the ribbon

    Monday, October 28, 2019 11:11 PM
  • For GPO, the policy is in this path: User Configuration > Policies > Administrative Templates > Microsoft Outlook 2016 > Outlook Options > Other

    >> Tested with another user account and it is also greyed out.

    Do you mean this issue happen to specific Outlook desktop client or specific users?

    If other users without problems logs on this client, will same issue occur? This could help check whether this issue lies on client side or server side.

    If it occurs to specific client, we can try opening Outlook in safe mode to see if the issue continues. Please exit Outlook, press Win key + R to open the Run command, type outlook /safe and then press Enter. This helps eliminate whether the problem lies on any third party add-ins.

    Besides, I found this similar thread which mentions to make sure “User owned Apps and Services” is enabled.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by AnnieDs Monday, November 4, 2019 6:32 AM
    • Marked as answer by Edward van BiljonMVP Tuesday, November 12, 2019 6:04 PM
    Tuesday, October 29, 2019 5:52 AM
  • Neither users had a GPO for Office section. What I am noticing is that the account they are both using to download office suite in portal.office.com is not the same email that they are signed into Outlook desktop app with. 

    They download and pay for office on their own, and then sign in with a work email. I think this is why they are not showing the add-in when I am trying to install.

    Besides that, the options are still greyed out in their desktop app with their work email. The add-in options should be showing up in the app regardless, correct?

    There are no settings or group policy that states the Office Store cant be used so I am still confused as to why the add-in button isn't clickable in the desktop app while they are signed in with work email.


    Tuesday, October 29, 2019 1:31 PM
  • Do you mean this issue happen to specific Outlook desktop client or specific users?

    If other users without problems logs on this client, will same issue occur? This could help check whether this issue lies on client side or user side.

    Do they sign in Office with the Office 365 account?

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Edited by Perry-Pan Wednesday, October 30, 2019 5:37 AM
    Wednesday, October 30, 2019 5:36 AM
  • Have you found a fix for this issue? Any updates?

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, November 1, 2019 5:57 AM
  • Issue is happening to another user with a different Windows 10 device and different Microsoft account. Both users have purchased the O365 Personal yearly subscription and have downloaded their product from the O365 portal. 

    They are both signed in with their work emails and connected to 2010 Exchange server on their personal subscription. 

    I have been unable to get any suitable support from Microsoft on this. They pointed me back to the Microsoft forums after going round and round with them.

    Monday, November 4, 2019 4:23 PM
  • Have not found a fix for this issue.
    Monday, November 4, 2019 4:23 PM
  • >>They are both signed in with their work emails and connected to 2010 Exchange server on their personal subscription. 

    What if we try signing in with the O365 account? Will this option be available?


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, November 7, 2019 1:34 AM