none
XLS file will not open in Excel 2016, only gray view

    Question

  • Hi, I downloaded a XLS (not XLSX) file from an internet application.  I have Excel 2016 and am on Windows 7.  If I open the file in notepad, I see that it has HTML tags/content.  however, when I double click on the file, it opens up the Excel app but there is no worksheet...just a gray background, no visual error.

    I've looked online and i've exhausted most of the known options, short of reinstalling Excel or manually changing the registry settings.

    I've done the following already:
    - Unchecked "Ignore other applications that use Dynamic Data Exchange (DDE) check box"
    - I've associated all files types to Excel in Control Panel
    - I've run the repair (both quick and online) function in Control Panel
    - I can't disable the following option because of security concerns: Excel > File > Options > Trust Center > Trust Center Settings > Protected View > “Enable Protected View for files originating from the Internet”.  If I did disable this, the file will open after I okay the warning message.
    - Checked "Disable hardware graphics acceleration" in Excel > Advanced
    - Opened the file from within Excel but same blank result.

    I have some colleagues who are on Excel 2013 that are able to open the file without issue, but some others could not either.

    Any ideas of where else to look?

    thanks,
    mike







    • Edited by MK5339 Tuesday, July 26, 2016 3:17 PM
    Tuesday, July 26, 2016 3:12 PM

Answers

  • The Excel team has made a change in the behavior of certain file types to increase security. This change came in the security updates KB3115262, KB3170008, and KB3115322. Previously, when you tried to open an HTML or XLA file with an .XLS file extension from an untrusted location, Excel would warn about the mismatch between the file extension and content, but would still open the workbook without Protected View security. After the security updates Excel no longer will open the workbook because these files are not compatible with Protected View and there is no warning or other indication it was not opened. We apologize that Excel is showing a blank screen instead of a more helpful error message with information about what to do next.

    We have a few options for workarounds. These are in order from safest to riskiest. While some people in the forums have suggested rolling back the security patch, we do not recommend that option as it can leave you open to other current and future threats.

    1. The best option is to move away from using HTML wrapped as .xls. If you use native formats (e.g. xls, xlsx, xlsb) which will open in protected view when untrusted, this will provide some level of protection from the documents being opened.
    2. You can unblock access for individual files you know are safe. To do this:
      1. Right click on the file and choose Properties
      2. On the General tab, click Unblock
      3. Click OK
    3. You can make use of existing Trusted Locations capabilities in Excel 2010, 2013, and 2016 via File -> options -> Trust Center -> Trust Center Settings -> Trusted Locations.
      1. You can save the web html file to a trusted location on the local machine (Excel comes with a set of default trust locations). If you do not see the local folder location you trust for these files, then press “Add new location…” button and add it in the Trusted Location dialog. If the HTML document is in a trusted location the KB fix is not applied (e.g. the unsafe HTML file is not blocked).
      2. This approach may unblock you, but it carries some risk as files of any file type in Trusted Locations are fully trusted. If an attacker can drop files into the trusted location they can easily exploit users who open such documents. Be especially cautious when specifying a custom folder as a trusted location.

    We are also investigating a more permanent solution that allows our users to remain secure as well as minimize disruption to existing user experience. We’ll provide updates on this in the coming days. Thank you for your patience.

    Freya

    Office Newsroom

    • Proposed as answer by Freya [MSFT] Tuesday, July 26, 2016 5:19 PM
    • Marked as answer by MK5339 Tuesday, July 26, 2016 9:49 PM
    Tuesday, July 26, 2016 5:19 PM
  • Update: Our dev team is working on options to preserve security and assist customers with their workflow. Currently we do not have any further workarounds.

     

    Additional background: The security update changed how Excel handles documents that are opened from untrusted locations (such the Internet zone) which are not supported in Protected View, such as HTML/XML/XLA files. Opening them without Protected View is a security vulnerability, and therefore files open from such locations are now blocked.  We realize this breaks compatibility with some existing solutions, and are working on getting these file types supported with Protected View.  Until that happens, users will need to manually trust the file before they open them in Excel, as demonstrated in one of the workaround suggestions.  Excel can still open these files without an issue if they are trusted. 

     

    We strongly recommend against removing the security update. It will leave your systems vulnerable. More information is located here: https://technet.microsoft.com/library/security/MS16-088?f=255&MSPPError=-2147217396. Specifically, the section regarding "Microsoft Office Security Feature Bypass Vulnerability – CVE-2016-3279".

     

    Additional information on implementing workaround options, by product version:

    Office 2016

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.16).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.16).aspx

     

    Office 2013

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.15).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.15).aspx

     

    Office 2010

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.14).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.14).aspx

     

    Freya

    Office Newsroom

    Thursday, July 28, 2016 8:42 PM

All replies

  • I am experiencing a very similar situation, except with mine, I can open the file from the local disk (Excel 2013) and I get a warning saying something along the lines of it being the wrong format or corrupt, but if I hit Ok, the file opens fine. (It is also an .xls with html in it generated by an as400). 

    The difference with mine is, when I try to open it directly from a network share, that is when I get the blank gray Excel application where no buttons are usable and there is no table or anything.

    For one user, this  has just started about a week and a half ago, the other user, it just happened today and was fine yesterday. Perhaps this could be a Windows or Ofiice update issue?

    Tuesday, July 26, 2016 4:03 PM
  • KillMeNext - Maybe you have a Trust Location setting on your local disk's Excel, whereas the network share's Excel does not?  I did muck around by adding a local trust location and I also got that warning message, but I don't want that option to appear.  But I do agree that something appears to have changed within the past couple of weeks, as this issue did not happen prior.
    Tuesday, July 26, 2016 4:53 PM
  • The Excel team has made a change in the behavior of certain file types to increase security. This change came in the security updates KB3115262, KB3170008, and KB3115322. Previously, when you tried to open an HTML or XLA file with an .XLS file extension from an untrusted location, Excel would warn about the mismatch between the file extension and content, but would still open the workbook without Protected View security. After the security updates Excel no longer will open the workbook because these files are not compatible with Protected View and there is no warning or other indication it was not opened. We apologize that Excel is showing a blank screen instead of a more helpful error message with information about what to do next.

    We have a few options for workarounds. These are in order from safest to riskiest. While some people in the forums have suggested rolling back the security patch, we do not recommend that option as it can leave you open to other current and future threats.

    1. The best option is to move away from using HTML wrapped as .xls. If you use native formats (e.g. xls, xlsx, xlsb) which will open in protected view when untrusted, this will provide some level of protection from the documents being opened.
    2. You can unblock access for individual files you know are safe. To do this:
      1. Right click on the file and choose Properties
      2. On the General tab, click Unblock
      3. Click OK
    3. You can make use of existing Trusted Locations capabilities in Excel 2010, 2013, and 2016 via File -> options -> Trust Center -> Trust Center Settings -> Trusted Locations.
      1. You can save the web html file to a trusted location on the local machine (Excel comes with a set of default trust locations). If you do not see the local folder location you trust for these files, then press “Add new location…” button and add it in the Trusted Location dialog. If the HTML document is in a trusted location the KB fix is not applied (e.g. the unsafe HTML file is not blocked).
      2. This approach may unblock you, but it carries some risk as files of any file type in Trusted Locations are fully trusted. If an attacker can drop files into the trusted location they can easily exploit users who open such documents. Be especially cautious when specifying a custom folder as a trusted location.

    We are also investigating a more permanent solution that allows our users to remain secure as well as minimize disruption to existing user experience. We’ll provide updates on this in the coming days. Thank you for your patience.

    Freya

    Office Newsroom

    • Proposed as answer by Freya [MSFT] Tuesday, July 26, 2016 5:19 PM
    • Marked as answer by MK5339 Tuesday, July 26, 2016 9:49 PM
    Tuesday, July 26, 2016 5:19 PM
  • Thank you for the above information, unfortunately none of those workarounds has worked for me. A few of them I had tried already from other threads I saw before. Here are the issues with the ones you mentioned.

    The path I am trying to open from is a network share, if I right click on the file to try and unblock it, that option is not available for any of the files. 

    I can not seem to add the network path as a trusted location, even when I turn on "allow trusted network locations", it gives an error message of "the path you have entered cannot be used as a trusted location for security reasons. choose another location or a specific folder." I have tried both a mapped network drive, as well as the direct UNC path. 

    The files are auto generated by our AS400's VAI ERP software which includes the HTML and will not be able to be changed either, and due to the nature of the documents, they are to remain on the network share for security purposes of the information contained in them.

    Unfortunately it seems that our only option would be to uninstall these updates in order to correct the behavior we are experiencing. 




    • Edited by KillMeNext Tuesday, July 26, 2016 5:52 PM
    Tuesday, July 26, 2016 5:45 PM
  • I had this issue with trying to open a .xls file that was saved on my laptop hard drive.  Solution number 2 (opening the properties and checking the unblock box) allowed Excel 2016 to open the file. 

    I had been searching for hours trying to figure out why Excel 2016 would not open a file that I used a few weeks ago.  My system must have been altered by a recent automatic security update.  Microsoft needs to do a better job of getting information about this type of a bug in their program out to the public.

    I am glad to have a solution to allow me to open .xls files saved on my hard drive, however, I am annoyed that it took so long to find a work around.

    Michael

    Thursday, July 28, 2016 2:47 AM
  • Update: Our dev team is working on options to preserve security and assist customers with their workflow. Currently we do not have any further workarounds.

     

    Additional background: The security update changed how Excel handles documents that are opened from untrusted locations (such the Internet zone) which are not supported in Protected View, such as HTML/XML/XLA files. Opening them without Protected View is a security vulnerability, and therefore files open from such locations are now blocked.  We realize this breaks compatibility with some existing solutions, and are working on getting these file types supported with Protected View.  Until that happens, users will need to manually trust the file before they open them in Excel, as demonstrated in one of the workaround suggestions.  Excel can still open these files without an issue if they are trusted. 

     

    We strongly recommend against removing the security update. It will leave your systems vulnerable. More information is located here: https://technet.microsoft.com/library/security/MS16-088?f=255&MSPPError=-2147217396. Specifically, the section regarding "Microsoft Office Security Feature Bypass Vulnerability – CVE-2016-3279".

     

    Additional information on implementing workaround options, by product version:

    Office 2016

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.16).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.16).aspx

     

    Office 2013

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.15).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.15).aspx

     

    Office 2010

    Here is information on Office Trusted Locations

    https://technet.microsoft.com/en-us/library/cc179039(v=office.14).aspx

    and information on Protected View settings

    https://technet.microsoft.com/en-us/library/ee857087(v=office.14).aspx

     

    Freya

    Office Newsroom

    Thursday, July 28, 2016 8:42 PM
  • Thanks for the help of this problem in Excel, Freya.

    :)


    Regards,

    Emi Zhang
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, July 31, 2016 2:13 PM
    Moderator
  • You could probably go to File>Options>Trust Center>Trust Center Settings>Protected View Menu and then uncheck the box "Enable Protected view for files originating from the internet". This has worked on most of the machines that I have come across on our network.

    This can be changed in Group Policy via the Microsoft Office 2016 (2013 or 2010 as well) ADMX

    https://www.microsoft.com/en-us/download/details.aspx?id=49030  (2016)

    https://www.microsoft.com/en-us/download/details.aspx?id=35554  (2013)

    https://www.microsoft.com/en-us/download/details.aspx?id=18968  (2010)

    Hope that this helps. On my test box I have implemented the change via local policy through these ADMX policies. They can be applied at a global level.

    Tuesday, August 2, 2016 3:44 PM
  • The Excel team has released a change in HTML/XLS file behavior in today’s security update for Excel 2010, 2013, and 2016. Excel will warn about the mismatch between the file extension and HTML content, but will now open the workbook in Protected View as an additional layer of security. If you trust the workbook, you can then enable editing. XLA and XLAM files are not part of this change, they will continue to not open in Excel.

    How do I get the update? It depends on which version of Office you have.

    Issue recap:

    The Excel team has made a change in the behavior of certain file types to increase security. This change came in the security updates KB3115262, KB3170008, and KB3115322. Previously, when you tried to open an HTML, XLA, or XLAM file with an .XLS file extension from an untrusted location, Excel would warn about the mismatch between the file extension and content, but would still open the workbook without Protected View security. After the security updates Excel no longer will open the workbook because these files are not compatible with Protected View and there is no warning or other indication it was not opened.

    Workarounds for .xla and .xlam files: https://support.microsoft.com/kb/3181507

    Thank you for your patience and input—community suggestions drove our decision to change this behavior in a way we hope will be much better for your workflows!

    • Proposed as answer by Freya [MSFT] Tuesday, August 9, 2016 5:23 PM
    Tuesday, August 9, 2016 5:23 PM
  • We cannot always trust files so its better to first convert them to actual excel format and then open them. We will also not have security issues once they are converted to excel format

    There is an open source code to convert HTML Wrapped file to Excel (xls 2003 format). You can install that and embed that service and improve on it if required as its opensource.

    https://github.com/ashwinrayaprolu1984/htmlwrapexcelconverter.

    Wednesday, August 10, 2016 4:33 PM
  • After applying this update, Excel now asks to open the file (as it used to), but then says that the file is corrupt, and cannot be opened.

    If i download, save and open it then, everything works normally.

    So we got the prompt back, but not a fix...

    Tuesday, August 23, 2016 9:48 AM
  • Frena:

    This is quite frustrating that you release this new update without any advanced warning to users on how to prepare for the change to avoid these problems. Converting to windows 10 was a challenge, but at least I was told when it was going to happen automatically, and what was the process for me to transition seamlessly if I transitioned before then. I did so and had no problems.

    I would think that programs could be saved as a different file format to prevent this problem when you ran your update- ie I have an .xls file that "went grey" and I can't open. I would think that I could have saved it as a new acceptable format and not lost the file. The rest of my files appear to be okay...for now. Several I checked are .xlsn. Is this format okay going forward, if not what should I save it as?

    I need to know what files need to be converted, by "save as", assuming that this is possible. Is it just .xls, or are there others? If I know this, I can review my files, saving each of the "obsolete" ones in an acceptable file format, and only have one file lost. (I am on Office 2016, Excel 2016). I also need to know the acceptable format to save them as.

    These are very important files for me. I wrote some many years ago, and continue to modify them. They cover my retirement plan, expense budget and investment portfolio. The file I lost is my investment portfolio. It will take 4-6 hours to recreate, but at least is the easiest of the 3. Problems with either of the other 2 would be disastrous. 

    Jeff

    Thursday, April 6, 2017 8:17 PM
  • Freya:

    Relative to your response 7 26 16, recommending a few approaches, I'm sure I'm migrating away from using files, as 90% of my files are of more current (workable format)- your point number 1.

    Relative to point number 2, to unblock individual files. I right click, go to properties. In the general screen, there is no "unblock" capability listed. There also is none in "advanced" or other settings.

    Do you have any advice?

    I have older copies of these files from when I backup my computer, with the files saved individually (not through the backup feature) on a separate hard drive. I believe these files were saved before your excel version that caused the problem. Could I do something to those files in the opening process that would allow me to open/save them in a new , acceptable format?

    Thanks,

    Jeff 

    Friday, April 7, 2017 2:25 PM
  • its 6/3/2017, this was not a problem till today for me - suddenly  xls file exported data from Amazon that helps me run  my business does not work. This is  a huge pain. The explanations to fix are cryptic / do not work  when I unblock file. Net I am super frustrated and unhappy with the UX - frankly pretty pissed off. I have work to do and I am dead in the water  do to this - not a happy camper...

    Can someone help me fix this ? I am using Excel 2016 on surface device  


    • Edited by Frankxr Saturday, June 3, 2017 11:32 PM
    • Proposed as answer by Conboy32 Wednesday, March 21, 2018 2:30 PM
    • Unproposed as answer by Conboy32 Wednesday, March 21, 2018 2:30 PM
    Saturday, June 3, 2017 11:32 PM
  • I had this vexing problem yesterday - driving me crazy because I'm trying to get a report out.  I found a very simple fix - open the file from Excel, not windows.  Open excel, and select the file from the browse menu, and it opens fine for me.  If I select from Windows and open it to start excel, it opens completely gray with no tabs - only some spreadsheets though...  

    So try opening it from excel and see if that fixes it.  I know I'm a year late on this but I just ran into this problem yesterday.  Between this and not being able to cut and paste .pdf data into certain spreadsheets so I can type the data in manually without printing a hardcopy of the handwritten data .pdf, it has been a rough week with Excel 2016.

    hope this helps the next poor lost user who opens up a completely gray spreadsheet with no tabs!



    • Edited by Conboy32 Wednesday, March 21, 2018 2:36 PM
    • Proposed as answer by Conboy32 Wednesday, March 21, 2018 2:36 PM
    Wednesday, March 21, 2018 2:35 PM
  • CREATIVE WORKAROUND.

    This same grey screen problem effected me yesterday while opening a workbook that I use near daily. I even emailed the XLS to some coworkers and Ironically we could preview it in Outlook but could not open in in Excel 2016. apperntly we all got the security update at the same time. I then tried a different machine with office 2013 - same problem

    My workaround, I opened it in Google Sheets then downloaded from there in xls format and named it V2. all is now 100%

    Ironic that I have to circumvent security and use Google, in oreder to use a Microsoft product secured by a Microsoft update...

    Hope this helps

    Tony


    • Edited by TonyFal Tuesday, April 24, 2018 1:01 PM
    Tuesday, April 24, 2018 12:59 PM