none
Outlook 2010 attachment size limit RRS feed

  • Question

  • We're using a sendmail server for our email and have been using Outlook 2003 for the client.  I'm evaluating Outlook 2010 but we've hit a snag.  Total attachments over ~20MB result in a "The attachment size exceeds the allowable limit".  This works fine under 2003.

     

    How can I fix this?



    Wednesday, May 26, 2010 5:22 PM

Answers

  • I was able to effectively remove the limit by editing the registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences]

    and adding a new DWORD value:

    MaximumAttachmentSize

    and setting its value to 0

    That appears to have the effect of making the the size of attachments you select limitless.  Any other value, as far as I can tell, sets the size in Kbytes.

    • Proposed as answer by PocketSidewalk Tuesday, June 8, 2010 7:05 PM
    • Marked as answer by Sally Tang Wednesday, June 9, 2010 8:44 AM
    Tuesday, June 8, 2010 4:25 PM

All replies

  • Hi,

     

    First, please let us know the email server you are using. Is it Exchange and what’s the version? Also, does this issue occur on all the client computers or only one some of the computers?

     

    As this issue might be related to some settings on the Exchange server side, you may also contact your network administrator to check the settings on the server side.

     

    If there are no attachment limitation settings on the server side, we can troubleshoot the issue by the steps below:

     

    Step 1: Disable background transfer of attachments to the Exchange server.
    =============
    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

     

    1. Run regedit on the outlook client computer that has the issue.
    2. Locate the following registry key:
    [HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook]
    3. On the Edit menu, click Add Value, and then add the following registry value:

    Value name: DisableBGSave
    Data type: REG_DWORD
    Radix: Hexadecimal
    Value data: 1

    Note: You will see the Policies key if policies are deployed in your environment. If so, add the registry key under the following registry key:
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook]

    4. Restart Outlook and test the issue again. Is the issue resolved? If the problem persists, let’s continue.

    Step 2: Start Outlook in online mode/safe mode.
    =============
    1. In Outlook, click File > Info > Account settings > Account settings.

    2. Click your Exchange account, and click the Change button, then More settings, Advanced tab. Uncheck Use cached Exchange mode.
    3. Exit Outlook . Click Start, point to All Programs, and then point to Microsoft Office.

    4. Press and hold the CTRL key, and then click Microsoft Outlook.

     

    Is the problem resolved? If not, let’s continue.


    Step 3: Create a new Outlook profile.
    =============
    1.    Exit Outlook.

    2.    Go to Start > Control Panel, click or double-click Mail.

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

     

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

     

    Note    The Mail icon appears after Outlook starts for the first time.

     

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

     

    3.    Click Show Profiles. Choose Prompt for a profile to be used.

    4.    Click Add.

    5.    Type a name for the profile, and then click OK.

    6.    Start Outlook, and choose this new profile.

     

    If this problem does not occur in the new Outlook profile, the old Outlook is corrupted. We can delete that and use a new Outlook profile.


    Step 4: If it still not resolved, create a new Outlook profile on another PC that does not have this issue, then check to see if it persists. This can help us to narrow down that if the issue is specific to the machines.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    Thursday, May 27, 2010 6:51 AM
  • The server we're using (currently) is Red Hat Linux (sendmail v8.13.8).  The client is Windows 7 x64.  Outlook is Office Pro x64 2010.  This is our 1st Win7/Office 2010 box - we're using it to test for problems prior to any migration.

    This is a AD 2003 environment w/roaming profiles/redirection.

    Our base is using Win XP w/Office 2003 (x86).  These systems access the same server for email and don't have the attachment size problem.

    There are no limits set on the server (POP).

    All PCs are fully patched.

    Steps 1 & 2 above didn't apply.    Step 3 gave the same results.

     

    I will install Office 2010 on a XP system to see if the problem is 2010 specific and I'll post the results here.
    Thursday, May 27, 2010 5:25 PM
  • Outlook 2010 now checks for file size limitations and rejects before sending. I have no idea why its not working for you though.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, May 27, 2010 6:09 PM
  • Additional data:

    I installed Office 2010 Pro + x86 onto a virtual XP Pro system (fully patched).  With a different user I composed an email and tried to add 2 attachments (total size ~22MB).

     

    Got the same result - "The attachment size exceeds the allowable limit".

    :(

     

    It appears the problem is with Outlook 2010.


    Thursday, May 27, 2010 7:08 PM
  • One thing try might be changing the server timeout option.  In the email account settings click change and then on the server settings page click More settings.  You may see that the server connection timeout setting is set to like 30 seconds.  Which is normally fine for most things but with very large attachments like this you might need more time.
    Friday, May 28, 2010 5:40 PM
  • Hi,

     

    Try to log on the computer with a different user account with the administrator rights, and check the issue again.

     

    Can you sent the attachment properly?

     

    Best Regards,

     

    Sally Tang

     

     

    Tuesday, June 1, 2010 7:39 AM
  • It was set to 1 minute so I changed it to 2.  I still get the message.  I don't think this  is server related as I get the message when I attempt to attach the files, not when I try to send the email.
    Tuesday, June 1, 2010 4:05 PM
  • No, same message.

     

    Additional notes:

    The Win 7 box is running ESET AV.  The XP VM is not running any AV.  This leads me to believe AV is not a cause.
    Tuesday, June 1, 2010 4:17 PM
  • Anyone? 

     

    Bueller?  Bueller?

    Thursday, June 3, 2010 9:49 PM
  • I'm having this same problem. It just started when I upgraded to Office 2010.

     

    I'm running Outlook as a standalone POP client without Exchange. I also get the pop-up message as soon as I click on the file to attach it. In other words, Outlook doesn't even try to attach the file. It just reads the size and tells me the attachment is over the limit.

    I'm running Symantec Endpoint Protection AV, but disabling that doesn't make a difference.

     

    I can't seem to find anything on this problem. Every time I come across what I think is a solution, it has to do with Exchange server (which I'm not using).

    Thursday, June 3, 2010 11:59 PM
  • I was able to effectively remove the limit by editing the registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences]

    and adding a new DWORD value:

    MaximumAttachmentSize

    and setting its value to 0

    That appears to have the effect of making the the size of attachments you select limitless.  Any other value, as far as I can tell, sets the size in Kbytes.

    • Proposed as answer by PocketSidewalk Tuesday, June 8, 2010 7:05 PM
    • Marked as answer by Sally Tang Wednesday, June 9, 2010 8:44 AM
    Tuesday, June 8, 2010 4:25 PM
  • Give this guy/girl some credit!!!  Awesome solution, file attachment limitation is GONE!!

    Thanks c.shea.qatester!!!

    Wednesday, June 9, 2010 7:44 PM
  • Thanks so much.  Works perfectly.
    Monday, June 14, 2010 8:15 PM
  • Please see related KB article on this topic at

    http://support.microsoft.com/default.aspx?scid=kb;en-US;2222370

    Friday, July 23, 2010 7:08 PM
  • I used FixIt and checked registry. Value seems to be 0 but error message still appears
    Friday, October 28, 2011 5:48 PM
  • I solve my problem with c.shea.qatester solution.

    Thank you!

    Friday, June 29, 2012 11:22 AM
  • Thanks a lot.

    Its worked for me....

    Monday, December 23, 2013 7:02 AM
  • I did the process advised here.

    I even tried to let the Microsft Fix-It man play, and he did not fix it.

    We have a POP3 server, no limitations set there.

    Just seems to be an issue here.

    I reset the Dword values in two locations to 0 when it comes to the allowable size limits, and that should have allowed unlimited.

    I even had the user reboot and died again.

    No luck.

    More ideas?

    Thanks

    Thursday, February 20, 2014 8:56 PM
  • Try setting it to a high value - like  102400  (for 100 MB)


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, February 20, 2014 9:45 PM
  • Try setting it to a high value - like  102400  (for 100 MB)


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    I just did RegEdit again, as suggested.

    Nothing

    Kind of perplexing, since this users has a notebook, same network, Outlook 2010, works fine!

    Friday, February 21, 2014 4:23 PM
  • I wonder if its something else, not Outlook, that is triggering the problems. what antivirus is installed on the affected computer? Does it work in Safe mode?



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Saturday, February 22, 2014 5:46 AM
  • I had the same problem where after I tried every step here in this post it still didnt work. What I ended up doing is:

    1. Closing outlook
    2. rename C:\Users\"user"\AppData\Local\Microsoft\Outlook\RoamCache to something else
    3. relaunch outlook 

    It seems as if the old rules were cached as as soon as this folder was missing it download the new rules and it worked. 

    Hope this helps


    • Proposed as answer by Jon Hazeleaf Thursday, April 17, 2014 9:47 PM
    • Edited by Jon Hazeleaf Thursday, April 17, 2014 9:49 PM error
    Thursday, April 17, 2014 9:47 PM
  • I was able to effectively remove the limit by editing the registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences]

    and adding a new DWORD value:

    MaximumAttachmentSize

    and setting its value to 0

    That appears to have the effect of making the the size of attachments you select limitless.  Any other value, as far as I can tell, sets the size in Kbytes.

    This worked for me!!!  Thanks!

    Friday, January 30, 2015 9:52 PM