none
Lync control Panel RRS feed

  • Question

  • Hi,

    I have successfully installed lync 2010 in my test environment,everything is working fine except the lync control panel when I try to open LCP via all programs it returns with the error 404 directory not found,tried browsing the cscp from IIS but got the similar error.

    I have tried unchecking the proxy as well,tried accessing it using https://server.domain.com/cscp.

    however iam able to manage the accounts via powershell.

    appreciate your help.

    Friday, December 28, 2012 10:47 AM

Answers

  • Hi

    Check the following:

    Did you configure a simple URL for the control panel?

    Is the DNS set up to point that url to the appropriate server?

    Did it prompt for a login?  Was the login you used a member of the CSAdministrator group?

    Are you able to login from another machine just using IIS/web url.


    /Tim

    • Marked as answer by Kent-Huang Wednesday, January 9, 2013 5:06 AM
    Friday, December 28, 2012 11:19 AM

All replies

  • Hi

    Check the following:

    Did you configure a simple URL for the control panel?

    Is the DNS set up to point that url to the appropriate server?

    Did it prompt for a login?  Was the login you used a member of the CSAdministrator group?

    Are you able to login from another machine just using IIS/web url.


    /Tim

    • Marked as answer by Kent-Huang Wednesday, January 9, 2013 5:06 AM
    Friday, December 28, 2012 11:19 AM
  • Thanks Tim,

    I havent configured the simple url for the control panel.

    Iam not getting to the login page when I type in https://server.domain.com/cscp. it returns with 404 directory not found error.

    No i cannot access it from any machine.

    Regards

    Friday, December 28, 2012 11:32 AM
  • Hi

    I'll test to use localhost instead of fqdn to see if that works from the Lync server.

    Also check in the topology builder and maybe change that simple url to the proper one.

    Also you could try using the ip if that works then you are missing the DNS name for the cscp.

     


    /Tim

    Friday, December 28, 2012 1:13 PM
  • Hi Tim,

    I tried with the localhost directly from IIS I get the webpage cannot be found or page cannot be displayed.

    I tried changing the simple url to admin.domain.com and created dns records for the same but doesnt like it.IP is not helping either.

    any settings i can try changing in IIS?

    Regards

    Monday, December 31, 2012 5:34 AM
  • Have you looked in IIS Manager and ensured that both web sites were created as part of the install?  There should be an internal and an external website in IIS on your front-end servers.  Inside the internal website you should see a virtual directory for CSCP.  Just something to double check.  Lastly, what happens if you simply go to https://localhost from the server itself?  You should get a certificate error and then a 403.14 - Forbidden error but at least we know the server is listening and serving up something.

    Thanks,

    Richard


    Richard Brynteson, Avtex, Lync MCM, Blog - www.masteringlync.com

    Monday, December 31, 2012 6:03 AM
  • Hi,

    Please try to install Silverlight and restart the front end server:

    http://www.microsoft.com/silverlight/

    Please go to Lync Topology Builder to check if the ports of internal web services are listened on 80 and 443, and check “Edit Bindings...” if it points to ports 80 and 443 in Internal Web site of IIS manager.


    Kent Huang
    TechNet Community Support

    Monday, December 31, 2012 6:37 AM
  • Hi,

    Yeah silver is already installed on the machine..and the ports are listening to 80 and 443 ,also checked edit bindings it is poiting to 80 and 443.

    not sure whats wrong,everything else works fine just the control panel.

    Regards

    Monday, December 31, 2012 7:10 AM
  • onething I have noticed if i try to browse localhost it returns to page cannot be displayed,how can I get this fixed please.
    Tuesday, January 1, 2013 4:40 AM
  • normal it is also possible to use https://server.domain.com/cscp as you tried.

    Did you try to open this website from another client and also add this web site to you local intranet on you security settings of the IE


    regards Holger Technical Specialist UC

    Tuesday, January 1, 2013 10:22 PM
  • Hi

    This is actually a test environment however yes tried adding the website to trusted sites but still doesnt work.

    Iam not going any further with this not sure what the next option will be.

    Wednesday, January 2, 2013 4:49 AM
  • You should try to analyze the logfiles from the IIS to see whats going on.

    If all other web services are runing for meetings, addressbook downloads etc.?

    maybe this thread will help?

    http://social.technet.microsoft.com/Forums/en-US/ocsplanningdeployment/thread/2bb584b7-ae5f-4eb0-a992-4175a3a9b5d9/


    regards Holger Technical Specialist UC

    • Proposed as answer by Kent-Huang Friday, January 4, 2013 8:43 AM
    • Marked as answer by Kent-Huang Friday, January 4, 2013 8:55 AM
    • Unmarked as answer by Mubashir4 Wednesday, January 9, 2013 8:37 AM
    Wednesday, January 2, 2013 1:25 PM
  • Iam sorry guys still not fixed,appreciate any further help on this please.
    Wednesday, January 9, 2013 8:38 AM
  • without doubt this sounds like routing issue from your DNS entry no being correct.

    so can you confirm your DNS entry looks like the following

    e.g.: 

    DNS A record

    admlync.northernlync.local = IP address of the lync pool or single frontend server.

    in the lync topology you have within the general administative path the following

    https://admlync.northernlync.local

    regards 

    Iain Smith

    www.northernlync.co.uk

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, January 12, 2013 4:18 PM
  • So if you open your website https://server.domain.com/cscp on a client IE, you recieve website not found (404)?

    Please check that your cscp webservice is created on the IIS and check the IIS log for some errors


    regards Holger Technical Specialist UC

    Saturday, January 12, 2013 6:05 PM