locked
Can't send mail from smartphones (android, iphone) larger than 2,5MB RRS feed

  • Question

  • This is Exchange 2010 DAG. I can send mail with attachment with 3-10mb from outlook client (MS office outlook 2010) or from OWA, but from smartphone (iphone, android) can't from same mailbox. When I send from iphone4 got error: "An error occured while delivering this message"; and mail stuck in Outbox.

    All exchange configuration let send mail larger than 3mb:

    [PS] C:\Windows\system32>Get-TransportConfig | ft MaxSendSize, MaxReceiveSize
    MaxSendSize                                                 MaxReceiveSize
    -----------                                                 --------------
    30 MB (31,457,280 bytes)                                    30 MB (31,457,280 bytes)

    [PS] C:\Windows\system32>Get-ReceiveConnector | ft name, MaxMessageSize
    Name                                                        MaxMessageSize
    ----                                                        --------------
    Default xxxx1                                              30 MB (31,457,280 bytes)
    Client xxxx1                                           10 MB (10,485,760 bytes)
    Default xxxx2                                         30 MB (31,457,280 bytes)
    Client xxxx2                                               10 MB (10,485,760 bytes)
    SMTP relay1                                             30 MB (31,457,280 bytes)
    SMTP relay1                                              30 MB (31,457,280 bytes)
    SMTP soft                                                 10 MB (10,485,760 bytes)
    SMTP soft                                                 10 MB (10,485,760 bytes)


    [PS] C:\Windows\system32>Get-SendConnector | ft name, MaxMessageSize
    Name                                                        MaxMessageSize
    ----                                                        --------------
    To Internet                                                 30 MB (31,457,280 bytes)

    [PS] C:\Windows\system32>Get-mailbox | ft Name, MaxSendSize, MaxReceiveSize

    all mailboxes -> unlimited

    Where can be a problem?  

    Thursday, June 13, 2013 6:23 AM

All replies

  • Hi,Have you evaluated the result of following cmdlet too?

    Get-ActiveSyncMailboxPolicy |fl *size*


    Regards from ExchangeOnline | Windows Administrator's Area

    Thursday, June 13, 2013 6:38 AM
  • Hi AKA12345,

    By default in exchange active sync policy there is no limit but you can try below script or you can modify script as per your requirement.

    Get-ActiveSyncMailboxPolicy |fl *size*

    Set-ActiveSyncMailboxPolicy -Identity MyPolicy -AllowNonProvisionableDevices $true -AllowSimpleDevicePassword $true -AlphanumericDevicePasswordRequired $true -AttachmentsEnabled $true -DeviceEncryptionEnabled $false -DevicePasswordEnabled $true -DevicePasswordExpiration 12 -DevicePasswordHistory 20 -DevicePolicyRefreshInterval 00:60:00 -MaxAttachmentSize 4 -MaxDevicePasswordFailedAttempts 5 -MaxInactivityTimeDeviceLock 00:15:00 -MinDevicePasswordLength 4 -PasswordRecoveryEnabled $true -UNCAccessEnabled $false -WSSAccessEnabled $false

    Reference: http://technet.microsoft.com/en-us/library/bb123484(v=exchg.141).aspx

    http://technet.microsoft.com/en-us/library/bb123994(v=exchg.141).aspx

     


    regards Sameer Shaikh

    Thursday, June 13, 2013 12:58 PM
  • Default policy options:

    [PS] C:\Windows\system32>Get-ActiveSyncMailboxPolicy |fl *size

    MaxAttachmentSize              : unlimited
    MaxEmailBodyTruncationSize     : unlimited
    MaxEmailHTMLBodyTruncationSize : unlimited

    • Edited by aka12345 Monday, June 17, 2013 7:45 AM
    Monday, June 17, 2013 7:08 AM
  • I created new policy and disabled old "default". New policy options:

    MaxAttachmentSize              : 20 MB (20,971,520 bytes)
    MaxEmailBodyTruncationSize     : 20480
    MaxEmailHTMLBodyTruncationSize : unlimited

    but same problem, mail hung up in smartphone outbox. looks like exchange 2010 bug?

    Monday, June 17, 2013 7:39 AM
  • Hi, do you see in your event log the event id 1008?

    check also the configuration in Microsoft\Exchange Server\V14\ClientAccess\Sync\web.config

    maxRequestLength and MaxDocumentDataSize

    • Edited by SSorin Monday, June 17, 2013 11:30 AM
    Monday, June 17, 2013 9:32 AM
  • web.config -> 

    <httpRuntime maxRequestLength="10240"/>    <---- if this is KB, then it means 10mb

    and

    <add key="MaxDocumentDataSize" value="10240000"></add>   <------if this is bytes,then it means ~10mb too

    And yes i have warning with ID 1008:

    An exception occurred and was handled by Exchange ActiveSync. This may have been caused by an outdated or corrupted Exchange ActiveSync device partnership. This can occur if a user tries to modify the same item from multiple computers. If this is the case, Exchange ActiveSync will re-create the partnership with the device. Items will be updated at the next synchronization. 



    • Edited by aka12345 Monday, June 17, 2013 1:02 PM
    Monday, June 17, 2013 1:01 PM
  • make a copy of the file change the values 20MB for both and restart iis

    Monday, June 17, 2013 1:43 PM
  • Hi

    In EMC if you go to Organizational configuration --> Exchange Active Sync Mailbox Policies

    Go to the properties of the policy then to the Sync Settings Tab

    Check the "Allow Attachments to be downloaded to device" is enabled along with the attachment size

    Monday, June 17, 2013 3:12 PM
  • I checked these settings already - "Allow Attachments to be downloaded to device" is enabled. 
    Tuesday, June 18, 2013 5:21 AM
  • make a copy of the file change the values 20MB for both and restart iis

    Ok I will try do this this evening. 
    Tuesday, June 18, 2013 5:23 AM
  • make a copy of the file change the values 20MB for both and restart iis

    Ok I will try do this this evening. 

    edited web.config to: 

    <httpRuntime maxRequestLength=" 20480"/>    

    and

    <add key="MaxDocumentDataSize" value="20971520"></add>   

    and did iisreset, but same problem... 


    • Edited by aka12345 Wednesday, June 19, 2013 5:29 PM nothing
    Wednesday, June 19, 2013 5:28 PM
  • So I decided that this is Exchange bug and we can't do anything...
    Thursday, June 27, 2013 11:31 AM
  • I changed the value of maxRequestLength to "30720" (kylobytes), which is aproximately the same as the maxAllowedContentLength parameter (30000000 bytes as default), which I kept unchanged, in web.config of all CAS servers.

    Next a made the same change to the web.config of all mailbox servers, but changed also the parameter MaxDocumentDataSize, to the value of 30720000 (bytes). This way all parameters have almost the same magnitude (~29 MB).

    Worked fine for me. No need to restart any service (neither the IIS itself).

    A mail that was stuck in outbox, which had a 8MB attachment, was sent successfully.

    Regards.

    Tuesday, August 29, 2017 2:48 PM