1628: Failed to complete installation - Microsoft Flight Simulator X - Win 7 64 RRS feed

  • Question

  • - I insert DVD and proceed to install "Flight Simulator X - Deluxe Edition"
    - DVD spins and installation starts, its starts to prepare installation
    - Then it gets stuck and I get an error: "1628: Failed to complete installation"
    - I tried compatibility mode with XP and Vista, but nothing.
    - I tied running all installer files as administrator, but nothing.

    The game will not install in Windows 7 RC 64-bit

     A brief description of my system:
    - ASUS P6T V2 deluxe motherboard
    - 6 GB triple channel RAM
    - Intel 920 i7 1366 CPU
    - SATA HDD
    - USB DVD drive
    - Dual EVGA nvidia 9800 GT OC in SLI

    FSX installs fine in Windows XP and Vista (32 bit), this is the first time I try on a 64 bit OS.

    I have read people running this in Windows 7 so I am puzzled. I appreciate any advice and comments.
    • Edited by KidBomba Monday, August 3, 2009 5:27 AM
    Monday, August 3, 2009 5:25 AM


All replies

  • Hi,

    I think the issues might be with the 64 bit version.

    I found this other post on Flight Simulator X on Windows 7:

    Also, the Windows Vista Compatibility center says Flight Simulator X is compatible for the 32 bit version, but doesn't mention the 64 bit version.

    Wednesday, August 5, 2009 1:19 AM
  • According to this link, Microsoft Flight Simulator X is compatible with Vista 64


    Reason why I find the error above strange.

    As on the thread, I see that ppl have it working. My error happens right at the install, when it prepares for installation.
    Thursday, August 6, 2009 1:41 PM
  • I had a similair problem. I can't remember excactly how I solved the problem.

    Where does it fails ?
    Is it when it tried to install DirectX 9?
    Is is when it stall MS VS 2005 Redistributable ?

    (I assume you don't get to that point as this will be in the 2nd disk)

    Are you running EPU 6 (I found that causes trouble) with win 7 and the ASUS P6T Deluxe V2. ?

    Do you any thing in the Event log ?
    Is ona fresh install ? (Do you install it righ after W7, before any other apps?)
    Try the action center, you might find a solution there.

    • Edited by tgs1970 Thursday, August 6, 2009 2:15 PM
    Thursday, August 6, 2009 1:55 PM
  • here is solution I used:

    Let me know if it works.
    • Marked as answer by Nicholas Li Friday, August 7, 2009 10:01 AM
    Thursday, August 6, 2009 2:18 PM
  • Hello tgs1970,

    Here is a screenshot sequence of the error:

    I will try the solution link (http://support.microsoft.com/default.aspx/kb/910816) you provided, but for some reason it says:

    "Server is too busy"

    This is the first time I see this from a microsoft KB! I will try again later, hopefully its temporary.

    I will post any results! thanks so much guys :)

    Edit: Bizarrely, I discovered a new issue with IE8, "Server is too busy" only happens in IE8 and not in Firefox..."puzzled" :S
    Friday, August 7, 2009 1:57 AM
  • Confirmed!

    http://support.microsoft.com/default.aspx/kb/910816 is the solution.

    I did method 2 thinking it would be quicker, I selected to install Installshield for 64 bit:
    Windows6.0-KB942288-v2-x64.msu but I got some wierd operating system error window.

    Method 1 fixed the issue. My installshield folder was in the C:\Program Files (x86)\Common Files\InstallShield location so I just renamed it to: C:\Program Files (x86)\Common Files\InstallShield1

    I ran the game and it installed installshield I guess since now I have a new C:\Program Files (x86)\Common Files\InstallShield\

    Thanks a bunch TGS!
    Friday, August 7, 2009 2:07 AM
  • Hello,

    I've got the same 1628 error here on my Windows 7 Ultimate x64.

    I have tried everything what they said on http://support.microsoft.com/default.aspx/kb/910816

    But I still have this problem, when I tried the first method the installations doenst show anything bit i can see in the taskmanager the proces ''IDriver.exe'' is still running. When I end this proces I got the 1628 error again.

    My PC is:

    Intel Core 2 Quad Q9550 @ 3.6ghz (1.3125 V)
    KINGSTON HYBER-X RAM DDR2 1066 mhz (6144mb)
    EVGA GeForce GTX 470 SuperClocked 1280MB (750/1500/1800)
    CORSAIR 750HX 
    SAMSUNG Spinpoint F1 HD103UJ 1TB 7200 RPM 32MB
    SAMSUNG EcoGreen F2 HD154UI 1.5TB 5400 RPM 32MB
    LG Optical BluRay
    LG Optical DVR 22X DL,IDE
    Cooler Master 690
    Cooler Master V8 CPU Cooler



    Monday, January 31, 2011 1:17 PM
  • Hello, Hopefully this helps...

    I had this problem and it was doing my head in.I couldnt play FSX and i had orderd Saitek Pannels for FSX for christmas and i was getting worried.Im on Windows 8 and this is how i fixed it.

    I tried to Uninstall FSX and it never done anything.I tried constant and then the trobleshooter came up.If you press that it didn't uninstall properlly and then hit fix compatibility problems or something like that it should work fine.Just then hit uninstall and when the menu comes up hit repair and make sure your FSX DISK 1 is in :).

    Hoped this helped :) - Fsx Pro! 

    Thursday, December 6, 2012 9:32 AM
  • @FSX Pro XI - What if you don't have it installed to begin with. I have win8 x64 and I keep getting the 1628 error even though I've tried all the methods listed in the above suggestions and nothing is working. Any other idea's or suggestions?
    Tuesday, December 11, 2012 12:25 AM
  • Hi,

    I am having the same problem. Have you had any success with solving the error.

    I have called microsoft about this, and they are as useless as tits on a bull.

    Please if you get a solution could you share with me.

    Warm regards.

    Friday, December 14, 2012 6:43 PM
  •  I've had this problems many times, mainly because I do a lot of installs/uninstalls with other games. But the answer to everybody is that you need to give(sometimes Windows 7)Windows 8 the admin approval of the app/game. Here is a link for a better understanding:


    But all you have to do is get a Command Prompt running by an admin(even if you are already admin, u need to do it). Then  type "net user administrator /active:yes" in the cmd(command prompt). Then suddenly after it finishes, run FSX or what ever u are installing the has this error.

    If u have questions or if it doesn't work contact me:

    E-mail: mdmpilot@Hotmail.com

    Wednesday, December 4, 2013 6:51 AM
  • I had the same issue with AOE3 on Windows 8.1 and was able to fix it.

    Once you insert the disk into your computer, you'll have to browse to your disc drive. Right click and click either 'open' or 'explore' depending on your OS.

    Next, find Setup.exe. Right click on the application, go to 'Properties', click on the 'Compatibility' tab.

    Check the box that says 'Compatibility Mode' and change it to 'Windows Vista (Service Pack 1).

    After you've completed that step, hit 'Apply' and then close the window.

    Finally, right click on the Setup.exe application again and select 'Run As Administrator'.

    At this point, the setup should proceed normally.


    Friday, July 11, 2014 5:20 PM
  • Thanks. I was trying to install FSX on Windows 10 (64) and got this error message:

    1628: Failed to complete installation - Microsoft Flight Simulator X.

    Changed the compatibility mode and worked well.


    Tuesday, July 28, 2015 6:34 PM