none
PST Import to Public Folder only partially completes RRS feed

  • Question

  • I'm helping a customer with a public folder issue.

    I'm trying to import some restored data in the form of PSTs into their PF tree.  However, some of the folders have several thousand items and when I import I am only getting roughly 500 items.  In one specific example, the sub-folder in question has 7000+ items.  After the initial import, the folder had 500 items in it.  I re-imported (using the overwrite duplicates option) and the folder had 634 items in it.  I decided to re-import using the skip duplicates option and had 1,141.  Tried again and got 1,648 items.  Rinse and repeat and I have 2,155 items, etc.  Each time I re-import that sub-folder I have an additional 507 items.

    The import is being done in Outlook 2013 to an Exchange 2010 server.  I'm fairly certain this issue is client side (Outlook) but I'm not sure how to confirm this.  The fact that each import with the "skip duplicates" option results in an additional 507 items makes me think there is a bug in Outlook 2013 at play.

    Has anyone seen similar behaviour?  Anyone have a suggestion for how to work around this?  My Google-Fu is failing to produce any meaningful results.

    Thanks in advance!

    Some Background

    The customer had an issue where they lost their public folder data (to a degree).  A colleague worked the issue and, in the end, used a third-party utility to extract the contents of a backup of the PF EDB file into PSTs and imported those.  Days go by as the customer is adding new messages into the restored public folder tree.  Then they noticed that some of the messages have weird symbols (an encoding issue), some attachments (mostly scanned PDFs) are corrupt and some email addresses have extra leading characters in them.

    I narrowed the issue down to the third-party tool which seemed to not do a great job converting the data.  I have since exported the PF's from a backup to PST using the new feature in Backup Exec 2012 to allow this.  The PSTs open fine and I can see all the messages in them and all the encoding, attachment and email address issues are absent in these PSTs so things are looking good except for this import issue.

    Note that the export to PST from backup is being done with Backup Exec 2012 with Outlook 2010 (32-bit) installed on the media server.

    Monday, April 14, 2014 12:12 PM

Answers