Getting error that the converter failed to save the file RRS feed

  • Question

  • From a document library I click on "Edit in Microsoft Excel (or Word) and the application is not open I get the error "The converter failed to to save the file".  It never opens the application and I'm returned to the document library.  If I already have the application it doesn't generate the error.  I'm running Office 2007

    • Moved by Mike Walsh FIN Thursday, July 9, 2009 3:32 PM admin q (From:SharePoint - Development and Programming)
    Thursday, July 9, 2009 3:19 PM


All replies

  • Asking about why something happens when you use standard functionality.

    That is not prorgramming - moving to Admin.
    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, July 9, 2009 3:31 PM
  • I get the exact same error message when I try to edit a particular Excel document in one of my document libraries.  
    As far as I can tell, there is no solution to this issue besides making sure that Excel is already open?  Anyone else have any tips on how to fix this issue?
    Tuesday, October 27, 2009 5:17 PM
  • I had the same issue.  When I installed Office Compatibility Pack SP1, the problem was resolved.  Update the Windows Installer first if you don't have the latest version.


    They released SP2 in April.

    Thursday, December 10, 2009 9:46 PM
  • Is the "Require documents to be checked out before they can edited" set to Yes for this document library?


    Sarbjit Gill
    Friday, August 6, 2010 3:10 AM
  • J.W.1 hits on the correct solution, it sounds like a compatibility issue with older versions of Excel.
    Friday, August 6, 2010 11:26 AM
  • I have a user with that issue now. Win 7 / MOSS 2007 / Office 2007. SP2 version of the Office Compatibility Pack is already in place.

    Still investigating. Could have an answer later.


    Sarbjit Gill
    Saturday, August 7, 2010 12:21 AM
  • I am having this same issue with one computer.  This is not user related, anyone logged into this machine has the same effect.  All Office 2007, Compatability Pack, Windows Updates are all up to date.  I ran the Office 2007 diagnostics tool, nothing found. 
    Wednesday, September 8, 2010 12:38 AM
  • Additionally, IE has been updated and the SharePoint intrranet site has been set as the "Local Intranet".
    Wednesday, September 8, 2010 12:39 AM
  • In my case giving additiona permission (actuall full control) to the user solved the issue.

    so for few of use the compatibility pack  only wasn't the answer. maybe it has got to do with permission and the pack.



    Sarbjit Gill
    Wednesday, September 8, 2010 4:04 AM
  • My problem was resolved after running the Microsoft Office Diganostics Tool (found in Start/Programs/Microsoft Office/Tools/)
    • Proposed as answer by eliu36 Tuesday, March 6, 2012 2:53 AM
    Tuesday, September 14, 2010 6:37 PM
  • Following up on my last.  The problem returned about once a week, it seemed just after patch Tuesday.  The 2007 compatability tool would run and create all sorts of strange behavior.  Then it dawned on me: The 2007 compatability tool is needed only for those on Office 2003.  This computer was on 2003 and recently upgraded to 2007.  For some reason when launching Excel from SharePoint would run the tool.  I removed the 2007 Compatability tool and now everything work as required. 
    • Marked as answer by Mike Walsh FIN Wednesday, November 17, 2010 7:42 PM
    Thursday, September 23, 2010 8:13 PM
  • I suddenly had this problem with all my files in every document library of the Microsoft persusasion, I am assuming that this is down to the site administrator changing the settings unwittingly.

    I chose check out, and then edit and checked use my local drafts folder - this then saves a temporary file in your SharePoint drafts folder (Use the search facility as I have no idea where it is actually stored, probably in your local user files though)  You have to open the file manually, but when you close the file it will prompt you to check it back in to the server.

    Not ideal, and not a real solution; but it is a work around.

    Wednesday, November 17, 2010 7:25 PM
  • This did it. I ran the diagnostics tool as stated above, it said it fixed one error that may improve performance. And then I went to Skydrive and it worked.
    Tuesday, March 6, 2012 2:54 AM
  • Ran the diagnostic tool and it worked.

    the compatibility packs did not do the job


    Monday, October 13, 2014 10:06 AM