locked
Exchange 2007 logs not deleting RRS feed

  • Question

  • I have an exchange 2007 SP2 (just updated) that will not delete logs after full backup. I've tried with Backup exec 12.5 and windows backup on the exchange server. No mater what programs I use they will not delete them.

    That is why I updated to the latest sp just to make sure I've covered all my bases.

    About 6 months ago I tested SCR with another backup machine, but I deleted the SCR and the other server as required by MS. I ran status script to see if there was any replication and it came back with none.

    I've searched it now for days and can't come up with a solution.
    Monday, September 28, 2009 6:41 PM

Answers

  • Hi,

     

    From the command output, looks like that the SCR has been disabled. Nevertheless, I suggest you double check following attribute to ensure the SCR is not enabled:

     

    In ADSIEdit, go to the properties of the Storage Group that will not truncate logs.

     

    CN=Configuration\CN=Services\CN=Microsoft Exchange\CN=<org name>\CN=Administrative Groups\CN=Exchange Administrative Group (FYDIBOHF23SPDLT)\CN=Servers\CN=<Servername>\CN=InformationStore\CN=<Storage Group Name>

     

    Scroll down to the attribute msExchStandbyCopyMachines

     

    Note if this attribute is populated with a value that corresponds to the old SCR target machine name. Edit the value, and clear out the non-existent machine name. Then, please perform Full Backup of the Storage Group again.

     

    If the  msExchStandbyCopyMachines attribute is empty, please also ensure the File-Level anti-virus software is configured correctly according to following article:

     

    File-Level Antivirus Scanning on Exchange 2007

    http://technet.microsoft.com/en-us/library/bb332342.aspx

     

    Mike Shen,

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    • Marked as answer by pltfla Wednesday, September 30, 2009 4:59 PM
    Wednesday, September 30, 2009 2:29 AM

All replies

  • Is this mailbox part of a CCR architecture?

    Could you please provide some more details around the environment? 

    Have you tried using ESE util to see what logs have been comitted?


    SF - MCITP:EMA, MCTS: MOSS 2007, OCS 2007, Exchange 2007
    Monday, September 28, 2009 7:43 PM
  • >No, not part of any CCR.

    >Windows server 2003 sp2 enterprise - exchange 2007 enterprise sp2 - no remote servers, all on one machine -

    >Yes, many times, I even deleted all the committed files at one time.
    Monday, September 28, 2009 7:54 PM
  • If log truncation is failing, there will errors in the event logs. Please post the exact errors here.
    What are you selecting to backup? You must choose the entire information store or by storage group.

    Also, run ExBpa against this server for a health check.
    Monday, September 28, 2009 8:53 PM
  • In addition to Andy, would you please let me know whether the issue occurs since testing SCR replication or the issue occurs recently? Would you please run get-storagegroupcopystatus and post result here?


    Mike Shen,

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     

    Tuesday, September 29, 2009 8:19 AM
  • Please make sure Storage Group is selected and Backup type is set to Normal backup.
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Tuesday, September 29, 2009 9:47 AM
  • I'm embarrassed to say if it has been going on that long, but it is possible.

    [PS] C:\Documents and Settings\adwpimin>get-storagegroupcopystatus

    Name                      SummaryCopyStatus        CopyQueueLength         ReplayQueueLength       LastInspectedLogTime
    ----                      -----------------        ---------------         -----------------       --------------------
    First Storage Group       Disabled                 0                       0
    Second Storage Group      Disabled                 0                       0

    I will followup with the logs shortly

    Thanks for the help
    Tuesday, September 29, 2009 11:36 AM
  • This seems to be the area in the log files. From the search results it looks like it is connected to the SCR, Which I have removed.

    1> MSExchangeIS (4060) First Storage Group: No log files can be truncated.

    2 > Exchange VSS Writer (instance a81638d8-fac3-45ce-b467-eba7c505b90c:1) has successfully completed the full or incremental backup of replicated storage group 'First Storage Group'. The log files will be truncated after they have been replayed

    Tuesday, September 29, 2009 12:09 PM
  • Here is the print out of the eseutil /mn if it would be helpful.



    [PS] C:\Documents and Settings\adwpimin>eseutil /mh "F:\ExchangeDB\Mailbox Database.edb"

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.02
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: F:\ExchangeDB\Mailbox Database.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,12
     Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
         DB Signature: Create time:10/28/2008 08:41:52 Rand:3635382 Computer:
             cbDbPage: 8192
               dbtime: 402389265 (0x17fbf911)
                State: Clean Shutdown
         Log Required: 0-0 (0x0-0x0)
        Log Committed: 0-0 (0x0-0x0)
       Streaming File: No
             Shadowed: Yes
           Last Objid: 381272
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 0
          Repair Date: 00/00/1900 00:00:00
     Old Repair Count: 0
      Last Consistent: (0x1742,656,6A)  09/29/2009 07:38:25
          Last Attach: (0x1741,9,86)  09/29/2009 07:33:34
          Last Detach: (0x1742,656,6A)  09/29/2009 07:38:25
                 Dbid: 1
        Log Signature: Create time:09/17/2009 11:38:59 Rand:12211694 Computer:
           OS Version: (5.2.3790 SP 2 NLS 1.1)

    Previous Full Backup:
            Log Gen: 5813-5828 (0x16b5-0x16c4) - OSSnapshot
               Mark: (0x16C5,8,16)
               Mark: 09/28/2009 19:00:18

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none
    Tuesday, September 29, 2009 12:38 PM
  • Hi,

     

    From the command output, looks like that the SCR has been disabled. Nevertheless, I suggest you double check following attribute to ensure the SCR is not enabled:

     

    In ADSIEdit, go to the properties of the Storage Group that will not truncate logs.

     

    CN=Configuration\CN=Services\CN=Microsoft Exchange\CN=<org name>\CN=Administrative Groups\CN=Exchange Administrative Group (FYDIBOHF23SPDLT)\CN=Servers\CN=<Servername>\CN=InformationStore\CN=<Storage Group Name>

     

    Scroll down to the attribute msExchStandbyCopyMachines

     

    Note if this attribute is populated with a value that corresponds to the old SCR target machine name. Edit the value, and clear out the non-existent machine name. Then, please perform Full Backup of the Storage Group again.

     

    If the  msExchStandbyCopyMachines attribute is empty, please also ensure the File-Level anti-virus software is configured correctly according to following article:

     

    File-Level Antivirus Scanning on Exchange 2007

    http://technet.microsoft.com/en-us/library/bb332342.aspx

     

    Mike Shen,

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    • Marked as answer by pltfla Wednesday, September 30, 2009 4:59 PM
    Wednesday, September 30, 2009 2:29 AM
  • Mike... YOU ARE DA MAN !!!

    It was in the AD, referencing the target server. The backup deleted the old logs.

    Thank you very much, this has been an issue for quite awhile.

    Phil
    Wednesday, September 30, 2009 5:01 PM