none
Server 2012 set session timeout per user

    Question

  • I have configured collection session limit to "never" in all 3 options but set user session limit for 5 minutes to test in AD.  the user's connection does  not end.   What am I missing?  thank you
    Thursday, October 2, 2014 7:22 PM

Answers

  • Thank you for the explanation.   So I finally got it to work. 

    1) created a Domain Local / Security Group

    2)on RDS server left Collection Session as Never and Disconnect and Default User Session Profile

    3)GPO under Domains - Edit Computer and User Configuration Session Time Limits

    4)Specified new group in Security Filtering.

    Thank you

    • Marked as answer by natcam265 Monday, October 6, 2014 11:45 PM
    Monday, October 6, 2014 11:45 PM

All replies

  • Hi,

    Thank you for posting in Windows Server Forum.

     Have you set any GPO setting for session time limit for your users?
    Please check the setting as follow.
    You can also configure timeout and reconnection settings by applying the following Group Policy settings, you can check the figure 3 for graphical view.
    -  Set time limit for disconnected sessions
    -  Set time limit for active but idle Remote Desktop Services sessions
    -  Set time limit for active Remote Desktop Services sessions
    -  End session when time limits are reached

    These Group Policy settings are located in the following locations:
    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    TechNet Community Support

    Friday, October 3, 2014 6:59 AM
    Moderator
  • Thank you.

    I have created an OU and a group within.  created a GPO to end session and added group to Security Filtering.   my policy is set to disconnect after 2 hours, disconnect idle after 3 hours and end session after time has expired.

    the user's idle time keeps climbing even after disconnecting after 2 hours.

    the only way it works is when I set the collection properties to end the session - but I don't want to end the session if connection is broken - only if session is reached.

    is that possible?

    Friday, October 3, 2014 8:48 PM
  • Hi,

    Thank you for posting in Windows Server Forum.

    The policy for session limit is reached or connection is broken is same. 

    - Specify whether to disconnect or end the user's Remote Desktop Services session when an active session limit or an idle session limit is reached.
    - If the user's session is disconnected, the programs that the user is running are kept active even though the user is no longer actively connected.
    - If the user's session is ended, the user will need to establish a new Remote Desktop Services session with an RD Session Host server.

    So if we set that policy as per above description it will act according to that functionality.

    More information.
    Configure Timeout and Reconnection Settings for Remote Desktop Services Sessions
    http://technet.microsoft.com/en-us/library/cc754272.aspx

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    TechNet Community Support

    Monday, October 6, 2014 2:09 AM
    Moderator
  • Thank you for the explanation.   So I finally got it to work. 

    1) created a Domain Local / Security Group

    2)on RDS server left Collection Session as Never and Disconnect and Default User Session Profile

    3)GPO under Domains - Edit Computer and User Configuration Session Time Limits

    4)Specified new group in Security Filtering.

    Thank you

    • Marked as answer by natcam265 Monday, October 6, 2014 11:45 PM
    Monday, October 6, 2014 11:45 PM