none
Why is Outlook 2010 eating my deleted emails? How can I make it stop?

    Question

  • Hi there,

    Outlook 2010 is automatically permanently deleting my POP emails when I hit the Delete button. How can I get this to stop? First, the option to automatically delete emails upon exiting Outlook is NOT checked, and second, the emails disappear IMMEDIATELY when I click Delete and never make it to the Deleted folder. While I know I can Undo to recover an email I've just deleted, that's no use if I'm trying to recover a previously deleted email. I prefer to kill my deleted emails manually. What am I doing wrong? Is this because I'm using the trial version or is this a new 'feature'?

    Thanks in advance for any words of wisdom.

    Tuesday, September 14, 2010 11:00 PM

Answers

  • In this case, you have a view set to hide read items.  You can start Outlook 1 time with the /cleanviews command line switch.  I will warn you that this will delete all custom views and reset the built-in views back to Microsoft defaults.
     

    Hi again Steven,

    I'll try your suggestion, but in the meantime here's another interesting tidbit. I generally read my emails in the preview pane and had them set to be marked as read as soon as they are selected. I changed that setting to not mark emails as read and sent myself a test email which I then deleted. Voila! The email went into the Deleted folder and didn't disappear. So whatever is causing this, it has to do with the email being considered 'read' and deleted for Outlook to find them so tasty.

    I'll give your suggestion a go and let you know what happens.

    Thanks much,

    Robina

    Tuesday, September 21, 2010 10:56 AM

All replies

  • You didn't mention how many POP3 accounts you have, so I will make an assumption that you have more that one PST file in your profile.  Each PST file will have its own Deleted Items folder.  Perhaps you will find your items in one of those secondary Deleted Items folder.
     

    Hi there,

    Outlook 2010 is automatically permanently deleting my POP emails when I hit the Delete button. How can I get this to stop? First, the option to automatically delete emails upon exiting Outlook is NOT checked, and second, the emails disappear IMMEDIATELY when I click Delete and never make it to the Deleted folder. While I know I can Undo to recover an email I've just deleted, that's no use if I'm trying to recover a previously deleted email. I prefer to kill my deleted emails manually. What am I doing wrong? Is this because I'm using the trial version or is this a new 'feature'?

    Thanks in advance for any words of wisdom.

    Wednesday, September 15, 2010 9:46 AM
  • Hi Steven,

     

    Thanks so much for your excellent suggestion. I do have multiple POP3 accounts and so I thought for a moment that maybe this really was the answer, but alas, no. I've checked each of the individual Deleted folders and nothing's there. Deleted emails sent through my Gmail account go into the trash as anticipated, but none of the POP3's. In setting up Outlook 2010 I did import my Outlook 2007 pst files. I'm wondering if in my set up I inadvertently hooped something?

     

    Thanks again.

    Wednesday, September 15, 2010 5:29 PM
  • Odd. I can't image in import of data from previous PST files to be the cause of this, so lets try some steps in order.
     
    1) Does this happen if you start Outlook in safe mode?
    How to:
    Start | Run
    Type: outlook.exe /safe
    OK button
     
    2) I would try creating a new mail profile (don't copy the existing) with just two POP3 accounts and see if the issue continues.  If it doesn't then add the next and test again.
     
     

    Hi Steven,

     

    Thanks so much for your excellent suggestion. I do have multiple POP3 accounts and so I thought for a moment that maybe this really was the answer, but alas, no. I've checked each of the individual Deleted folders and nothing's there. Deleted emails sent through my Gmail account go into the trash as anticipated, but none of the POP3's. In setting up Outlook 2010 I did import my Outlook 2007 pst files. I'm wondering if in my set up I inadvertently hooped something?

     

    Thanks again.

    Thursday, September 16, 2010 11:45 AM
  • Hi again Steven,

    I'll try your suggestion, but in the meantime here's another interesting tidbit. I generally read my emails in the preview pane and had them set to be marked as read as soon as they are selected. I changed that setting to not mark emails as read and sent myself a test email which I then deleted. Voila! The email went into the Deleted folder and didn't disappear. So whatever is causing this, it has to do with the email being considered 'read' and deleted for Outlook to find them so tasty.

    I'll give your suggestion a go and let you know what happens.

    Thanks much,

    Robina

    Friday, September 17, 2010 4:38 PM
  • In this case, you have a view set to hide read items.  You can start Outlook 1 time with the /cleanviews command line switch.  I will warn you that this will delete all custom views and reset the built-in views back to Microsoft defaults.
     

    Hi again Steven,

    I'll try your suggestion, but in the meantime here's another interesting tidbit. I generally read my emails in the preview pane and had them set to be marked as read as soon as they are selected. I changed that setting to not mark emails as read and sent myself a test email which I then deleted. Voila! The email went into the Deleted folder and didn't disappear. So whatever is causing this, it has to do with the email being considered 'read' and deleted for Outlook to find them so tasty.

    I'll give your suggestion a go and let you know what happens.

    Thanks much,

    Robina

    Tuesday, September 21, 2010 10:56 AM
  • I have also just found that my emails disappear when deleting from the inbox, I haven't set any specific views so not sure the above answer will solve my problem?
    Tuesday, May 21, 2013 6:07 PM