none
SSRS 2016 Shared Dataset deployment issue RRS feed

  • Question

  • Has anyone successfully deployed a shared data set to SSRS 2016? I consistently get:

    Error rsProcessingError : The shared dataset definition is not valid.  Details: The required attribute 'Name' is missing.

    The 'Name' is set on the shared data set (it won't let you close the window without it). And it's not an error with my query, because it occurs on the simplest of queries:

    SELECT 1 AS Test

    I'm using VS Enterprise 14.0.25123.00 Update 2, DataTools 14.0.60525.0, and Reporting Services 13.0.1601.5.

    Wednesday, June 15, 2016 3:24 PM

All replies

  • Same issue here, did you got it solved??
    Wednesday, June 15, 2016 10:43 PM
  • Same issue...

    But, when create dataset embedded in some report, and after convert this dataset to shared dataset, it works ...

    • Proposed as answer by Madhan Raghu Tuesday, June 21, 2016 6:09 AM
    Thursday, June 16, 2016 12:11 PM
  • There's a thread elsewhere saying that it's a known bug and fixed in the next version of SSDT due sometime in July.

    In the meantime you can edit the .RSD file, find the DataSet element and give it an attribute of Name="". That should allow you to deploy.

    Here's that other thread.

    • Edited by KevinDahl Thursday, June 16, 2016 1:48 PM
    Thursday, June 16, 2016 1:45 PM
  • I have this issue as well.  I reported it as a bug on Microsoft Connect a week or so ago.  It worked fine for me on all of the RC builds, but not since we upgraded to the public release.
    Tuesday, June 21, 2016 4:13 AM
  • Funny I just checked my Connect submission and they haven't responded.  Where did you see that they announced it was a known bug?
    Tuesday, June 21, 2016 4:15 AM
  • I'm not sure there was an announcement about it. One of the questions it has brought up is why the empty XML attribute was a dependency in the first place?

    The temporary workaround is in the thread Kevin posted but I just posted to your connect submission also.

    Cheers!

    Tuesday, June 21, 2016 3:06 PM
  • And, for sloppy noobs like myself - "Name" is case-sensitive.
    Thursday, April 20, 2017 2:16 PM